Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Fire Stick TV don't play anything from a remote server

I'm trying the plex player in Amazon Fire Stick TV but I was not able to play any remote media.

I tried to change remote resolution settings without success. I also tried to disable AC3 check, but it has no effect.

I'm able to browse the remote server select a title and select play but the app stucks for a few seconds on the playback screen and then the fallowing error message is shown:

"playback has stopped because the connection to the Plex Media Server has been lost. Please ensure the server is available and retry."

I know that the problem is not the server because I'm able to play those media from the same remote server in my phone, pc browser and even in a web browser app in the same Fire TV stick device. but when i switch to the Plex app I'm not able to play media.

Answers

  • andyshortandyshort Posts: 2Members, Plex Pass Plex Pass

    Are you connecting to your plex server over a secure connection? What you describe happens to me if I use a secure connection. The only way I can get it to work is by changing the 'Allow fallback to insecure connection' option from never to either of the other options.

  • daniel.dia@outlook.comdaniel.dia@outlook.com Posts: 6Members ✭✭

    I changed "Allow fallback to insecure connection" to Always . without success.

  • andyshortandyshort Posts: 2Members, Plex Pass Plex Pass

    Did you close down the plex app and reopen after you changed the setting? In my case I need to close plex fully (not just press the home button on the remote and then reopen plex) before the setting takes effect.

    If that still doesn't work then you've got a different problem to me :(

  • daniel.dia@outlook.comdaniel.dia@outlook.com Posts: 6Members ✭✭

    Yes, I restarted the app, restarted the fire stick, restarted the entire network also, unfortunately none of this solved my problem. :'(

  • daniel.dia@outlook.comdaniel.dia@outlook.com Posts: 6Members ✭✭

    Here is logging error (at the end)

Sign In or Register to comment.