Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Resolution issue with PMP Embedded on Intel Skull Canyon

AchelonAchelon Members, Plex Pass Posts: 11 Plex Pass

Hi,

I am running PMP Embedded on an Intel Skull Canyon (NUC6i7KYK) and have two issues:

1) When connecting to my TV (Panasonic TX55AX902B) using the HDMI connection, the audio playback has a distortion (stutter) in it on certain videos (but not others).

2) When connecting to the TV using the mini DisplayPort connection, audio playback is fine on all videos but no video is shown unless the DisplayPort is configured on the TV side to "Single Stream" mode. When I do this, PMP only sets the resolution to 1080P and not 4K.

I can force the correct 4K mode by manually issuing an xrandr command, but if I do, the sides of the debug overlay get cut off, as though the TV is overscanning (it isn't) and in the debug overlay, the resolution stated in "Window and Web" is "3840×2160 2880×2160" - i.e. they don't match.

I'm less bothered about the HDMI connection, but any ideas how to get the miniDisplayPort working correctly?

Btw, looks like one of the devs is a 2001 film fan - love the minor Easter Egg when issuing host:message with no parameters, PMP displays an on-screen message saying "I'm sorry Dave I can't do that" - love it.

Regards,
Achelon

Sign In or Register to comment.