Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex docker not respecting UID / GID variables

itsrumseyitsrumsey Members, Plex Pass Posts: 7 Plex Pass

I am setting up a new Plex server and cannot get these permission issues worked out.

I have tried running Plex with the following command:

docker run -d --name plex --network=host -e PLEX_CLAIM="claim-XXX" -e PLEX_UID="0" -e PLEX_GID="0" -v "/plexshare/plexdockerconfig":/config -v "/plexshare/transcode":/transcode -v "/plexshare/media":/data plexinc/pms-docker

However I cannot access my /transcode or /media folders which are owned by root.

When I exec in to container as root I can navigate fine:

But when I do the same as user plex, I can't:

Since the docker runs PMS as "plex" and doesn't respect my GID preferences, I have no way of accessing my media.
I am at a loss here so if anyone has advice please chime in.

Best Answer

  • itsrumseyitsrumsey Members, Plex Pass Posts: 7 Plex Pass
    Accepted Answer

    @ChuckPA said:
    PLEX_UID and PLEX_GID are first-run parameters when creating as

    I thought they might be, so I deleted the container, the image, and the config directory and tried starting from scratch but that did not change anything.

    I managed to work around the issue using a unionfs mount with allow_other permission, but this is really silly and I am still frustrated I can't get PMS working right on its own without a 3rd party tool.

    Nevertheless if anyone else has the same issue, I did the following:
    unionfs -o allow_other /plexshare/media/:/plexshare/emptypermfix/ /plexshare/plexmedia/

    And then of course set


Sign In or Register to comment.