Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Samsung SmartTV not playing from local server

Hello everybody, I have recently updated my Plex server to the last version 1.7.6.4058. I use a Plex Pass and a single authenticated user, with secure connections. In my local LAN and Wifi network i can stream content from iphones and PCs. My internet provider use a NAT, so my server is published to the internet and I am able to browse the content, but I cannot stream anytihng outside my local network. Unfortunately, ma Samsung Smart TV Plex App (version 3.1.0, Tizen 3.0) is able to see the media catalogue, but unable to stream or play any content. Once I choose the movie to see or the song to listen to, the app say: "PLAYER_ERROR_CONNECTION_FAILED". I tried to move my server on a different internet connection, with a different provider without a NATted address, so it was completely reacheable from the public internet network: in that case, the Samsung Plex App works fine.
So, it seems that with this app I am force to have my SmartTv and my Plex server always on on the internet network, even if I am trying to play or stream from a local network...
If it is true, I cannot use my SmartTv Plex App anymore. Any suggestion or help? Thanks a lot.

Answers

  • maxmondianimaxmondiani Members, Plex Pass Posts: 3 Plex Pass

    Just to have a complete understanding, my server is running on a QNAP NAS. Contents view from Plex Web player or iOS App or Plex Hometheater Windows app is working perfectly in the local network. I also tried to add Local Server address on the Plex Samsung App, without success.

  • maxmondianimaxmondiani Members, Plex Pass Posts: 3 Plex Pass

    I just solved the problem, maybe I did not read carefully the instructions, but I would like to share with you the solution I find. You just need to disable Plex authentication of the local server in the settings. Follow the instrutions here: https://www.howtogeek.com/303282/how-to-use-plex-media-server-without-internet-access/

Sign In or Register to comment.