If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

UPnP settings drops off every day

mimixyymimixyy Posts: 7Members, Plex Pass Plex Pass

I have a weird issue with my router. Not sure if it is the router or the Plex media server "not staying connected" to the router, and then the settings subsequently dropping.
I have to log in to my home network remotely, and then click the retry button on the remote access page in the Plex media server (note that the port is not manually configured).
Doing this remotely doesn't work.

I understand that UPnP is basically the router and app doing the port forwarding automatically. But the settings don't stay long. So I thought let's just port forward manually so the settings would stay. I tried multiple external ports, but it wouldn't let the remote access work. I tried the UPnP port 25272, 32400 and 32401. Obviously set those ports manually in Plex as well. I also manually opened them in my firewall, both incoming and outgoing traffic. I tried disabling UPnP as well. None of this got the manual port forwarding to work.

Ideally i'd like UPnP to do the job, but it seems to be dropping the UPnP entry after a day, and to get the router add it back in automatically I need to hit the retry button every time.
What happens when UPnP entry drops off? I get given "indirect" access to my media.

It is a Netgear R9000 router. The router even comes with an option to install the Plex media server directly onto the router! That's why I find it very weird that Plex specifically would play up on this router. ;)

Best Answers

Answers

  • bbubulkabbubulka Posts: 93Members, Plex Pass Plex Pass

    When did the issue start?
    Any changes made before the issue?
    Have you updated the firmware of your router?
    What's the version of your PMS?

    PLEX Setup:
    Server Side: Dell R410 (16 Core | 16GB RAM) / Ubuntu Desktop 16.04.01 64bit / Synology RS812 & RS814 (9TB @ RAID 5)
    Client Side: Roku 4 (x4)

    Please remember to mark the appropriate answer(s) which solved your issue.

  • mimixyymimixyy Posts: 7Members, Plex Pass Plex Pass

    Issues started when I got a new router. The R9000
    Firmware is at the latest version
    Latest version of PMS 1.7.5.4035

    The plex port keeps changing. Then the media server doesn't push it to the router UPnP until I click retry. Then router UPnP picks it up and it works fine.

    The port number is now 269xx something like that. Before it was 25273. It seems every time plex server decides to change the port, it have to hit retry.

    Can plex not just keep using the same port? Why does it need to keep changing?
    And if it has to change, can it have better interaction with the router UPnP to add the new port in?

  • mimixyymimixyy Posts: 7Members, Plex Pass Plex Pass

    So the fix will likely have to come from the router vendor. Or will plex ever change the way it interacts with the router? It seems a fix can come from either side?

    Anyway, I tried doing port forwarding on the router. But I can't seem to get the plex server to get an external connection. I tried opening inbound and outbound ports as well on the firewall. Port forwarding works for all my other applications. Except when I try port forwarding for plex.
    It works for game servers, sql server port forwarding etc. if I create a dhcp reservation, do I also have to manually configure the IP on the server for the plex port forwarding to work? I'm stumped as to why the manual port forwarding for plex isn't working :/ will give it another good shot and let you know. Thanks for the clarification on the UPnP issue.

  • mimixyymimixyy Posts: 7Members, Plex Pass Plex Pass

    @sa2000 said:

    @mimixyy said:
    So the fix will likely have to come from the router vendor. Or will plex ever change the way it interacts with the router? It seems a fix can come from either side?

    Many routers - many manufacturers - many do not do things right. I have seen it on my router - for example taking 50 seconds to respond to an SSDP search - way after the timeout

    It has been raised with the Plex development team to look into how we handle router issues like this and minimizing the impact

    @mimixyy said:
    Anyway, I tried doing port forwarding on the router. But I can't seem to get the plex server to get an external connection. I tried opening inbound and outbound ports as well on the firewall. Port forwarding works for all my other applications. Except when I try port forwarding for plex.
    It works for game servers, sql server port forwarding etc. if I create a dhcp reservation, do I also have to manually configure the IP on the server for the plex port forwarding to work? I'm stumped as to why the manual port forwarding for plex isn't working :/ will give it another good shot and let you know. Thanks for the clarification on the UPnP issue.

    1. Firewall in PC to have inbound port rule: Protocol=tcp, local port=32400, remote port=any, remote IP=any, programs=anny
    2. Router DHCP Reservation for the hardware mac address
    3. Port forward for public port xxxxx to local port 32400 (tcp) to the dhcp reserved IP
    4. Server remote access settings, tick manually specify port and enter port xxxxx in the box and apply
    5. may need to retry but do leave time (30 sec) between retries

    If windows 10, double check the network connection is showing as Private and not Public

    Thanks a lot! Did the port forwarding again, and again it didn't work. I checked 2 websites which check if port forwarding was done correct. And it showed the port open. I was patiently hitting retry. But no luck

    So I restarted the server. lol...
    Did the trick. I don't know why I didn't try that sooner.
    Thanks a lot for your assistance. Gave me confidence that port forwarding was the way forward on this issue.

Sign In or Register to comment.