If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Shield TV AAC 5.1 files no surround sound only stereo

jjkc29jjkc29 Posts: 78Members, Plex Pass Plex Pass

My reciever doesn't support AAC files - however in the past the Shield would pass five discreate channels as PCM to my reciever - however of late (several months) it only sends out a stereo signal. Wondering if I've set something stupidly - any thoughts appreciated.

Answers

  • BigWheelBigWheel Posts: 9,913Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    edited July 29

    what are your audio settings on shield itself and app?

    Logs > https://support.plex.tv/hc/en-us/articles/201869908-Log-Files
  • jjkc29jjkc29 Posts: 78Members, Plex Pass Plex Pass

    @BigWheel said:
    what are your audio settings on shield itself and app?

    The Shield surround mode is set to automatic, The Plex app is set for Audio Passthrough Auto.

    Interestingly enough - if I use the Shield TV as a google cast (as cast from my phone) effectively bypassing the plex app I get 5.1 digital (showing on my reciever as dolby digital)

    Any thoughts appreciated

  • kentemplinkentemplin Posts: 16Members, Plex Pass Plex Pass

    In the audio settings, try changing surround sound to always.

  • jjkc29jjkc29 Posts: 78Members, Plex Pass Plex Pass

    @kentemplin said:
    In the audio settings, try changing surround sound to always.

    Thanks for the suggestion, unfortunately it didn't make a difference.

  • BigWheelBigWheel Posts: 9,913Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    strange i have the same setting and works fine ( my receiver does not do aac either and shows it is PCM )

    have you changed any setting on your receiver. is your receiver set to straight/direct out put ( or whatever it is called on your receiver when not using any fancy post processing )

    Logs > https://support.plex.tv/hc/en-us/articles/201869908-Log-Files
  • jjkc29jjkc29 Posts: 78Members, Plex Pass Plex Pass

    @BigWheel said:
    strange i have the same setting and works fine ( my receiver does not do aac either and shows it is PCM )

    have you changed any setting on your receiver. is your receiver set to straight/direct out put ( or whatever it is called on your receiver when not using any fancy post processing )

    Apologise for the very late reply - have been away - too answer your question (if you can remember what we were discussing) the reciever settings are set to not do any post processing (straight signal).

    I should have have perhaps added (and now that I think about it this might well be the source of my problems) that I am using the ARC on my TV HDMI to route audio to the reciever. This is primarily because my TV is 4k but my Reciever is older and doesn't support 4k so I'm using my TV as the switcher. I have a Sony TV, when using the Plex app on the Sony TV 5.1AAC files don't get coverted either.

    I rather suspect I've got my answer but any thoughts appreciated

Sign In or Register to comment.