If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

How to setup RasPlex for offline use

Superman185Superman185 Posts: 7Members, Plex Pass Plex Pass

I am wondering how to setup RasPlex for offline use. I live in an area that has shotty reliability in extreme weather. My inet goes out several times a month and sometimes for days.

I have been trying to configure this RasPlex for offline use and simulating an outage of my internet. This still allows me to connect to my local Plex server, however if I restart the pi and simulate a power loss (frequent as well) I can NO longer connect to my local media.

I can use any other device however and still use Plex when my inet is down, I want that for RasPlex so this device can perform equally. I had to give up chromecast because it required a constant inet connection.

Can any one please tell me how to set that up. Or suggest another app that works just as well as RasPlex that can accomplish that goal please.

Just a FYI

  • I can access my local network files WITHOUT logging into plex when my inet is connected and freshly rebooted my pi.
  • I have put in the manual media server under >>> Preferences>Media Server>Manually specify server <<< to my local ip address and correct port.
  • I have made sure that my server firewall accepts all connections from the pi's ip address. I even disabled to try this out.

Thank you

Answers

  • Superman185Superman185 Posts: 7Members, Plex Pass Plex Pass

    Just a little update to the situation...

    I found this under the skin 'Aeon Nox' under >>> Preferences>System Info>Network>Link: Not Connected <<< that has to be the issue right there. The RasPlex requires a internet connection to verify the stored data, whether logged in or not. And not relying on a GDM connection and stored credentials.

    Is there a way to just verify the local area connection and not go through the inet for credential use?

    If not being able to shut that off how can I redirect to my servers ip for authentication?

    Because GDM in plex allows for local network discovery and this application seems to lock up access of any kind if it can't access it's main server over a inet ping or log on.

    This I believe would solve the issue.

  • videotecaCNSUvideotecaCNSU Posts: 317Validating, Plex Pass Plex Pass
    edited July 31

    Because rpi don't hace an internal battery it needs to check the time on internet to allow any kind of secure connections. Just allow unsecure connections on the server and you will be ok.

    Also you can check some guides of people who made some portable setups for cars etc.

  • Superman185Superman185 Posts: 7Members, Plex Pass Plex Pass

    @videotecaCNSU said:
    Because rpi don't hace an internal battery it needs to check the time on internet to allow any kind of secure connections.

    That maybe true for rasxplex's startup. However plex does not require the clock to be correct to have a "unsecured connection" / GDM on the network and still be able to access plex.

    @videotecaCNSU said:
    Just allow unsecure connections on the server and you will be ok.

    I have set my plex server for unsecure connections and set the IP for the PI in the advanced menu and still no luck. I've even put the servers local IP in >> Preferences>Network>Media Server>Manually specify server << to no avail.

    It should still be network discoverable. Because it still has my login user name when it's not connected to the internet. Why is that? So if it does have my login, it still must have local IP/secure connection of my network. And so rasplex is requiring a internet connection.

    So why does rasplex requires a internet connection? Whether or not it's for the clock, or is it just to enable rasplex? Like chromecast does.

    @videotecaCNSU said:
    Also you can check some guides of people who made some portable setups for cars etc.

    Have you done it? Or do you have guide on how to do it? I've done two guides and both require a internet connection in some form. Because I've searched and searched and all I could get for "offline use" was to change the skin and browse the local media aka the flash drive, that's the car guide. I'm sorry but there is nothing that I have found that makes it work without checking online to be enabled and only looking for a local area connection.

    I want it to work with no internet connection.

    So is there a way to shut rasplex's internet requirement off? I don't care about the clock.
    Where is programming/options file for the startup so it can be turned off?
    Is there a add on that can do it?
    Or is there a completely other OS that can accomplish this?

  • videotecaCNSUvideotecaCNSU Posts: 317Validating, Plex Pass Plex Pass

    Plex client needs internet for 2 things. First they need it because sometimes they check with the plex webpage for the first handshake and second they need the correct time for any kind of encrypted connection.

    I have never done it myself but I know that the key is to disable completely the encrypted connections, I have seen this method on some of the car media player threads but I currently dont have the link

  • videotecaCNSUvideotecaCNSU Posts: 317Validating, Plex Pass Plex Pass

    this was the guide

  • Superman185Superman185 Posts: 7Members, Plex Pass Plex Pass

    @videotecaCNSU said:
    Plex client needs internet for 2 things. First they need it because sometimes they check with the plex webpage for the first handshake and second they need the correct time for any kind of encrypted connection.

    I know it Plex needs it for the first connection, I mentioned it. Plex does NOT require the correct time on any machine after the initial handshake is done. That is ONLY for secured connections. Over a local area network it can connect with a unsecured connection and still stream over said network. I AM DOING IT RIGHT NOW WITH OTHER DEVICES. I can set the time to 1970ad and plex will still run over the network. Time doesn't matter on a UNSECURED CONNECTION.

    RASPLEX requires the internet connection to enable the program NOT PLEX.

    How do you turn that off on rasplex's side? It's a open software. So this setting IS optional. I know this because none of the plex apps on ANY OTHER DEVICE requires a internet connection once the secure cookie/token/login/credentials/handshake is done.

    Rasplex keeps the cookie/token/login/credentials/handshake and this is verified with a reboot with no internet connection. Because my login name is still listed on the title screen.

    @videotecaCNSU said:
    this was the guide

    Thank you for the link it redirected me to other posts but I finally found what you meant. This however has no solution either as I tried all the steps from benjaminwolf, over and over between 1.7.1 & 1.8.0

    I know I'm betting a dead horse, but rasplex's PROGRAMMING is what it is preventing it from looking at a local connection. Rasplex ONLY looks for a secure connection. As benjaminwolf said "There's not a reliable way of which I'm aware". This is compounded further in that conversation that the man who started the topic, Steve+Brace had to share his LAN connection to get rasplex to work. This is all on the programming side of rasplex. It was ONLY PROGRAMMED for a SECURE CONNECTION over the internet ONLY, as this is a open software there must be a way for that to be disabled and use a NON SECURE CONNECTION over the LAN and NOT USE the internet. The Plex app can do it on any device.

    That is why I know some how it can be incorporated into rasplex for that functionality.

    The whole point is to have this device connected to a TV and not use a mobile device.

    Someone must have a proper solution this quandary.

  • videotecaCNSUvideotecaCNSU Posts: 317Validating, Plex Pass Plex Pass

    Sorry but I dont have a setup to try it myself

    They also recommend not using plexhome or other plexpass features but I guess you already saw that

  • Superman185Superman185 Posts: 7Members, Plex Pass Plex Pass

    @videotecaCNSU said:
    Sorry but I dont have a setup to try it myself

    They also recommend not using plexhome or other plexpass features but I guess you already saw that

    I did and that did nothing as well. Thank you

  • benjaminwolfbenjaminwolf Posts: 979Members, Plex Pass Plex Pass

    Enjoy Rasplex/OpenPHT? Consider dropping some bones into our development war chest! $25, $10, $5, or even $1 helps. All donations go toward development expenses so our volunteers spend less out of pocket. rasplex.com

  • Superman185Superman185 Posts: 7Members, Plex Pass Plex Pass

    Thank you ben. However the automatic sign in is greyed out on Raspberry pi. How can I enable that?

  • Superman185Superman185 Posts: 7Members, Plex Pass Plex Pass

    Btw I did a fresh install and still no luck.

  • Vaughan01Vaughan01 Posts: 28Members, Plex Pass Plex Pass

    auto signin is a plex home thing for when you're normally having to enter a pin. I can't recall if you can add a pin to a non plex home user

Sign In or Register to comment.