If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

The Connection to the server was lost. You can try again ...... But playing from the Deck works ok

StuartWildmanStuartWildman Posts: 18Members ✭✭

Setup:
Files are on a Windows 10 Server
Plex Media Server is on Nvidia Shield
Both are on ethernet to Sky Router
New Setup, I have added all my Movies and TV Shows and not much else

On the Nvidia Shield in Plex,
On Deck, I can browse and play both Movies and TV Shows
Library, I can browse to and play Movies (I have a lot of movies..), when I select TV Shows I get the error message
"The Connection to the server was lost. You can try again or select a different server instead"

A have a lot of TV Shows, however I wouldn't expect it to fail.
Any ideas?

Thanks

Best Answer

  • StuartWildmanStuartWildman Posts: 18Members ✭✭
    Accepted Answer

    Answers to the two issues I had
    PMS on Nvidia Shield - I turned off all thumb nails, video, trailers etc, to make it as slimmed down as possible.
    I renamed the files from 01x02 to S01E02 and I set the local info first rather than searching on TVDB.
    The combination of the above seemed to do it.

    PMS on Windows - This was a strange rights issue when installing. I have 1 account i.e. If I am called Dave Smith, I logon to windows with Dave, and so Users/Dave/Local/AppData/Plex Media Server folder was created, but not working.
    After a couple of restarts and re-installs all of a sudden is create DSmith, with only 1 folder, /AppData/Plex Media Server
    I don't logon as DSmith, I logon as Dave.
    Very strange, but I now have a server working on the Shield and on Windows.
    I will be dropping the Shield server and just using it as a play.

Answers

  • StuartWildmanStuartWildman Posts: 18Members ✭✭
    edited August 2

    I forgot to add,
    1) I can browse and play both Movies and TV Shows, from my Android App
    2) In Plex on Nvidia, when I go to Select a Server, my Nvidia Shield has a Green Padlock Icon and a tick.
    3) I can also play from my Plex on my laptop.

    So laptop and Android are fine, however Nvidia Shield where the Plex Server is installed, isn't.
    Strange and slightly annoying

  • rouqrouq Posts: 361Members, Plex Pass Plex Pass

    What is the Plex server version installed on the Shield?

  • StuartWildmanStuartWildman Posts: 18Members ✭✭
    edited August 2

    Plex App Version 6.2.1.1036 19th July 2017
    Plex Media Server Version 1.7.4.4017

  • StuartWildmanStuartWildman Posts: 18Members ✭✭

    Looking at the Storage on the shield, I have 11GB, with 1.2GB spare.
    I've only installed Kodi and Plex so far.

    Plex Media Server 4.72GB used in internal shared Storage
    4.6Gb Data 125 Cache

    Could this be the issue?
    Should i get a large microSD and could i get PLex Server to use that instead?

  • Strategizer8520Strategizer8520 Posts: 21Members ✭✭

    @StuartWildman said:
    Looking at the Storage on the shield, I have 11GB, with 1.2GB spare.
    I've only installed Kodi and Plex so far.

    Plex Media Server 4.72GB used in internal shared Storage
    4.6Gb Data 125 Cache

    Could this be the issue?
    Should i get a large microSD and could i get PLex Server to use that instead?

    Buying a SD card or adopting USB 3.0 storage as internal storage wont fix this because Plex require the server data to be on the Nvidia Shield Tv actual internal storage. I have around 1GB or less storage left on my Nvidia shield tv internal HDD & its getting quite sluggish now & then, But I also have a perfectly fine & capable 256GB Samsung SSD w/ 3.0 adapter as adoptive storage (180GB free), But still cant move data to this storage to help improve Shield/Plex performance.

  • StuartWildmanStuartWildman Posts: 18Members ✭✭
    edited August 3

    @Strategizer Thanks for the reply. The 16GB is starting to look a little small, I got the Sheild cehaper on Amazon warehouse.

    As TV Shows wasn't working too well, I decided to clear the Data and Cache.
    PMS wasn't playing ball.
    I had to uninstall, then find the APK.
    This then created multiple instances of the Server, which had to removed and then re-added (Claimed on the Shield).
    A long way of uninstalling and re-installing :smile:
    I am now adding the TV Shows, so fingers crossed

    It is still adding all the TV Shows, but I can now see them, so fingers crossed

  • StuartWildmanStuartWildman Posts: 18Members ✭✭

    Has anyone added a USB drive or External HDD, as Internal storage and had their Plex data moved on to that?

  • StuartWildmanStuartWildman Posts: 18Members ✭✭

    It's happened again, but this time I think I know what is happening.
    Via the web I can see that it is has "Finished Processing xxxxx S03E04"
    It's probably this background activity that did it.
    Now just have to wait for it to stop
    And figure out the settings for it :smiley:

  • ferrar1sferrar1s Posts: 16Members, Plex Pass Plex Pass

    Why are you using PMS on the Shield when you have a Windows server?

  • StuartWildmanStuartWildman Posts: 18Members ✭✭

    A very good question.
    For some reason when I install PMS on it, it runs in Task Manager, but I can't see it or get to it to login, setup etc.
    I can't find the icon in the System Tray.
    So I have moved to the Shield, I'll get back to Win Server another day ( too many battles to fight)

    Anyway an update.
    I factory reset the Shield
    Setup PMS, no thumbnails etc.
    Loaded the 1000+ shows and all working fine.
    Watched a couple of shows and all of a sudden it starts to happen again.

    • Library TV Shows - Nothing
      Checking the Status Alerts, I can see that it is Loading Metadata and Processing.

    • I did a voice search for Friends - Nothing

    • I did a voice search for Jennifer Aniston - Bingo
      From there I could go to Friends, Season and episode.

    So I think the problem is, whilst it is Processing the Shield is too busy.
    However there is a workaround.

    I'm going to wait and see if I can see all TV Shows when it finishes processing.
    (I can then send many hours trying to sort out PMS on the Win 10 server)

  • ferrar1sferrar1s Posts: 16Members, Plex Pass Plex Pass

    On a server you access PMS through a browser eg. \server_name:port number or install Plex Media Player and you can access the setting through that. I don't believe there is a system tray icon.

  • StuartWildmanStuartWildman Posts: 18Members ✭✭
    Accepted Answer

    Answers to the two issues I had
    PMS on Nvidia Shield - I turned off all thumb nails, video, trailers etc, to make it as slimmed down as possible.
    I renamed the files from 01x02 to S01E02 and I set the local info first rather than searching on TVDB.
    The combination of the above seemed to do it.

    PMS on Windows - This was a strange rights issue when installing. I have 1 account i.e. If I am called Dave Smith, I logon to windows with Dave, and so Users/Dave/Local/AppData/Plex Media Server folder was created, but not working.
    After a couple of restarts and re-installs all of a sudden is create DSmith, with only 1 folder, /AppData/Plex Media Server
    I don't logon as DSmith, I logon as Dave.
    Very strange, but I now have a server working on the Shield and on Windows.
    I will be dropping the Shield server and just using it as a play.

Sign In or Register to comment.