If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex on FreeNas not showing movie posters.

mdecoumdecou Posts: 5Members, Plex Pass Plex Pass

Hi all,
I just did a clean install of Plex (plex pass) on my freenas box, including blowing away the entire jail and meta data. I have installed version 1.8.0.4109. Everything works as expected, except that the movies in my library are not showing the posters. The meta data IS downloading correctly, and each movie has all the posters downloaded... its just that none of them are selected by default. I just get a generic dark grey rectangle. I can go in to each movie and "edit" it, an select a poster, but that will become maddening very quickly. Is anyone seeing this, or is anyone aware of a fix?

Thanks

Answers

  • mdecoumdecou Posts: 5Members, Plex Pass Plex Pass

    CORRECTION... My meta data does not appear to be populating. I get all sorts of notifications that my movies are finished processing, but no data. Is this a known issue with 1.8?

  • sa2000sa2000 Posts: 29,453Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @mdecou said:
    Is this a known issue with 1.8?

    There is a known issue with jail setup where sometimes users fail to ensure there is a loopback IP address configured.

    Logs collected after a restart and waiting 5 minutes should confirm if there is an issue with localhost

    Otherwise - need logs with debug logging enabled covering time media is being scanned and metadata refreshed
    See https://support.plex.tv/hc/en-us/articles/201643703-Reporting-issues-with-Plex-Media-Server
    https://support.plex.tv/hc/en-us/articles/200250417-Plex-Media-Server-Log-Files

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • mdecoumdecou Posts: 5Members, Plex Pass Plex Pass

    @sa2000 said:

    @mdecou said:
    Is this a known issue with 1.8?

    There is a known issue with jail setup where sometimes users fail to ensure there is a loopback IP address configured.

    Logs collected after a restart and waiting 5 minutes should confirm if there is an issue with localhost

    Otherwise - need logs with debug logging enabled covering time media is being scanned and metadata refreshed
    See https://support.plex.tv/hc/en-us/articles/201643703-Reporting-issues-with-Plex-Media-Server
    https://support.plex.tv/hc/en-us/articles/200250417-Plex-Media-Server-Log-Files

    Thanks for the reply. I am attaching the logs after being up for a few minutes, and doing a metadata refresh. I did not let it do the entire library as it would just go on for a while with the same results for everything. Please let me know if this gives you what you need, and thanks very much for the assistance.

  • sa2000sa2000 Posts: 29,453Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @mdecou said:

    @sa2000 said:

    @mdecou said:
    Is this a known issue with 1.8?

    There is a known issue with jail setup where sometimes users fail to ensure there is a loopback IP address configured.

    Logs collected after a restart and waiting 5 minutes should confirm if there is an issue with localhost

    Otherwise - need logs with debug logging enabled covering time media is being scanned and metadata refreshed
    See https://support.plex.tv/hc/en-us/articles/201643703-Reporting-issues-with-Plex-Media-Server
    https://support.plex.tv/hc/en-us/articles/200250417-Plex-Media-Server-Log-Files

    Thanks for the reply. I am attaching the logs after being up for a few minutes, and doing a metadata refresh. I did not let it do the entire library as it would just go on for a while with the same results for everything. Please let me know if this gives you what you need, and thanks very much for the assistance.

    Logs show several issues

    There are permissions issues for this area /usr/local/plexdata-plexpass/Plex Media Server/Media

    Aug 03, 2017 13:50:58.141 [0x80ba4f200] ERROR - Error creating directory /usr/local/plexdata-plexpass/Plex Media Server/Media/localhost/0: boost::filesystem::create_directories: Read-only file system: "/usr/local/plexdata-plexpass/Plex Media Server/Media/localhost"
    
    Aug 03, 2017 13:50:58.141 [0x80ba4f200] ERROR - Error creating directory /usr/local/plexdata-plexpass/Plex Media Server/Media/localhost/0/85bc89fbc61770399b34a1caca4e0c1c3180544.bundle/Contents: boost::filesystem::create_directories: Read-only file system: "/usr/local/plexdata-plexpass/Plex Media Server/Media/localhost/0/85bc89fbc61770399b34a1caca4e0c1c3180544.bundle"
    

    You lost DNS / Internet at 13:53

    Aug 03, 2017 13:53:06.973 [0x80b64e400] ERROR - Error issuing curl_easy_perform(handle): 6
    Aug 03, 2017 13:53:06.973 [0x80b64e400] WARN - HTTP error requesting GET http://plex.tv/pms/:/ip (0, No error) (Couldn't resolve host 'plex.tv')
    Aug 03, 2017 13:53:06.973 [0x80b64e400] ERROR - PublicAddressManager: Unable to get public IP adddress from myPlex (httpCode=-6): 
    
    Aug 03, 2017 13:53:06.974 [0x80b64e400] DEBUG - HTTP requesting PUT https://plex.tv/devices/f8d6db7f175a4b66ee4d020668a8597688b4162c?httpsEnabled=1&httpsRequired=0&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx
    Aug 03, 2017 13:53:06.974 [0x80b64e400] ERROR - Error issuing curl_easy_perform(handle): 6
    Aug 03, 2017 13:53:06.974 [0x80b64e400] WARN - HTTP error requesting PUT https://plex.tv/devices/f8d6db7f175a4b66ee4d020668a8597688b4162c?httpsEnabled=1&httpsRequired=0&X-Plex-Token=xxxxxxxxxxxxxxxxxxxx (0, No error) (Couldn't resolve host 'plex.tv')
    

    DNS issues continued after relaunch of Plex Media Server

    Aug 03, 2017 13:53:51.578 [0x80ac4f900] ERROR - Error issuing curl_easy_perform(handle): 6
    Aug 03, 2017 13:53:51.578 [0x80ac4f900] ERROR - HTTP -6 downloading url https://meta.plex.tv/t/theater?language=en&subtitleLanguage=en&redband=0
    
    Aug 03, 2017 13:53:54.150 [0x809af5200] WARN - HTTP error requesting GET http://ocspx.digicert.com/MFEwTzBNMEswSTAJBgUrDgMCGgUABBSnVdbEyh8T3xvVlkPGHNCJxnqCPgQUlIuJ90hyifJRStmIe%2BVhtaqc1QECEA0g%2BbdZFzMlYmWrvCQx%2BQc%3D (0, No error) (Couldn't resolve host 'ocspx.digicert.com')
    Aug 03, 2017 13:53:54.150 [0x809af5200] ERROR - OCSP response error: -6
    Aug 03, 2017 13:53:54.259 [0x809af6600] ERROR - Error issuing curl_easy_perform(handle): 6
    Aug 03, 2017 13:53:54.259 [0x809af6600] WARN - HTTP error requesting GET https://plex.tv/servers/f8d6db7f175a4b66ee4d020668a8597688b4162c/access_tokens.xml?auth_token=xxxxxxxxxxxxxxxxxxxx&includeProfiles=1&includeProviders=1 (0, No error) (Couldn't resolve host 'plex.tv')
    

    and permissions issue continue eg

    Aug 03, 2017 13:57:22.503 [0x809af6600] ERROR - Error creating directory /usr/local/plexdata-plexpass/Plex Media Server/Media/localhost/7: boost::filesystem::create_directories: Read-only file system: "/usr/local/plexdata-plexpass/Plex Media Server/Media/localhost"
    
    Aug 03, 2017 13:57:22.503 [0x809af6600] ERROR - Error creating directory /usr/local/plexdata-plexpass/Plex Media Server/Media/localhost/7: boost::filesystem::create_directories: Read-only file system: "/usr/local/plexdata-plexpass/Plex Media Server/Media/localhost"
    
    Aug 03, 2017 13:57:22.503 [0x809af6600] ERROR - Error creating directory /usr/local/plexdata-plexpass/Plex Media Server/Media/localhost/7/21be3f9334d14b17f8102a266d6e780746348a1.bundle/Contents: boost::filesystem::create_directories: Read-only file system: "/usr/local/plexdata-plexpass/Plex Media Server/Media/localhost/7/21be3f9334d14b17f8102a266d6e780746348a1.bundle"
    

    Separately from this - there is also some locale issue

    Aug 03, 2017 13:53:13.832 [0x809acee00] ERROR - Failed to determine system locale: locale::facet::_S_create_c_locale name not valid. Defaulting to en-US.
    

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • sa2000sa2000 Posts: 29,453Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @sa2000 said:
    Separately from this - there is also some locale issue

    Aug 03, 2017 13:53:13.832 [0x809acee00] ERROR - Failed to determine system locale: locale::facet::_S_create_c_locale name not valid. Defaulting to en-US.
    

    I understand this is normal for FreeBSD

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • mdecoumdecou Posts: 5Members, Plex Pass Plex Pass

    Well, the good news is that i am able to get meta data flowing again. I addressed the permissions issue in Freenas (mount was set to read-only).

    Regarding the DNS, I did a rebuild of the jail, rebooting at every step (jail creation, portsnap, install, etc). After each step, I checked DNS by pinging plex.tv as well as some other sites.

    Just for sanity's sake, I have attached my logs again. I am curious if anything still seems out of whack.

    Thanks!

  • sa2000sa2000 Posts: 29,453Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @mdecou said:
    Well, the good news is that i am able to get meta data flowing again. I addressed the permissions issue in Freenas (mount was set to read-only).

    Regarding the DNS, I did a rebuild of the jail, rebooting at every step (jail creation, portsnap, install, etc). After each step, I checked DNS by pinging plex.tv as well as some other sites.

    Just for sanity's sake, I have attached my logs again. I am curious if anything still seems out of whack.

    Thanks!

    There were still DNS issues at 19:51

    Aug 03, 2017 19:51:15.298 [0x80a6cf000] ERROR - Error issuing curl_easy_perform(handle): 6
    Aug 03, 2017 19:51:15.298 [0x80a6cf000] WARN - HTTP error requesting GET https://plex.tv/api/photos/profile (0, No error) (Couldn't resolve host 'plex.tv')
    
    Aug 03, 2017 19:51:25.513 [0x80ac52400] ERROR - Error issuing curl_easy_perform(handle): 6
    Aug 03, 2017 19:51:25.513 [0x80a6d0e00] ERROR - Error issuing curl_easy_perform(handle): 6
    Aug 03, 2017 19:51:25.513 [0x80a6d0e00] ERROR - HTTP -6 downloading url https://meta.plex.tv/t/theater?language=en&subtitleLanguage=en&redband=0
    Aug 03, 2017 19:51:25.513 [0x80ac52400] ERROR - HTTP -6 downloading url https://meta.plex.tv/t/theater?language=en&subtitleLanguage=en&redband=0
    
    Aug 03, 2017 19:51:25.514 [0x80a6d0e00] ERROR - Error issuing curl_easy_perform(handle): 6
    Aug 03, 2017 19:51:25.514 [0x80ac52400] ERROR - Error issuing curl_easy_perform(handle): 6
    Aug 03, 2017 19:51:25.514 [0x80a6d0e00] ERROR - HTTP -6 downloading url https://meta.plex.tv/t/video?language=en&subtitleLanguage=en&redband=0
    Aug 03, 2017 19:51:25.514 [0x80a6d0e00] ERROR - IVA: Error downloading trailers for source 2.
    Aug 03, 2017 19:51:25.514 [0x80ac52400] ERROR - HTTP -6 downloading url https://meta.plex.tv/t/video?language=en&subtitleLanguage=en&redband=0
    Aug 03, 2017 19:51:25.514 [0x80ac52400] ERROR - IVA: Error downloading trailers for source 2.
    

    but resolved at 19:53
    eg

    Aug 03, 2017 19:53:05.507 [0x80a6d0e00] DEBUG - HTTP requesting GET https://plex.tv/updater/products/1/check.xml?build=freebsd-x86_64&channel=16&distribution=freebsd&version=1.8.0.4109-42bd8c63f
    
    Aug 03, 2017 19:53:05.971 [0x80a6d0e00] DEBUG - HTTP 200 response from GET https://plex.tv/updater/products/1/check.xml?build=freebsd-x86_64&channel=16&distribution=freebsd&version=1.8.0.4109-42bd8c63f
    

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
Sign In or Register to comment.