If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

can't access docker anymore

vigilianvigilian Posts: 88Members, Plex Pass Plex Pass
edited August 4 in Docker

Processing triggers for systemd (229-4ubuntu13) ...
[cont-init.d] 50-plex-update: exited 0.
[cont-init.d] done.
[services.d] starting services
[services.d] done.
Starting Plex Media Server.
Starting Plex Media Server.
....
Starting Plex Media Server.
Starting Plex Media Server.
Starting Plex Media Server.
Starting Plex Media Server.
Starting Plex Media Server.
terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector >'
what(): boost: mutex lock failed in pthread_mutex_lock: Invalid argument
Error: Unable to set up server: bind: Cannot assign requested address (N5boost16exception_detail10clone_implINS0_19error_info_injectorINS_6system12system_errorEEEEE)
****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Library/Application Support/Plex Media Server/Crash Reports/1.8.0.4109-42bd8c63f/PLEX MEDIA SERVER/6973e32e-5cea-dbb4-628073e5-49c087b1.dmp
Aborted (core dumped)
Starting Plex Media Server.
Starting Plex Media Server.

...

and it goes on like this over and over

Best Answer

Answers

  • vigilianvigilian Posts: 88Members, Plex Pass Plex Pass

    and by theway my command start is with -e ADVERTISE_IP="http://192.168.5.100:32400/"
    where is the config files exactly?

  • sn00psn00p Posts: 142Members, Plex Pass Plex Pass

    @vigilian said:
    and by theway my command start is with -e ADVERTISE_IP="http://192.168.5.100:32400/"
    where is the config files exactly?

    Wherever you mounted the /config with the docker run command.

  • vigilianvigilian Posts: 88Members, Plex Pass Plex Pass
    edited August 4

    you are thinking about permissions problems no? it was working yesterday so norammly it hasn't change and I have done a "chown plex:plex -R ./ from inside the container, inside config anyway.

    docker create --name plex -p 32400:32400/tcp -p 3005:3005/tcp -p 8324:8324/tcp -p 32469:32469/tcp -p 1900:1900/udp -p 32410:32410/udp -p 32412:32412/udp -p 32413:32413/udp -p 32414:32414/udp -e TZ="Europe/Brussels" -e PLEX_CLAIM="..." -e ALLOWED_NETWORKS="192.168.5.0/25,192.168.2.0/25,192.168.3.0/25,192.168.4.0/25" -e ADVERTISE_IP="http://192.168.5.100:32400/" -h 47k_plex -v /media/stock/reserve/plex:/config -v /media/stock/reserve/plextranscode:/transcode -v /media/qnap/series:/data/tvshows -v /media/qnap/media:/data/movies -v /media/syno:/data/mediaTypeA -v /media/qnap:/data/mediaTypeB plexinc/pms-docker:plexpass

  • vigilianvigilian Posts: 88Members, Plex Pass Plex Pass
    edited August 4

    <?xml version="1.0" encoding="utf-8"?>
    Preferences MachineIdentifier="..." ProcessedMachineIdentifier="..." customConnections="http://192.168.5.100:32400/" allowedNetworks="192.168.5.0/25,192.168.2.0/25,192.168.3.0/25,192.168.4.0/25" TranscoderTempDirectory="/transcode" OldestPreviousVersion="legacy" AnonymousMachineIdentifier="..." MetricsEpoch="1" AcceptedEULA="1" PublishServerOnPlexOnlineKey="1" PlexOnlineToken="..." PlexOnlineUsername="vigilian" PlexOnlineMail="...." CertificateVersion="2" LastAutomaticMappedPort="0" FriendlyName="" ButlerUpdateChannel="8" ManualPortMappingMode="1" ManualPortMappingPort="32400" WanPerStreamMaxUploadRate="2000" WanTotalMaxUploadRate="3000" PubSubServer="82.94.168.54" PubSubServerRegion="ams" PubSubServerPing="28" LanguageInCloud="1" CloudSyncNeedsUpdate="0" LanNetworksBandwidth="192.168.5.0/25,192.168.2.0/25,192.168.3.0/25,192.168.4.0/25" FSEventLibraryPartialScanEnabled="1" FSEventLibraryUpdatesEnabled="1" ScheduledLibraryUpdateInterval="21600" ScheduledLibraryUpdatesEnabled="1" watchMusicSections="1" LogVerbose="1" logTokens="1" EnableIPv6="1" WanPerUserStreamCount="2"/

  • vigilianvigilian Posts: 88Members, Plex Pass Plex Pass

    okey I found the problem. It's because I4ve activated ipv6 in plex....
    So let's debug this.
    Why would it be a problem to have ipv6 in this container ?docker can manage ipv6 to my knowledge so why is that a problem? even if there are no ipv6 available.

  • sa2000sa2000 Posts: 29,449Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @vigilian said:
    Processing triggers for systemd (229-4ubuntu13) ...
    [cont-init.d] 50-plex-update: exited 0.
    [cont-init.d] done.
    [services.d] starting services
    [services.d] done.
    Starting Plex Media Server.
    Starting Plex Media Server.
    ....
    Starting Plex Media Server.
    Starting Plex Media Server.
    Starting Plex Media Server.
    Starting Plex Media Server.
    Starting Plex Media Server.
    terminate called after throwing an instance of 'boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector >'
    what(): boost: mutex lock failed in pthread_mutex_lock: Invalid argument
    Error: Unable to set up server: bind: Cannot assign requested address (N5boost16exception_detail10clone_implINS0_19error_info_injectorINS_6system12system_errorEEEEE)
    ****** PLEX MEDIA SERVER CRASHED, CRASH REPORT WRITTEN: /config/Library/Application Support/Plex Media Server/Crash Reports/1.8.0.4109-42bd8c63f/PLEX MEDIA SERVER/6973e32e-5cea-dbb4-628073e5-49c087b1.dmp
    Aborted (core dumped)
    Starting Plex Media Server.
    Starting Plex Media Server.

    ...

    and it goes on like this over and over

    @sa2000 said:
    This boost error on bind (N5boost16exception_detail10clone_implINS0_19error_info_injectorINS_6system12system_errorEEEEE) has been seen on NAS systems as well and I have raised it as an issue with the development team

    FYI The fix for this has now got released in version 1.9.3

    Release Notice - here http://forums.plex.tv/discussion/comment/1527039/#Comment_1527039

    • (Network) Fallback to IPv4 only if IPv6 networking fails to setup (#7382)

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
Sign In or Register to comment.