Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Zero Plex Channels found in directory

BenjormanBenjorman Members Posts: 18 ✭✭

As stated in the title, my Plex server is unable to find any channels whatsoever via the channel directory, even though I have my region set to US, and ignore compatibility is checked. I am running the latest version of plex on windows 10. Repairing my install had no effect.

Tagged:

Answers

  • sGarversGarver Members, Plex Pass Posts: 412 Plex Pass

    What channels have you installed? Are you aware that the channels library is for plug-ins?

  • BenjormanBenjorman Members Posts: 18 ✭✭

    None, and yes. I'm trying to install the SubZero plugin.
    As you can see in this screenshot, there are no results whatsoever when I have "More -> All Available Plugins" selected.

  • sGarversGarver Members, Plex Pass Posts: 412 Plex Pass

    Not what I was expecting. This does not appear to be an issue with installing into the correct Plug-ins folder... you are not even seeing available plug-ins.

    In my settings I have only "Region" == "United States"; all other options are unchecked or blank and I do get the list of available plug-ins.

    Sorry, This is beyond me, @sa2000 do you have any idea or who might be best to look at this?

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 28,145 Plex Team Member
    edited August 7

    The only thing I can suggest is enabling verbose plex web logging
    Settings / Web / General / Show Advanced / Debug
    Enable Verbose
    Save changes

    Click Home
    Click Channels
    Install Channels
    Reproduce the problem
    Take screenshot showing url and time
    Then Settings / Web / General / Show Advanced / Debug
    View Logs
    Select all text and copy to notepad and save as text file

    attach this log and screenshot

    and reset web logging back to default of disabled

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • shopgirl284shopgirl284 Members, Plex Pass, Plex Ninja, Forum Moderator Posts: 2,565 Plex Ninja

    Some users, who have had issues with the Plex Web app not properly displaying channel plugins in the Channel Directory, have found that manually setting their region fixes the issue. The "Auto" option can sometimes cause issues with the Channel Directory listing the channel plugins properly.

    See Region Settings for instructions to manually set your region.

    Otherwise, there is an issue with the Plex Web app on your browser/system and you would need to post to the Plex Web app section of the forum where someone familiar with the Plex Web app can help you troubleshoot the issue.

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 28,145 Plex Team Member

    I can move the thread there once we have the plex web app log I asked for

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • BenjormanBenjorman Members Posts: 18 ✭✭
    edited August 8

    Sorry, long day at work. Here is the requested screenshot, taken at 10:08PM PST / Local time.

    Enabled verbose logging, and restarted plex as admin for good measure before navigating to install channels page. Debug log paste spam attached.

    Thanks for looking into this!

    *Edit: I was looking through my log, and for some reason, the log seems to think it's tomorrow (8/8) at 5AM, despite my system time being correct. It appears the time of the screenshot listed in the file is "2017-08-08T05:08:14.999Z"

  • BenjormanBenjorman Members Posts: 18 ✭✭
    edited August 8

    FYI Just to assuage any doubts :P

    The only case similar to my own I was able to find online mentioned an issue of an IP being blocked by windows firewall.

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 28,145 Plex Team Member

    Thanks for the Plex web log and screenshot. It looks like the list of channels is acquired through Plex Media Server and not directly by Plex Web. Could I ask you to repeat the test please only this time including both the plex web log and the zipped plex media server logs

    ensure server debug logging is already enabled and restart the server
    Settings / Server / General / Show Advanced : Enable debug
    Save changes
    Restart Server

    Ensure plex web verbose logging enabled
    Reproduce the problem
    Get screenshot
    Get plex web log
    Get server log (settings / server / help / download logs)

    This is what the plex web log is showing
    Request for Featured list sent Plex Media Server

        "type": "ajax",
        "url": "https://192-168-1-2.a5c3c45be89846cbaa652f83364a18de.plex.direct:32400/system/appstore/featured?X-Plex-Product=Plex%20Web&X-Plex-Version=3.17.3&X-Plex-Client-Identifier=d6f5bdcd-adac-4aea-bc79-20dc4fcae6ce&X-Plex-Platform=Chrome&X-Plex-Platform-Version=60.0&X-Plex-Device=Windows&X-Plex-Device-Name=Plex%20Web%20%28Chrome%29&X-Plex-Device-Screen-Resolution=1661x909%2C2560x1440&X-Plex-Token=TOKEN",
        "status": 200,
        "headers": {
          "Accept-Language": "en"
        },
    

    Response received with zero content

        "response": "<?xml version='1.0' encoding='utf-8'?>\n<ASContainer viewGroup=\"Store:Info\" art=\"/:/plugins/com.plexapp.system/resources/store-art.png?t=1498654104\" noCache=\"1\" noHistory=\"0\" title1=\"Channel Directory\" title2=\"Featured\" replaceParent=\"0\" size=\"0\" viewmode=\"65592\" contenttype=\"items\" identifier=\"com.plexapp.system\"/>\n",
        "time": "2017-08-08T05:08:04.051Z"
      },
    

    Similarly - request for whats new

      {
        "type": "ajax",
        "url": "https://192-168-1-2.a5c3c45be89846cbaa652f83364a18de.plex.direct:32400/system/appstore/new?X-Plex-Product=Plex%20Web&X-Plex-Version=3.17.3&X-Plex-Client-Identifier=d6f5bdcd-adac-4aea-bc79-20dc4fcae6ce&X-Plex-Platform=Chrome&X-Plex-Platform-Version=60.0&X-Plex-Device=Windows&X-Plex-Device-Name=Plex%20Web%20%28Chrome%29&X-Plex-Device-Screen-Resolution=1661x909%2C2560x1440&X-Plex-Token=TOKEN",
        "status": 200,
        "headers": {
          "Accept-Language": "en"
        },
    

    Response with zero content

        "response": "<?xml version='1.0' encoding='utf-8'?>\n<ASContainer viewGroup=\"Store:Info\" art=\"/:/plugins/com.plexapp.system/resources/store-art.png?t=1498654104\" noCache=\"1\" noHistory=\"0\" title1=\"Channel Directory\" title2=\"What's New\" replaceParent=\"0\" size=\"0\" viewmode=\"65592\" contenttype=\"items\" identifier=\"com.plexapp.system\"/>\n",
        "time": "2017-08-08T05:08:05.858Z"
    

    The Plex Media Server logs would show how these requests were handled and what url was sent to the plex.tv site - then we can take it from there

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 28,145 Plex Team Member

    @Benjorman said:
    I was looking through my log, and for some reason, the log seems to think it's tomorrow (8/8) at 5AM, despite my system time being correct. It appears the time of the screenshot listed in the file is "2017-08-08T05:08:14.999Z"

    I believe Plex Web log timestamps are all GMT

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • BenjormanBenjorman Members Posts: 18 ✭✭
    edited August 9


    I misread your instructions so I ended up grabbing both verbose and non-verbose versions of the server logs.

    9:41 PM PST for verbose web log & verbose **server log ** (zip labeled accordingly) and screenshot
    9:45-9:46 PM PST for non-verbose server log

  • BenjormanBenjorman Members Posts: 18 ✭✭
    edited August 9

    Went log-diving out of curiosity. In the non-verbose server logs, I see something that might be what you're looking for in com.plexapp.system.log starting after
    2017-08-08 21:45:46,744 (1f34)

    :smile:

    If it's saying what it SEEMS to be saying, I wonder why the issue wasn't addressed through normal service updates.

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 28,145 Plex Team Member

    @Benjorman said:
    Went log-diving out of curiosity. In the non-verbose server logs, I see something that might be what you're looking for in com.plexapp.system.log starting after
    2017-08-08 21:45:46,744 (1f34)

    :smile:

    If it's saying what it SEEMS to be saying, I wonder why the issue wasn't addressed through normal service updates.

    I have not seen this before.
    The server is failing to parse the request from com.plexapp.system

    Aug 08, 2017 21:44:46.671 [2540] DEBUG - Request: [::ffff:127.0.0.1:64608 (WAN)] GET  (4 live) GZIP Signed-in Token ()
    Aug 08, 2017 21:44:46.671 [2540] ERROR - Error parsing HTTP request: ET  HTTP/1.1
    Host: 127.0.0.1:32400
    User-Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_2) AppleWebKit/537.74.9 (KHTML, like Gecko) Version/7.0.2 Safari/537.74.9
    Connection: close
    X-Plex-Token: xxxxxxxxxxxxxxxxxxxx
    Accept-Encoding: gzip
    

    Do you any thing special in your environment for localhost ? proxy ?
    Some issue with the header in the request leading to it seen as ET rather than GET

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 28,145 Plex Team Member

    And do you have any separate install of python?

    Could you send me the output of set - want to see all environment variables and what you have in PATH=
    The request from the python code appears to be wrong. May be some issue with headers ? carriage return / line feed characters. Not sure

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • BenjormanBenjorman Members Posts: 18 ✭✭

    Answering in order:

    Do you any thing special in your environment for localhost ? proxy ?

    I am using a VPN, but I'm not sure that that would cause the request to be truncated. When I disable my VPN, the issue still occurs as stated. My router also reports to no-ip.net for Dynamic DNS stuff, but that shouldn't affect anything. I also have two other browser-accessed services like PLEX, Sonarr and Jackett, but I don't think they should be interfering in any way.

    One thing of note that shouldn't but might be affecting things, I have a proxy issue with windows 10 like the one described here.

    I've run numerous antivirus and anti-spyware software both in and out of safe mode that say my computer is clean.I suspect I simply have a rogue, legitimate application that's **** with my settings in a way that it shouldn't be, but I don't have the expertise to track it down.

    I'd do a clean install of the OS, but at the moment I have way too much data and no good way to manage it.

    And do you have any separate install of python?
    Could you send me the output of set - want to see all environment variables and what you have in PATH=
    The request from the python code appears to be wrong. May be some issue with headers ? carriage return / line feed >characters. Not sure

    I don't recall intentionally installing python, but it's possible I did as some point to run a specific script. When I typed set into the command line, these were the results:

                    Microsoft Windows [Version 10.0.15063]
                    (c) 2017 Microsoft Corporation. All rights reserved.
    
                    C:\WINDOWS\system32>set
                    ALLUSERSPROFILE=C:\ProgramData
                    APPDATA=C:\Users\Steakpirate\AppData\Roaming
                    asl.log=Destination=file
                    CommonProgramFiles=C:\Program Files\Common Files
                    CommonProgramFiles(x86)=C:\Program Files (x86)\Common Files
                    CommonProgramW6432=C:\Program Files\Common Files
                    COMPUTERNAME=STEAKY-PC
                    ComSpec=C:\WINDOWS\system32\cmd.exe
                    FP_NO_HOST_CHECK=NO
                    GTK_BASEPATH=C:\Program Files (x86)\GtkSharp\2.12\
                    HOMEDRIVE=C:
                    HOMEPATH=\Users\Steakpirate
                    LOCALAPPDATA=C:\Users\Steakpirate\AppData\Local
                    LOGONSERVER=\\STEAKY-PC
                    NUMBER_OF_PROCESSORS=8
                    OneDrive=C:\Users\Steakpirate\OneDrive
                    OS=Windows_NT
                    Path=C:\ProgramData\Oracle\Java\javapath;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\QuickTime\QTSystem\;C:\Program Files (x86)\GtkSharp\2.12\bin;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Program Files (x86)\Skype\Phone\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Users\Steakpirate\AppData\Local\Microsoft\WindowsApps
                    PATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.MSC
                    PROCESSOR_ARCHITECTURE=AMD64
                    PROCESSOR_IDENTIFIER=Intel64 Family 6 Model 60 Stepping 3, GenuineIntel
                    PROCESSOR_LEVEL=6
                    PROCESSOR_REVISION=3c03
                    ProgramData=C:\ProgramData
                    ProgramFiles=C:\Program Files
                    ProgramFiles(x86)=C:\`Program Files (x86)
                    ProgramW6432=C:\Program Files
                    PROMPT=$P$G
                    PSModulePath=C:\WINDOWS\system32\WindowsPowerShell\v1.0\Modules\
                    PUBLIC=C:\Users\Public
                    SystemDrive=C:
                    SystemRoot=C:\WINDOWS
                    TEMP=C:\Users\STEAKP~1\AppData\Local\Temp
                    TMP=C:\Users\STEAKP~1\AppData\Local\Temp
                    USERDOMAIN=STEAKY-PC
                    USERDOMAIN_ROAMINGPROFILE=STEAKY-PC
                    USERNAME=Steakpirate
                    USERPROFILE=C:\Users\Steakpirate
                    VS140COMNTOOLS=C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\Tools\
                    windir=C:\WINDOWS
    
  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 28,145 Plex Team Member

    @Benjorman said:
    Answering in order:

    I am using a VPN, but I'm not sure that that would cause the request to be truncated. When I disable my VPN, the issue still occurs as stated. My router also reports to no-ip.net for Dynamic DNS stuff, but that shouldn't affect anything. I also have two other browser-accessed services like PLEX, Sonarr and Jackett, but I don't think they should be interfering in any way.

    One thing of note that shouldn't but might be affecting things, I have a proxy issue with windows 10 like the one described here.

    We can concentrate on the proxy aspects first as possible software interfering.

    The position is that no one else is having this symptom

    It is not affecting browser requests but some internal requests made by a PlexScriptHost.exe python process for com.plexapp.system and to 127.0.0.1

    It is possible that some adjustments to the request header are being made leading to the 1 character shift in the request striing making the GET look like ET

    Does the C:\Windows\System32\drivers\etc\hosts file have any content for 127.0.0.1?

    What are the proxy settings showing ?

    Are you able to use some tools to allow you to see 127.0.0.1 traffic ? There are some third party products to use with wireshark

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • BenjormanBenjorman Members Posts: 18 ✭✭

    Does the C:\Windows\System32\drivers\etc\hosts file have any content for 127.0.0.1?

    It looks Spybot SD inserted a whoooole mess of sites. I don't see any where the localhost IP is in the right column (not sure if that's what you were asking). I've attached a copy.

    Here's the proxy settings page:

    The rest of the "Address" box not pictured is just the same thing for HTTPS.

    After googling Wireshark and coming across this page, it suddenly dawned upon me that once upon a time I installed Wireshark as part of an investigation into what had been constantly waking my computer from sleep. I wonder if that could be the source of my weird proxy settings issues... That would be far preferable to the after-effects of some long dead virus.

    I've updated Wireshark to the latest version, and I captured a couple minutes of activity, but I don't know what if anything I'd be looking for. (The file was about 60mb. Not sure what the upload limit is here).

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 28,145 Plex Team Member
    edited August 11

    My guess is that the problem is to do with going through proxy software

    Your screenshot shows the proxy exclusion list
    Could you replace <-localhost> with this exclusion list
    localhost;127.0.0.1

    You can also tick Don't use the proxy for local (intranet) addresses

    Save and reboot and see if it makes any difference

    Even if this fixes the channels issue, having a proxy could affect other aspects

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
Sign In or Register to comment.