If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Hangs during playback of DVR recordings on Apple TV 4-Plays fine with VLC

WillParWillPar Posts: 9Members, Plex Pass Plex Pass

Like others, I get hangs during playback of my DVR content on AppleTV4. I also get the message that my server is not powerful enough. Task Manager shows CPU usage of 80-90+ due to transcoding during playback. Finally I decided to download the Apple TV video player app VLC. VLC will link to my Plex library and play the same content. Recordings that snag/hang in Plex play perfectly fine in VLC. Also when playing in VLC Task Manager shows little or no increase in CPU usage with usage staying below 10-15%.

So, why will VLC play the same Plex recording with little CPU usage as opposed to playing the same content in Plex with high CPU usage??? I don't want to have to resort to playing my all Plex DVR recordings with VLC. I've tried to adjust every imaginable setting in Plex, Apple TV and windows 10 without any progress. Please advise. Thanks.

Best Answers

  • WillParWillPar Posts: 9Members, Plex Pass Plex Pass
    Accepted Answer

    It is starting to look as if my problem is resolved by updating the driver for my Realtec Ethernet adapter. There was a new driver for Windows 10 (upd. 7/27) and since updating the driver I've been successfully playing 1080p HD shows all afternoon with no problems. I'm guessing either the Windows 10 Anniversary and/or Creators update combined with my old driver caused some Ethernet performance issues on my home network. (Fingers crossed.)

Answers

  • WillParWillPar Posts: 9Members, Plex Pass Plex Pass

    Thanks mschlotz. I had waded through several other threads on this problem but hadn't found that thread yet. It's extremely discouraging to learn that Plex has been aware of the problem for such a long time without providing a solution. I became a Plex Pass customer for the DVR capability. I like the Plex interface otherwise, but playback is worthless as is. (Live TV is pretty clunky as well compared to Channels). I'll quit searching for a solution and just use VLC to play my recordings. Apple TV will always be my choice for streaming media, so Plex best get on board soon. Otherwise they will lose me as a Plex Pass customer. I know of several other DVR solutions and it looks like I need to start searching for another media server solution as well. At least I now won't have to waste any more of my time trying to fix this problem.

  • kinoCharlinokinoCharlino Posts: 1,186Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Please try enabling ‘transcode’ on the server. It's possible its because you have mpeg2 recordings.

    Search our Knowledge Base for more help

  • dragonmeldragonmel Posts: 627Members, Plex Pass Plex Pass

    yeah.. but you have the FEATURE to pay for plex pass from apple tv now.. arent you stoked!!! ???

  • dragonmeldragonmel Posts: 627Members, Plex Pass Plex Pass

    we need to press the openpht guys into getting a developer account with apple so they can port the ONLY plex client that WORKS

  • WillParWillPar Posts: 9Members, Plex Pass Plex Pass

    To elaborate on my problem, I previously used Argus TV to record my OTA shows. I was always able to play HD 1080 mbps (.ts) recordings from Argus without any difficulty in Plex. At that time I was using an Apple TV3 running PlexConnect. This spring I signed up for the Plex Pass to use the Plex DVR. About that same time I purchased an Apple TV4 and started using the new Plex app.

    At some some point after switching over to the Plex DVR this past spring, HD 1080 recordings started to "pause" as if buffering during playback. During this pause, if I hit the "play/pause" button twice on my Apple remote, the recording will start playing again immediately. If I do nothing, it may take 20 or 30 seconds to start again on its own.

    So it is only after changing to Plex DVR and the Plex Apple TV4 app that I started having difficulties. Additionally, I have one HD 1080 show that was recorded 18 months ago using Argus. I know for certain I played that 4 hour recording multiple times in PlexConnect with no problem shortly after I recorded it. I tried it again this week and it now hangs repeatedly on the AppleTV4. All of my problems seem related to the new Plex app for Apple TV4. (I no longer have PlexConnect setup on my ATV3 so I can't test with it now.)

    I think something changed in the new Plex app for Apple TV4 that wasn't happening in PlexConnect. I suspect this is the age-old problem of new applications being more resource intensive than older apps. I also suspect it has me bumping against the upper limits of my CPU. My CPU has a benchmark of 2,585 so it should be sufficient to play HD 1080 content (as it did previously), but that doesn't leave me with much extra if the new Plex app needs extra CPU resources.

    To "kinoCharlino" please explain what you mean by enabling transcode? My problem is with .ts files recorded with Plex DVR. Plex is transcoding when I play these recordings. I can see that in Task Manager. I have transcode limit set to 1. I assume that pertains to optimize which I hope I don't need to start using.

    I am still investigating...VLC has some issues I don't like.. it doesn't play closed captions and I had an instance when it didn't play smoothly. I'm wondering if closed captions require excessive resources? Argus TV didn't record closed captions.

    I'm still working on this and will report again if I get this resolved. I'm still actively pursuing a solution. If anyone from Plex can provide assistance, it will be appreciated.

  • WillParWillPar Posts: 9Members, Plex Pass Plex Pass
    Accepted Answer

    It is starting to look as if my problem is resolved by updating the driver for my Realtec Ethernet adapter. There was a new driver for Windows 10 (upd. 7/27) and since updating the driver I've been successfully playing 1080p HD shows all afternoon with no problems. I'm guessing either the Windows 10 Anniversary and/or Creators update combined with my old driver caused some Ethernet performance issues on my home network. (Fingers crossed.)

  • WillParWillPar Posts: 9Members, Plex Pass Plex Pass

    I'm not sure how this forum is moderated, but as the OP I'm requesting this question and topic be deleted. I've made a number of changes to my system and now Plex is running just fine. The problems I encountered were specific to my system and unrelated to Plex. The Plex application as written functions perfectly well and I'm very happy as a Plex Pass member.

  • kinoCharlinokinoCharlino Posts: 1,186Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @WillPar said:
    I'm not sure how this forum is moderated, but as the OP I'm requesting this question and topic be deleted. I've made a number of changes to my system and now Plex is running just fine. The problems I encountered were specific to my system and unrelated to Plex. The Plex application as written functions perfectly well and I'm very happy as a Plex Pass member.

    Sorry I missed your ping earlier this week. Thanks for providing us an update, glad to see things are working for you! Just to give you a bit of background, the feature I was referring to is in the DVR settings that enables transcoding of content to h264 as it is being recorded. In your server settings (in Plex Web), go to Live TV & DVR and click on the orange gear next to your tuner. Then select Transcode.

    Search our Knowledge Base for more help

  • WillParWillPar Posts: 9Members, Plex Pass Plex Pass

    kinoC, Thanks for the followup. I had seen this setting, but didn't fully understand what it did. I was reluctant to use it because it was labeled Experimental, and because it required a fast CPU. I tried it today and now see how incredibly useful this setting is. First I tried it on a 30 minute HD broadcast. Ran fine, transcoding during the recording, and playback was excellent without any extra CPU usage (because that all occurred during the recording). Next I raised my transcode limit to 2 and scheduled two simultaneous 30 minute HD recordings. I wasn't sure my CPU (Intel Core i3-530 2.93Ghz) could transcode two streams simultaneously. Now I know it can. Transcoding of the two simultaneous HD streams continued for about 20 minutes beyond the recording end times (which concerned my initially), but when it finished, both shows had recorded fine and both played back fine. This is great. Now I should never have to worry about playback glitches, perhaps even when running my network monitoring utility that caused a lot of my problems initially.

    My only concern is that during the extra 20 minutes of transcoding (beyond the recording end times), both of my HDHomeRun tuners stayed busy. If I had scheduled another recording immediately following the simultaneous recordings, I'm guessing that no tuner would have been available. I'm wondering if I raise my transcode limit to 3 or 4, if that would release the tuners at the end of the recording time. I have to test that later. Even if it doesn't release the tuners, I'll just know that is a limitation of my CPU.

    I suggest you remove the [Experimental] tag on this setting and put a more complete description so users won't be reluctant to use it. I now see how useful this setting really is. I'm extremely pleased with how my Plex system is functioning now.

Sign In or Register to comment.