If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

New install, added library now barely works

jmorrison@bogomips.comjmorrison@bogomips.com Posts: 2Members

I installed Plex on ubuntu, but have problems after adding media.

Through the web interface I get timeouts and loading the dashboard. The iOS app sees some media then hangs when I pick a series.
I've turned on debug/verbose logging but nothing stands out but there are slow queries.

The Plex Media Server process is using all the CPU. strace -f shows that the process is forking continually - it looks like it's the Script host. Which logs should I look in? tail -f of the server log doesn't show much unless a browser connects.

Noticed a problem with remote access, seemed to be caused by secondary routes/interfaces. Seemed to fix itself after rebooting.

Answers

  • ChuckPAChuckPA Posts: 18,382Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Please don't get lost in trying to analyze how PMS works at the process / strace level. It'll drive you crazy in no time.

    Let's break out your issues and solve them one at a time?

    1. PMS consumes all the CPU doing ___________ ? (what please exand on this)
    2. Remote access has a problem with multiple routes on your machine. Makes sense. We'll get to that with proper logs.
    3. iOS app hangs when browsing media. Not sure if related but perhaps networking from the Server to the App given #2 above
    4. Log files. Please set to Debug level, and let's see what it shows. Do a 'Update Libraries" first. This is a good general indicator, then Settings - Server - Help - Download Logs and attach that ZIP file here with your next post. I'll take a look at it

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support forums: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility List

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • jmorrison@bogomips.comjmorrison@bogomips.com Posts: 2Members
    1. I found the "optimize" button and that seems to have calmed it down. Automagically running this would be a nice touch.
    2. remote access fixed itself after reboot but didn't work on first install. As a precaution I also swapped IP addresses with eth0 and eth0:1 in case plex make assumptions about IP addresses and rebooted again. When it wasn't working it was complaining about NAT and it was using the wrong IP address.
    3. iOS app works now

    so seems all good now

Sign In or Register to comment.