If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Endpoint /client returns MediaContainer size 0

curtisghansoncurtisghanson Posts: 4Members, Plex Pass Plex Pass

Plex Server: 1.8.0.4109
Ubuntu: 16.04.2 LTS

I try to make a GET request to the

http:[IP_ADDRESS]:32400/clients?Plex-X-Token=[TOKEN]

endpoint and all I ever get is:

<?xml version="1.0" encoding="UTF-8"?>
<MediaContainer size="0"></MediaContainer>

in the response body.

I have tried it within my local network, over the WAN, and even performed it directly on the server using localhost. I have opened all ports and disabled the firewall (ufw) and still nothing. I have also had media playing on the browser and my Android app while making the request. The settings on the app advertise the ability to control them is turned on.

No matter what IP address I try (even with every port needed open and the firewall disabled) I never get any content. Here is the relevant information in the log.

Aug 09, 2017 13:54:53.325 [0x7f5c80fff700] DEBUG - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
Aug 09, 2017 13:54:53.326 [0x7f5c80fff700] DEBUG - Auth: authenticated user 1 as curtisghanson
Aug 09, 2017 13:54:53.326 [0x7f5c80fff700] DEBUG - Auth: Came in with a super-token, authorization succeeded.
Aug 09, 2017 13:54:53.326 [0x7f5c53bfb700] DEBUG - Request: [198.xxx.xxx.xxx:34386 (WAN)] GET /clients (13 live) GZIP Signed-in Token (curtisghanson)
Aug 09, 2017 13:54:53.327 [0x7f5c80fff700] DEBUG - Completed: [198.xxx.xxx.xxx:34386] 200 GET /clients (13 live) GZIP 0ms 397 bytes (pipelined: 1)

Does anyone have any suggestions as to why I can't get anything on this? Even the log shows '13 live' clients which I believe are the devices I should be able to control? I've Googled the **** out of this and I can't find even a hint as to what causes it.

Comments

This discussion has been closed.