If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Audio transcoding starts transcoding video with subtitles. Is a bug. Sony TV and Andoid Smart Box

chupa.livornochupa.livorno Posts: 6Members, Plex Pass Plex Pass

Good evening I have a Smart Android Box specifically for a MXQ Pro II. In the settings I selected only image formats for the subtitles but when I press play makes me transcoded to the video even though the subtitle format is SRT I believe that before the last update this did not happen. How can I fix it for Direct Play or Direct Stream? Thanks

Answers

  • chupa.livornochupa.livorno Posts: 6Members, Plex Pass Plex Pass
    edited August 12

    Good morning, today I have had some time and I did some tests.
    I used an MKV file with H264 codec and subtitles in SRT and audio AC-3, I set the quality to "Maximum" after I set the subtitles to "only image format" after I did the following tests:

    Test 1
    Subtitle enable: ✔
    Device Support AC-3:✘
    Device Support E-AC-3:✘
    Result Video: Transcode H264 to H264
    Result Audio: Transcode AC-3 to AAC

    Test 2
    Subtitle enable: ✘
    Device Support AC-3:✘
    Device Support E-AC-3:✘
    Result Video: Direct Stream
    Result Audio: Transcode AC-3 to AAC

    Test 3
    Subtitle enable: ✔
    Device Support AC-3:✔
    Device Support E-AC-3:✔
    Result Video: Direct Play
    Result Audio: Direct Play

    Test 4
    Subtitle enable: ✘
    Device Support AC-3:✔
    Device Support E-AC-3:✔
    Result Video: Direct Play
    Result Audio: Direct Play

    As you can see, enabling or disabling "Device Support AC-3" and "Device Support E-AC-3" triggers transcoding for the video if a subtitling is selected, but why does audio affect subtitles? If the SRT subtitle is supported by the device and I set "only image format" it should not start the transcode
    Cunningly do some Plex developers control this situation?

    Thanks

    PS: Same as with a Sony TV The XE90 that when selected a DTS-HD 7.1 audio and SRT subtitles starts audio transcoding from DCA to AAC and that's fine, but also part of the video transcoding from H264 to H264

  • ShasdoShasdo Posts: 1Members

    Hi

    Does your problem has been solved?

    Because I bought last week a Xaiomi Mibox 4K and I think I have almost the same problem.

    I run PMS Version 1.8.4.4249 on a Synology DS412+
    I tried two different movie , each one is an MKV with embeded SRT.

    Movie 1: H264 + AAC
    Subtitle enable: ✘
    Result Video: Direct Play
    Result Audio: Direct Play

    Movie 1: H264 + AAC
    Subtitle enable: ✔
    Result Video: Direct Play
    Result Audio: Direct Play

    Movie 2: H264 + DTS
    Subtitle enable: ✘
    Result Video: Direct Stream
    Result Audio: Transcode DCA -> AAC

    Movie 2: H264 + DTS
    Subtitle enable: ✔ (same with sidecar SRT)
    Result Video: Transcode H264 -> H264
    Result Audio: Transcode DCA -> AAC

    Did you find a solution?

    Thx

Sign In or Register to comment.