If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

How to get metadata for the first episode of Stargate SG-1 when using DVD order?

percysnoodlepercysnoodle Posts: 10Members ✭✭

I've added Stargate SG-1 and Stargate Atlantis to my library, using the DVD order option under the advanced settings for the series. Everything has matched correctly, except for the first episode of SG-1 which has no metadata at all. On TVDB, the opening two-parters for both shows are listed using the usual notation for two-parters, except that SG-1 lists them as 1.1 and 1.2 [1], whereas SGA lists them as 1.0 and 1.1 [2]. According to their wiki, SG-1 is correct and SGA is wrong [2], so I doubt I could get them to change the SG-1 listing.

How can I fix the match for the one incorrectly-matched episode?

Thanks,

--
Simon

[1] http://thetvdb.com/index.php?lid=7&seasonid=4147&seriesid=72449&tab=season&order=dvd
[2] http://thetvdb.com/index.php?lid=7&seasonid=1192&seriesid=70851&tab=season&order=dvd
[3] http://www.thetvdb.com/wiki/index.php?title=DVD_Order

Best Answer

  • percysnoodlepercysnoodle Posts: 10Members ✭✭
    Accepted Answer

    Thanks. In the end, I was able to obtain an adequate match by moving my SG-1 folder away, emptying the trash and clearing bundles, and then creating a new SG-1 folder. I moved just the first episode back and set the series to Aired Order. Once the metadata had loaded for that episode, I set the series to DVD order and moved the other episodes back. I don't know how stable this solution will be - if it loses the metadata for the first episode I may try your method - although I have disabled local file metadata since it causes other problems.

    Thanks again,

    --
    Simon

Answers

  • OttoKernerOttoKerner Posts: 25,129Members, Plex Pass, Plex Ninja Plex Ninja

    How is the file named?

    Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • percysnoodlepercysnoodle Posts: 10Members ✭✭

    It's named "Stargate SG-1 s01e01.m4v", in a folder named "Stargate SG-1". The file named "Stargate SG-1 s01e02.m4v" is correctly matched.

  • OttoKernerOttoKerner Posts: 25,129Members, Plex Pass, Plex Ninja Plex Ninja

    You may have hit a limitation in Plex's implementation of the DVD order.
    Plex doesn't support sub-divisions of episode numbers. So I will probably never fetch meta data for this episode.
    As a workaround, embed the episode title and the description into the m4v file yourself. Then 'Refresh Metadata' of the show

    Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • percysnoodlepercysnoodle Posts: 10Members ✭✭
    Accepted Answer

    Thanks. In the end, I was able to obtain an adequate match by moving my SG-1 folder away, emptying the trash and clearing bundles, and then creating a new SG-1 folder. I moved just the first episode back and set the series to Aired Order. Once the metadata had loaded for that episode, I set the series to DVD order and moved the other episodes back. I don't know how stable this solution will be - if it loses the metadata for the first episode I may try your method - although I have disabled local file metadata since it causes other problems.

    Thanks again,

    --
    Simon

  • OttoKernerOttoKerner Posts: 25,129Members, Plex Pass, Plex Ninja Plex Ninja

    @percysnoodle said:
    although I have disabled local file metadata since it causes other problems.

    Instead of outright disabling LMA, you can pretty much rule out interference from embedded metadata with the matching process by changing the order of the metadata agents.
    This has the benefit that you can still use embedded metadata as a fallback if the online sources don't deliver.
    And of course this also enables external subtitles and local posters/artwork.

    Go to Settings - Server - Agents - Shows - TheTVDB
    In there, grab the line 'Local Media Assets' (LMA) with your mouse and drag it downwards, so it ends up being at the bottom of the stack of active agents.
    Repeat the same under
    Settings - Server - Agents - Shows - TheMovieDatabase
    +
    Settings - Server - Agents - Movies - Plex Movie
    +
    Settings - Server - Agents - Movies - TheMovieDatabase

    But do keep 'LMA' activated.

    Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
Sign In or Register to comment.