Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Unable to connect to content server

colotticolotti Posts: 55Members, Plex Pass Plex Pass

Never been able to get this working from SmartHub TV with app from Samsung App Store. Tried again today with no luck. What's the deal to make it work?

App and PMS are both latest code. I can browse all the shows and movies it's connected just won't play anything

Comments

  • colotticolotti Posts: 55Members, Plex Pass Plex Pass

    Seems to work only on direct stream not auto or direct play.

  • OrcaOrca Plex for Samsung Developer Posts: 7,617Members, Plex Pass, Plex Ninja Plex Ninja

    You are probably using secure connections, if s,o please set them to preferred on the server and off on the app.
    With Direct streaming or Transcoding , the server handles the certificates and that works, but not all models accept the Plex certificates when in direct play.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • colotticolotti Posts: 55Members, Plex Pass Plex Pass

    Server is set to preferred but need to check the app to disable. Where is it in the app?

  • OrcaOrca Plex for Samsung Developer Posts: 7,617Members, Plex Pass, Plex Ninja Plex Ninja

    It's under preferences > sysytem.

    Tip: you can download the manual here.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • manolodfmanolodf Posts: 6Members, Plex Pass Plex Pass
    edited June 7

    Hi Orca,
    I have a couple of Samsung tvs that were working totally fine, then out of the blue began having issues where anything attempted to play on plex gave an error of "Unable to connect to the content server" . My Plex Server Security settings is set to "preferred" as you mentioned, and Secure Settings on the Samsung Smart TV App are disabled.

    The only way to get them to play anythign and not give the error is to set the Player Playback to "Transcode" instead of "Auto" but that is just so intensive on the server, and those TVs before used to Direct Play pretty much everything!

    Not sure what happened from one day to another. Is there anything else I can test or shoudl try?

    This is one of them (2012 E-Series with Latest Firmware 2004.0):

    This is the other Samsung also with latest firmware:

  • OrcaOrca Plex for Samsung Developer Posts: 7,617Members, Plex Pass, Plex Ninja Plex Ninja

    The most obvious would be that the file can't be direct played by your model, but the app should tell you if so.
    I know 2012 models can't play HEVC for instance.

    Also check if the server maybe has a limit set for the download speed. (it's under remote access)
    If so the server will not allow you to use more bandwidth than given, which will result in transcoding, to reduce it.

    To be really sure, enable "Send Debug to PMS" and check the Plex media server.log for [PlexForSamsung] messages
    They should show exactly why it picks transcoding instead of direct play.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • manolodfmanolodf Posts: 6Members, Plex Pass Plex Pass

    Thanks for the Reply Orca,
    I checked and I have no speed limit under remote access, and maybe I did not explain it properly.
    I do not mind when it forces transcode when it needs to, its bound to happen. But what happened from one day to another a while back is that the user was getting the "Unable to connect to the content server" and absolutely nothing was playing, not a single thing, when before it played just fine, some direct play, some transcoding if it needed to, but it decided on its own. The only way to get those 2 tvs (2012 and 2015) to play anything at all was to go into player and change it from "Auto" to "Transcode" and force transcoding on everything, having it on Auto will just simply not play any media at all.

  • OrcaOrca Plex for Samsung Developer Posts: 7,617Members, Plex Pass, Plex Ninja Plex Ninja

    The only way I can think of, is that transcoding is needed because of certificates being used.
    I know 2012 does not support playback over https, but it will still show all movies in the app.
    Are you sure that the server you connect to isn't running https?

    Check the log file > how to create one

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • manolodfmanolodf Posts: 6Members, Plex Pass Plex Pass
    edited June 7

    I know for a fact both of those users' tvs played content perfectly before, and few months ago, it just started giving that cannot connect to content server error.

    Yesterday I checked to make sure on both that in the App secure connections was indeed off.

    Here is the server, that also has it set to preferred, and no certificates of any sort .

    I have asked the user if whenever they are home if they can change playback back to Auto and get the error a few times on different media to try and pinpoint some logs. Any other tests I can do? Those are the only ones having issues, my samsung tv works fine but its 2016 version, as well as Roku TVs. Would any custom access server URLs affect this at all?

  • OrcaOrca Plex for Samsung Developer Posts: 7,617Members, Plex Pass, Plex Ninja Plex Ninja

    Something must have changed. Things do not change overnight on their own.
    The trick is to find out what is different now. New router, firewall, changed configurations?
    Is your server logged in to your Plex account? If not, the info in the cloud could be wrong and clients may have to connect through relay, which has a bandwidth limitation.
    Check how the server is listed on the client and see if that matches with your actual IP address.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • manolodfmanolodf Posts: 6Members, Plex Pass Plex Pass

    I know and I cant pinpoint the issue, and unfortunately they did not tell me the exact time, just said a few months back. The only thing I can figure is that a Plex Server update at some point caused it.

    -The router for sure has been stable as I have not switchced routers.
    -The server is logged in to my account (should i log out and log back in?)
    Where do they have to go to view how the server is listed on the client on the samsung? So i can have them send me pictures of it.

    Anything specific to log? Grab the logs of them getting the errors? Change secured from Prefered to disabled? Anything you can think to try or first get some logs?

  • OrcaOrca Plex for Samsung Developer Posts: 7,617Members, Plex Pass, Plex Ninja Plex Ninja

    If a user connects to your server, ask them to temporarily enable the option "Send debug to PMS" and reproduce the error.
    Then grab the Plex media server.log from your server. It should have lines with [PlexForSamsung] in it.
    It should show, what's happening

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

Sign In or Register to comment.