If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

No Audio When Playing Music

interconnectinterconnect Posts: 195Members, Plex Pass Plex Pass
edited August 13 in Roku

Sometimes when I play music I get no audio. Usually there is no sound at all, including system click sounds. Other times there will be Roku click sounds but no audio from Plex only. Restarting the Roku fixes the problem every time, until after a while it happens again and have to reboot again.

I am running PMS 1.8.0, Plex 4.4 build 1 on Roku 7.7.0 build 4117-29 firmware on Roku Ultra connected via optical to receiver.

Comments

  • interconnectinterconnect Posts: 195Members, Plex Pass Plex Pass

    I took of the video of the issue:

    I did a little more research and I've found that music stops working only after a movie has been played. One the Roku is restarted it works againg, again, until a movie is played. Doesn't matter if the movie has DD or DTS audio, if it's in a playlist (or you browse directly to the file itself), or which movie or audio track is played; it happens with every single one I tested.

  • shopgirl284shopgirl284 Posts: 2,700Members, Plex Pass, Plex Ninja, Forum Moderator Plex Ninja

    Does this only occur when playing the media on the Plex app for Roku or does it occur on other Plex player apps? (If you do not have another Plex device, you can use the Plex Web from the browser on any computer, tablet of phone.)

    Is the movie being transcoded or the music you play afterwards? If so, does changing the Transcode Format under the Plex app for Roku Settings > Video > Transcode Format make any difference?

    Attaching the Roku log would also help along with your Roku's audio settings.

    Many issues and questions can be resolved by reviewing the Plex Support Documentation
    Providing details about your issue, Plex setup, and including log files are important when when asking for help on the forums.
    See Log Files
    Before posting channel plugin questions or issues, please review the pinned threads at the top of the Channel Plugin forum:
    READ FIRST: Guidelines for Posting Channel Plugin Issues/Questions and Things to Check First
    FAQ for Channel Plugin FAQ

  • interconnectinterconnect Posts: 195Members, Plex Pass Plex Pass
    edited August 15

    @shopgirl284 Here's the answers to all your questions (hopefully):

    1. I tried this on the web app, iOS app, Plex on Roku 3 and Plex on the Roku Ultra. All these were the latest versions at the time of this writing, including the Roku firmware. Only the Roku Ultra (connected via optical) exhibits the issue.

    2. On the Roku Ultra, it will transcode depending on the audio format. Currently DTS playback is broken on the Ultra (as to which there are numerous reports on the Roku forums) and results in a huge audio sync delay so I have the Roku audio settings to DD only; it'll transcode DTS to DD then. Regarding music, all music I've tested Direct Plays; all my music is high bitrate mp3. I tried changing the Transcode Format to the other two options and it did not make a difference at all; issue was still present.

    3. I did the Remote Logging that goes to Plex automatically and reproduced the issue. Are you able to see that or do I need to get them manually? My Roku audio settings are... Audio Mode: Auto (Dolby D); HDMI and S/PDIF: Dolby D.

  • interconnectinterconnect Posts: 195Members, Plex Pass Plex Pass

    @shopgirl284 Any feedback on this?

  • shopgirl284shopgirl284 Posts: 2,700Members, Plex Pass, Plex Ninja, Forum Moderator Plex Ninja

    I would post Logs manually.

    Advanced audio issues on the Roku would not be my strong point, but with more info about your issue and the Logs, one of the users with more experience with this can help.

    I have also seen a few posts about HDMIs causing random sound issues on Roku and that either unplugging and plugging back in the HDMI cable or just changing the HDMI inputs on your TV remote and then going back can sometimes fix the sound issues. For example- https://nhlifefree.com/2015/03/01/roku-3-easily-fixing-the-no-sound-problem-with-hdmi-connection/. I found that in a google search, it may not work, but it is worth a try

    Many issues and questions can be resolved by reviewing the Plex Support Documentation
    Providing details about your issue, Plex setup, and including log files are important when when asking for help on the forums.
    See Log Files
    Before posting channel plugin questions or issues, please review the pinned threads at the top of the Channel Plugin forum:
    READ FIRST: Guidelines for Posting Channel Plugin Issues/Questions and Things to Check First
    FAQ for Channel Plugin FAQ

  • interconnectinterconnect Posts: 195Members, Plex Pass Plex Pass

    @shopgirl284

    Ok, attached is the log. I played a song first, which worked no problem, next played a movie which worked no problem, then went back and played the same song again which did not have any audio. I also played two additional songs, which both did not have any sound.

    Also, my Roku Ultra is connected to my receiver via optical and not HDMI, so it's not that.

  • interconnectinterconnect Posts: 195Members, Plex Pass Plex Pass

    Anyone have any ideas what's going on?

  • PutarPutar Posts: 2Validating, Plex Pass Plex Pass

    I am having the same problem with Roku ultra, except that my music sound doesn't work regardless of whether or not I've just played a movie. Playing a music file cuts the audio, including app sounds. Logging out and back into PLEX restores the sounds, but I still can't play music.

  • PutarPutar Posts: 2Validating, Plex Pass Plex Pass

    After some fiddling, I found that two albums will play, and actually bring the audio sounds back if I select them, but none of my other music will. I should add that the last time I played music on PLEX, (about two weeks ago) there were no issues. I think the problem might be that PLEX is a glitchy platform with inadequate maintenance put into making sure it works properly.

Sign In or Register to comment.