If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

My plex keeps crashing every other day.. Does anyone else experience the same?

marenodomarenodo Posts: 4Members ✭✭
edited August 11 in Linux

As above stated, my plex keeps crashing. I think it might have something to do with me watching from an Ipad, but that's just speculations.. Anyone else with the same problem, or eventually a fix?
tya

Answers

  • sa2000sa2000 Posts: 29,447Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    If it is crashing there would be relevant info in the server logs

    Please attach the logs here to be downloaded on restart after next crash

    See
    https://support.plex.tv/hc/en-us/articles/201643703-Reporting-issues-with-Plex-Media-Server
    https://support.plex.tv/hc/en-us/articles/200250417-Plex-Media-Server-Log-Files

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • marenodomarenodo Posts: 4Members ✭✭

    This here should be my logs. It happens quite a lot

  • sa2000sa2000 Posts: 29,447Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Strange things showing up in the logs

    • on launch after a crash Plex Media Server first kills any residual processes from time before the launch. The logs show these accumulating with multiple processes being killed when only one should be there. As if the kill is not working and you do end up with multiple instances of processes
    • Server is seeing a lot of other servers. Are you on a big network a 10.0.xx.xx network rather than 10.0.8.xx ?
    • And the WAN IP for the server is being returned by the router as 127.0.0.1 !

    Some extracts to show this

    Server IP Address info

    Aug 11, 2017 15:50:50.869 [0x7fbd12c40800] DEBUG - Network interfaces:
    Aug 11, 2017 15:50:50.869 [0x7fbd12c40800] DEBUG -  * 1 lo (127.0.0.1) (loopback: 1)
    Aug 11, 2017 15:50:50.869 [0x7fbd12c40800] DEBUG -  * 3 eth0 (10.0.9.8) (loopback: 0)
    

    and server name is antaeus

    Recorded public IP address in plex.tv is 185.21.xxx.xxx

    But the router when interrogated returned 127.0.0.1 as the public IP address - how is that possible

    Aug 11, 2017 14:50:17.804 [0x7f4299fff700] DEBUG - NAT: PMP::getPublicIP, Received public IP from router: 127.0.0.1
    Aug 11, 2017 14:50:17.804 [0x7f4299fff700] DEBUG - PublicAddressManager: got WAN IP 127.0.0.1 from router
    

    and the servers that are being seen are all these on 10.0.7.x and 10.0.9.xx - just wondering if that is actually your intention

    Aug 11, 2017 14:50:14.544 [0x7f42953ff700] DEBUG - NetworkServiceBrowser: SERVER arrived: 10.0.9.29 (antaeus)
    Aug 11, 2017 14:50:15.415 [0x7f42953ff700] DEBUG - NetworkServiceBrowser: SERVER arrived: 10.0.8.24 (FeralHosting Antaeus)
    Aug 11, 2017 14:50:15.825 [0x7f42953ff700] DEBUG - NetworkServiceBrowser: SERVER arrived: 127.0.0.1 (antaeus)
    Aug 11, 2017 14:50:15.965 [0x7f42953ff700] DEBUG - NetworkServiceBrowser: SERVER arrived: 10.0.8.119 (antaeus)
    Aug 11, 2017 14:50:15.981 [0x7f42953ff700] DEBUG - NetworkServiceBrowser: SERVER arrived: 10.0.8.113 (antaeus)
    Aug 11, 2017 14:50:15.996 [0x7f42953ff700] DEBUG - NetworkServiceBrowser: SERVER arrived: 10.0.9.16 (FH_Server)
    Aug 11, 2017 14:50:16.015 [0x7f42953ff700] DEBUG - NetworkServiceBrowser: SERVER arrived: 10.0.8.74 (Cloud Server)
    Aug 11, 2017 14:50:16.032 [0x7f42953ff700] DEBUG - NetworkServiceBrowser: SERVER arrived: 10.0.9.42 (antaeus)
    Aug 11, 2017 14:50:16.050 [0x7f42953ff700] DEBUG - NetworkServiceBrowser: SERVER arrived: 10.0.8.96 (Séries TV, Antaeus)
    Aug 11, 2017 14:50:16.069 [0x7f42953ff700] DEBUG - NetworkServiceBrowser: SERVER arrived: 10.0.9.38 (antaeus)
    Aug 11, 2017 14:50:16.087 [0x7f42953ff700] DEBUG - NetworkServiceBrowser: SERVER arrived: 10.0.8.124 (antaeus)
    Aug 11, 2017 14:50:16.119 [0x7f42953ff700] DEBUG - NetworkServiceBrowser: SERVER arrived: 10.0.9.21 (Minh)
    Aug 11, 2017 14:50:16.137 [0x7f42953ff700] DEBUG - NetworkServiceBrowser: SERVER arrived: 10.0.7.123 (AO)
    Aug 11, 2017 14:50:19.527 [0x7f42953ff700] DEBUG - NetworkServiceBrowser: SERVER arrived: 10.0.9.5 (antaeus)
    

    and regarding the crashes - i need to understand what was happening
    We have a set of logs that go up to Aug 11, 2017 02:45:28
    The next log file starts at Aug 11, 2017 14:50:10 - so was there a crash after 02:45:28 that you noticed at 14:50 and restarted the server?

    At 14:50 Plex Media Server found 42 residual processes from previous run and what is strange is that there 15 python com.plexapp.system processes, 6 Plex EAE Service processes and 10 Plex Tuner Service and on next relaunch these were still to be killed. So kill process is not working.

    This shows the attempts to kill old processes at the 14:50 launch

    This session lasted till Aug 11, 2017 15:50:37 and 9 seconds later there was a relaunch of Plex Media Server. Did you do that ?
    And the old processes all but 4 were still there needing to be killed again

    I am going to get a linux person pick this up

    What is the platform? I see the linux version shows as

    ubuntu PC x86_64 - build: linux-ubuntu-x86_64 ubuntu
    Linux version: 4.12.4-feral (#2 SMP Sat Jul 29 19:17:51 BST 2017)
    

    And one final question - why are you still on version 1.5.5 of Plex Media Server?
    The current Public Releasde version is 1.7.5

    Please could you look into my observations and issues highlighted and update the thread

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • sa2000sa2000 Posts: 29,447Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    Moving the thread to the linux forum

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • ChuckPAChuckPA Posts: 18,376Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member
    edited August 11

    @marenodo

    Would you please go to the host, open a Terminal (shell) window and type the following, capture all the text output, place in a file and attach here ?

    sudo sh
    /bin/df -m
    ps -ef
    ifconfig
    netstat -an
    free
    ipcs
    

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support forums: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility List

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
  • marenodomarenodo Posts: 4Members ✭✭

    Hi there, sorry for the late answer.

    I do not have root acces. Or acces to sudo

  • Peter_WPeter_W Posts: 2,110Members, Plex Pass, Plex Ninja Plex Ninja
    edited August 12

    Then you need to ask the person in charge of the server to upgrade Plex to the latest version, check if the issue persists and if it does then ask him to perform the diagnostics that Chuck requires.

    Server running VMware/NAPP-IT/OmniOS/ZFS
    Lian Li PC-Z70 - Corsair AX760 - Intel E3-1245V3 w Noctua NH-U14S CPU cooler - Supermicro X10SAE - 32GB Kingston ECC RAM - Intel 530 SSD 80GB - LSI MegaRAID 9240-8i (flashed to IT mode) - 8 3TB WD RED in Raid-Z2

    Please check the support site first - https://support.plex.tv/hc/en-us :: No PM's unless requested ::

  • sa2000sa2000 Posts: 29,447Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member
    edited August 12

    There are serious issues on that environment if "kill process" does not work and has no permission to do that and to be on a class b network - is that wise ?

    and to have many servers with the same name

    and for the router to respond with a response indicating 127.0.0.1 is the public WAN IP Address - that is not right

    I do not think the issue is the version of Plex Media Server but more, the environment that the server is running in - however, the upgrade should be done but in a sane environment and any issues should be raised by the server owner that has root access

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • ashmandiasashmandias Posts: 29Members ✭✭

    @sa2000 said:
    There are serious issues on that environment if "kill process" does not work and has no permission to do that and to be on a class b network - is that wise ?

    Feral uses network namespaces to run 1 instance of Plex per user. The kill command Plex seems to be issuing is attempting to kill processes owned by other users (and is rightly failing).

    and to have many servers with the same name

    Feral has unique names for every host -- but since they are using network name spaces and running multiple Plex processes per server, it may appear otherwise.

    and for the router to respond with a response indicating 127.0.0.1 is the public WAN IP Address - that is not right

    I believe that this is an artifact of the network name spaces. That's the route out to the public internet from the private namepace.

    I do not think the issue is the version of Plex Media Server but more, the environment that the server is running in - however, the upgrade should be done but in a sane environment and any issues should be raised by the server owner that has root access

    The Feral servers are a sane environment, once you step back and look at the bigger picture.

  • ChuckPAChuckPA Posts: 18,376Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    To bring closure here from your other threads. Debian is not officially supported. That kernel build and environment (Feral's namespaces) is a YMMV (your mileage may vary) and isn't supportable.

    Please DISABLE Verbose logging until requested

    Please search before posting

    Primary support forums: Linux, Synology, and QNAP

    Please remember to report back. This benefits others.

    Useful links

     Installation and Basic Setup |  Media Preparation (How to name your media files)  |  Linux Permissions 

     Handling TV Specials | Handling Movie extras  |  Nas Compatibility List

     Reporting Plex Server issues | Plex Media Server FAQ | Linux Tips

     

    Other useful guides: Local Subtitles | The Plex "dance" | Synology FAQ | PMS Release Announcements

    Hosts: Fedora, QNAP, Synology, most Linux distros in VM

    No technical support via PM unless offered

    Please remember to mark the appropriate answer(s) which solved your issue.

     
Sign In or Register to comment.