If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex playing some files too fast

diamondswdiamondsw "Vitriolic yet well-intentioned"Posts: 841Members, Plex Pass, Plex Ninja Plex Ninja
The Issue
Plex plays some files too quickly; seemingly at 150% or so of normal. Interestingly, this only occurs on my Mac Mini HTPC (32-bit Core Duo), but works properly on my testbed MacBook Pro (64-bit Core i7). I don't know how I can reset the client without affecting the server on the Mac Mini.

My Setup
  • Plex Media Server runs on a Mac Mini (32-bit Core Duo)
  • Media is located across a gigabit ethernet network on a DroboFS, mounted via AFP
  • HTPC is the same Mac Mini as PMS runs on
  • HTPC connects to a receiver via DVI-to-HDMI for video and optical for audio
  • Testbed is a MacBook Pro (64-bit Core i7)

Most of that won't be relevant, but I include it for completeness. Full System Profiler reports here.

Plex Media Server Configuration
Hosted on Mac Mini, files on DroboFS via AFP
Language/subtitle settings as follows:

languagepreferences.png

Issue:	Plays back too fast, probably 150% of normal (Mac Mini only)
File:	Shares/Anime/Series/Lost Universe/Lost Universe - S01E01.mkv
MD5:	c5ce51bdd1608bec3106c2ecc8ef0fd1

* * * MediaInfo Mac 0.7.36.0 file analysis report.
* * * MediaInfo Mac is ©2010 by Diego Massanti - http://mediainfo.massanti.com
* * * MediaInfoLib by Jerome Martinez - http://mediainfo.sourceforge.net
Created on: Jul 20, 2011 1:28:46 AM CDT
Report for file: Lost Universe - S01E01.mkv

General / Container Stream #1
	Total Video Streams for this File.................1
	Total Audio Streams for this File.................2
	Total Subtitle Streams for this File..............2
	Video Codecs Used.................................DivX 5
	Audio Codecs Used.................................AAC LC-SBR / AAC LC-SBR
	SubTitle Codecs Used..............................UTF-8 / VobSub
	Available Sutbitle Languages......................English / English
	File Format.......................................Matroska
	Play Time.........................................22mn 52s
	Total File Size...................................233 MiB
	Total Stream BitRate..............................1 423 Kbps
	Title (Tag).......................................[a4e]Lost Universe - 01 - A Blade of Light Shines
	Encoded with......................................mkvmerge v0.8.9 built on May  6 2004 19:48:43
	Encoding Library..................................libebml v0.7.0 + libmatroska v0.7.0
Video Stream #1
	Codec (Human Name)................................MPEG-4 Visual
	Codec (FourCC)....................................DX50
	Frame Width.......................................696 pixels
	Frame Height......................................520 pixels
	Frame Rate........................................29.970 fps
	Total Frames......................................41124
	Display Aspect Ratio..............................4:3
	Scan Type.........................................Progressive
	Color Space.......................................YUV
	Codec Settings (Summary)..........................BVOP
	Codec Settings (BVOP).............................Yes
	Codec Settings (QPel).............................No
	Codec Settings (GMC)..............................No warppoints
	Codec Settings (Matrix)...........................Default (H.263)
	Video Stream Length...............................22mn 52s 172ms
	Bit Depth.........................................8 bits
	Video Stream Title................................[a4e]Lost Universe - 01
	Video Encoder.....................................DivX503b1328p
	Video Stream Language.............................Japanese
Audio Stream #1
	Codec.............................................AAC
	Codec (FourCC)....................................A_AAC/MPEG4/LC/SBR
	Audio Stream Length...............................22mn 52s 159ms
	Number of Audio Channels..........................6
	Sampling Rate.....................................44.1 KHz
	Audio Stream Title................................Japanese Audio
	Audio Stream Language.............................Japanese
Audio Stream #2
	Codec.............................................AAC
	Codec (FourCC)....................................A_AAC/MPEG4/LC/SBR
	Audio Stream Length...............................22mn 52s 159ms
	Number of Audio Channels..........................6
	Sampling Rate.....................................44.1 KHz
	Audio Stream Title................................English Audio
	Audio Stream Language.............................English
Subtitle Stream #1
	Language..........................................English
	Format............................................UTF-8
	Codec ID..........................................S_TEXT/UTF8
	Codec Info........................................UTF-8 Plain Text
Subtitle Stream #2
	Language..........................................English
	Format............................................VobSub
	Codec ID..........................................S_VOBSUB
	Codec Info........................................The same subtitle format used on DVDs

Comments

  • diamondswdiamondsw "Vitriolic yet well-intentioned" Posts: 841Members, Plex Pass, Plex Ninja Plex Ninja
    No change in Plex 0.9.3.3.
  • KristijanKristijan Posts: 42Members, Plex Pass Plex Pass
    I have the same issues, but it's not the entire length of the movie/tv show...every now and then for < 5 seconds, the audio and video seem to speed up, but then it stops and it's fine for the rest of the show.

    I've only noticed it on .mkv files.

    -Kristijan
  • andrewlefandrewlef Posts: 18Members, Plex Pass Plex Pass
    Kristijan wrote:

    I have the same issues, but it's not the entire length of the movie/tv show...every now and then for < 5 seconds, the audio and video seem to speed up, but then it stops and it's fine for the rest of the show.

    I've only noticed it on .mkv files.

    -Kristijan


    I have the same issue. Using Mac Mini 5,1 (2011) with Core i5 output audio/video over HDMI and running Lion 10.7. It happens occasionally for a few seconds. It's pretty weird, but I don't think it's related to the more annoying audio issue currently plaguing Lion.
  • soundbitessoundbites Posts: 1Members
    Hi Guys,

    I have the some video files play too fast too. Only, all of them play too fast all the time.

    For example the, all the video sent from my iOS device to the AirVideo Plex plugin, diamondsw has written is 1.5x too fast.
    Some of the Apple trailers are too fast, example is "The Artist" trailer.
    Some of my anime mkv's are playing too fast (Bleach, Naruto, etc..)

    And while I'm typing this, I've figured out the problem!

    I'm running an Apogee mini-dac with Firewire at 192Khz sample rate from my mac mini. Some movies when my DAC is set at 192Khz, play too fast, when i set it to for example 48Khz they play fine.
    I know, Plex adjusts the video speed to the rate the audio is playing. So i guess, since Lion (10.7.0 and .1), for some video files, the amount of audio samples going to the OS X system is streamed too fast and plea is trying to keep the video speed up.

    My current solution is, switching my sample rate to 48Khz when running plea, and setting it back to 192Khz when playing my alas and flac files.
    But I hope the devs can find and fix this problem.

    btw. XBMC does not have this problem ;)
  • GoozeGooze Posts: 17Members, Plex Pass Plex Pass
    Are there any programs (like eyetv) running in the background? Try closing their windows and therefore their claim on the audio output. Maybe that helps.
  • chieferchiefer Posts: 15Members, Plex Pass Plex Pass
    Hi

    Rather than creating a new thread I thought Id post here. I have similar problems to the ones above.

    Re-installed Plex, with Lion.

    Have mkvs that are (but still in sync) playing too fast.

    Plays fine with VLC but in Plex, no go.

    Tried looking everywhere but can't find a solution! Hope someone can help :)
  • ScottRTLScottRTL Posts: 25Members, Plex Pass Plex Pass
    soundbites wrote:

    Hi Guys,

    I have the some video files play too fast too. Only, all of them play too fast all the time.

    For example the, all the video sent from my iOS device to the AirVideo Plex plugin, diamondsw has written is 1.5x too fast.
    Some of the Apple trailers are too fast, example is "The Artist" trailer.
    Some of my anime mkv's are playing too fast (Bleach, Naruto, etc..)

    And while I'm typing this, I've figured out the problem!

    I'm running an Apogee mini-dac with Firewire at 192Khz sample rate from my mac mini. Some movies when my DAC is set at 192Khz, play too fast, when i set it to for example 48Khz they play fine.
    I know, Plex adjusts the video speed to the rate the audio is playing. So i guess, since Lion (10.7.0 and .1), for some video files, the amount of audio samples going to the OS X system is streamed too fast and plea is trying to keep the video speed up.

    My current solution is, switching my sample rate to 48Khz when running plea, and setting it back to 192Khz when playing my alas and flac files.
    But I hope the devs can find and fix this problem.

    btw. XBMC does not have this problem ;)


    I have the same issue, all episodes of Drew Carey's Improv-a-ganza (MKV Files) play so fast, that everyone sounds like chipmunks, vlc doesn't have this issue during playback, plex has it for the entire episode. (Audio and video are in sync, just about 1.5 times normal speed)

    Mac OS X 10.7 Lion Mac Mini 2.52 GHz Core 2 Duo.

    Thanks
  • ZuiljiNZuiljiN Posts: 2Members
    edited September 2011
    ScottRTL wrote:

    I have the same issue, all episodes of Drew Carey's Improv-a-ganza (MKV Files) play so fast, that everyone sounds like chipmunks, vlc doesn't have this issue during playback, plex has it for the entire episode. (Audio and video are in sync, just about 1.5 times normal speed)

    Mac OS X 10.7 Lion Mac Mini 2.52 GHz Core 2 Duo.

    Thanks


    I had exactly the same issue with the season 3 of Fringe in french, for now the only way i've found to fix that is to disable DTS and Dolby in audio option of Plex.
  • diamondswdiamondsw &quot;Vitriolic yet well-intentioned&quot; Posts: 841Members, Plex Pass, Plex Ninja Plex Ninja
    Not that anyone's probably still looking at this, but like many such bugs, Plex 0.9.5 Laika fixed it. Yay!
  • Gillis902Gillis902 Posts: 5Members
    diamondsw wrote:

    Not that anyone's probably still looking at this, but like many such bugs, Plex 0.9.5 Laika fixed it. Yay!



    i still have this problem, has any one found any solutions?

    running plea media server Version 0.9.6.9.240-8fd9c6a
  • sludgetroughsludgetrough Posts: 4Members

    I'm still having this problem on certain files, exactly as described above, and I'm now on Plex 1.13.0.5023 with a Roku3.

Sign In or Register to comment.