Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

No sound on Roku Premiere+ unless Roku restarted

jamiewardjamieward Members, Plex Pass Posts: 14 Plex Pass

Recently, after I turn on my entertainment system, launch Plex and start playing a video, the video will play, but there is no sound. I must restart my Roku and the sound then returns with no problems. There is sound effects like scrolling sounds and the background show music bed, but when a show is played there is no audio unless the Roku is rebooted.

I don't have issues with any other app. Just Plex. There are no updates available for my Roku. It is up to date.

I'm running Plex Media Server on a Windows 10 box. Version 1.8.0.4109.

Tagged:

Answers

  • steveh11284steveh11284 Members, Plex Pass Posts: 10 Plex Pass

    I think it's the Roku. I have the same issue on Vudu for movies that have Dolby Digital Plus audio as well. I have to reboot in order for that and Plex to play correctly. Or I have to change my sound settings to Stereo.

  • interconnectinterconnect Members, Plex Pass Posts: 184 Plex Pass
  • BillyPrefectBillyPrefect Members, Plex Pass Posts: 84 Plex Pass

    Part of this group as well. The movie in question shows this under INFO
    The movie is supposed to have commentary audio in stereo, 5.1 audio for normal, and then

    Media

    Video Resolution 1080p
    Duration 1:27:42
    Bitrate 3293 kbps
    Width 1920
    Height 1088
    Aspect Ratio 1.78
    Container MKV
    Video Frame Rate 24p
    Audio Profile dts
    Video Profile high

    Part

    Duration 1:27:42
    File (some file name for the media).mkv
    Size 2.02 GB
    Audio Profile dts
    Container MKV
    Video Profile high

    Codec H264
    Bitrate 3069 kbps
    Bit Depth 8
    Chroma Subsampling 4:2:0
    Color Range tv
    Color Space bt709
    Frame Rate 23.976 fps
    Height 1088
    Level 4.1
    Profile high
    Ref Frames 4
    Scan Type progressive
    Width 1920

    Codec AAC
    Channels Stereo
    Language English
    Audio Channel Layout stereo
    Profile lc
    Sampling Rate 48000 Hz
    Title Stereo

    Codec AC3
    Channels 5.1
    Bitrate 224 kbps
    Language English
    Audio Channel Layout 5.1(side)
    Sampling Rate 48000 Hz
    Title Surround

    Plex Media Server Plex-Pass.

  • hereisoblivionhereisoblivion Members, Plex Pass Posts: 31 Plex Pass

    Same issue here.
    I have a new 2017 Vizio and a new Yamaha sound bar.
    The roku menus audio and all other apps work fine.
    Plex has no audio after a short distorted sound at the start of any video.
    Rebooting the roku fixes it.
    I have to reboot 3 times per day.
    It seems most consistent when playing a video that was recently watched.

    No problems on any other device in my home (Android, Windows, web based, etc.)

  • BillyPrefectBillyPrefect Members, Plex Pass Posts: 84 Plex Pass

    So is there a bug posting that can be placed somewhere ?

    Plex Media Server Plex-Pass.

  • shopgirl284shopgirl284 Members, Plex Pass, Plex Ninja, Forum Moderator Posts: 2,557 Plex Ninja

    Are you using the latest version of the Plex Pass version of the Plex app for Roku (It has a orange banner in the upper right hand corner that says Preview)?

    There was a fix for "No audio during video playback containing a 7.1 channel audio stream (Roku Ultra)" and that may also address the issues you are having. And it appears that the Roku store has still not updated the official channel with these updated yet.

    See https://forums.plex.tv/discussion/comment/1433874/#Comment_1433874 and https://forums.plex.tv/discussion/comment/1424192/#Comment_1424192

  • BillyPrefectBillyPrefect Members, Plex Pass Posts: 84 Plex Pass

    I am. Double checked myself last night when I checked on power cycling being a fix.

    Plex Media Server Plex-Pass.

  • shopgirl284shopgirl284 Members, Plex Pass, Plex Ninja, Forum Moderator Posts: 2,557 Plex Ninja

    @BillyPrefect said:
    I am. Double checked myself last night when I checked on power cycling being a fix.

    Does this only occur when playing the media on the Plex app for Roku or does it occur on other Plex player apps? (If you do not have another Plex device, you can use the Plex Web from the browser on any computer, tablet of phone.)

    Is the video transcoding? If so, does changing the Transcode Format under the Plex app for Roku Settings > Video > Transcode Format make any difference?

    Attaching the Roku log would also help along with information about your Plex setup like PMS operating system and version. And your Roku audio settings.

  • BillyPrefectBillyPrefect Members, Plex Pass Posts: 84 Plex Pass
    via Email
    Only the Plex app on Roku. I checked on my iPhone, iPad, MacBook app, and web browser versions. They all play audio.

    I don’t recall right off hand if it was transcoding video or direct streaming video. I will have to get back to you on that tomorrow.

    Where do I get Roku logs. I will grab those as well when checking on the video transcoding.

    Also, thank you for your time with this, it is very appreciated !

    Plex Media Server Plex-Pass.

  • rfischer1984rfischer1984 Members, Plex Pass Posts: 27 Plex Pass
    edited August 16

    I have the same issue. I have a Yamaha AVR and I noticed someone had a yamaha sound bar. I wonder if it is connected. My AVR will show decoder off because no sound is being sent to the receiver. I can restart the roku but that gets annoying. we usually have to do it ever other day.
    I want to add that it works fine with the firetv and never had issue with the apple tv. I just didnt like the apple tv and that is why im using my roku. I am about tempted to switch back to the firetv, but that is not a solution thats a work around.

    Plex Media Server:OpenMediaVault 3, Intel i7 920 3.6 ghz, 8 GB Ram

    Storage:8 TB Hitachi

    Clients: FireTV 2, Roku Premier+,  Roku 3, AppleTV 4, Huawei Mate 9, IPad, and Web. 

     
  • BillyPrefectBillyPrefect Members, Plex Pass Posts: 84 Plex Pass

    I’m connected to a Marantz

    Plex Media Server Plex-Pass.

  • rfischer1984rfischer1984 Members, Plex Pass Posts: 27 Plex Pass
    edited August 16

    @BillyPrefect said:
    I’m connected to a Marantz

    I think it is some type of HDMI issue. I wished i had the Roku Ultra now so i could try the optical port and see if sound still acts up. It only does it with surround sound. It could also just be the fact that the roku audio is passed through but still doesnt explain why i never have issues with netflix, or HBONOW and so on.

    Plex Media Server:OpenMediaVault 3, Intel i7 920 3.6 ghz, 8 GB Ram

    Storage:8 TB Hitachi

    Clients: FireTV 2, Roku Premier+,  Roku 3, AppleTV 4, Huawei Mate 9, IPad, and Web. 

     
  • shopgirl284shopgirl284 Members, Plex Pass, Plex Ninja, Forum Moderator Posts: 2,557 Plex Ninja

    As for Roku log, see https://support.plex.tv/hc/en-us/articles/201377603-Roku-Logs (FYI I made the words Roku log a link to those instructions.)

    @rfischer1984 said:

    I think it is some type of HDMI issue. I wished i had the Roku Ultra now so i could try the optical port and see if sound still acts up. It only does it with surround sound. It could also just be the fact that the roku audio is passed through but still doesnt explain why i never have issues with netflix, or HBONOW and so on.

    I did a Google search and did see that some were able to address sound issues on the Roku with unplugging and plugging the HDMI cable back in or changing HDMI inputs and then returning to that HDMI port. So it could be a HDMI issue that is specific to the Roku. EX https://nhlifefree.com/2015/03/01/roku-3-easily-fixing-the-no-sound-problem-with-hdmi-connection/

Sign In or Register to comment.