If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

[Solved] Plex Transcoder crashes when transcoding media with embedded fonts (with no log details)

miniluigi008miniluigi008 Posts: 20Members, Plex Pass Plex Pass
edited November 2017 in macOS/OS X (Mac)

I recently bought a Plex Pass for the mobile sync feature but it has only been working with my movies and music but not with my TV shows. The problem herein arises when Plex goes to transcode the media in any way. These TV shows used to play beautifully, but recent updates have rendered them unplayable in Plex (yet they play fine in VLC.) Some TV shows transcode fine, and some refuse to play or sync, a.k.a. the obscure "The transcoder was unable to process this media." error and when playing "The transcoder crashed or failed to start..." error.

I am on the latest version of Plex (Version 1.8.0.4109 at the time of writing) and the latest version of macOS (Version 10.12.6 (16G29) at the time of writing). Some TV shows do work, so at first I suspected it was an issue loading the font for the subtitles, but the crash report from the Plex Transcoder indicates that it was some sort of memory corruption issue. It was under my impression that this was fixed for 1.8.0, and I see no details about it in the log besides the Job Handler stating that the transcoder quit because of signal 11.

Here is a relevant excerpt of the crash report:

Process: Plex Transcoder [1973]
Path: /Applications/Plex Media Server.app/Contents/MacOS/Plex Transcoder
Identifier: Plex Transcoder
Version: 0
Code Type: X86-64 (Native)
Parent Process: Plex Media Server [1944]
Responsible: Plex Transcoder [1973]
User ID: 501

Date/Time: 2017-08-13 21:03:55.991 -0400
OS Version: Mac OS X 10.12.6 (16G29)
Report Version: 12

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: EXC_I386_GPFLT
Exception Note: EXC_CORPSE_NOTIFY

Termination Signal: Segmentation fault: 11
Termination Reason: Namespace SIGNAL, Code 0xb
Terminating Process: exc handler [0]

Just for laughs, I booted up Plex Server Version 0.9.8.6 and the TV show played beautifully (even though the Flash Player was a bit crappy.) I'm not sure what has happened between these two, but there have been changes made to the transcoder that obviously have been detrimental. I wanted to try a version after 1.0.0.0, but alas, there seem to be no archive for downloads, which I think is unfortunate at the least, especially because that makes it impossible to pinpoint exactly where it went wrong. Maybe the file is not being loaded correctly? I can watch it convert about 7% of the way in and then it just crashes. I have plenty of free space (20+ GB on my main drive and 91+ GB on my external drive) so memory, RAM (16GB) and computing resources (2.9 GHz i7) don't seem to be a problem.

Any help is appreciated, especially if someone could point me towards a version of Plex a few versions back (but not quite as old as pre-1.0.) I'm really scratching my head here... the Plex Dance has failed me.

Best Answer

«1

Answers

  • miniluigi008miniluigi008 Posts: 20Members, Plex Pass Plex Pass

    I'm going to try the experimental 1.8.1 and see if I get any results.

  • miniluigi008miniluigi008 Posts: 20Members, Plex Pass Plex Pass

    Transcoder still quits unexpectedly with the 1.8.1 beta.

  • miniluigi008miniluigi008 Posts: 20Members, Plex Pass Plex Pass

    Alright, I reverted to Version 1.4.4.3495 from my ancient backup that I had forgot about, and now everything is peachy.
    Would like a fix though, doesn't make sense to pay for a Plex Pass without Live DVR, etc.

  • sa2000sa2000 Posts: 31,256Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @miniluigi008 said:
    Transcoder still quits unexpectedly with the 1.8.1 beta.

    Please could you see if it also crashes with a clip from the video (eg a 1 minute clip)
    See https://support.plex.tv/hc/en-us/articles/201035968-Generating-Sample-Files-from-Media

    Would like sample (the clip) and logs when the error occurs
    See https://support.plex.tv/hc/en-us/articles/201643703-Reporting-issues-with-Plex-Media-Server
    https://support.plex.tv/hc/en-us/articles/200250417-Plex-Media-Server-Log-Files

    @miniluigi008 said:
    Alright, I reverted to Version 1.4.4.3495 from my ancient backup that I had forgot about, and now everything is peachy.
    Would like a fix though, doesn't make sense to pay for a Plex Pass without Live DVR, etc.

    1.4.4 does not have access to codecs - and the minimum supported level is 1.5.x

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • miniluigi008miniluigi008 Posts: 20Members, Plex Pass Plex Pass
    edited August 2017

    @sa2000
    Alright, here goes.

    Step 1 Duplicate a slice of the media which reveals the issue

    Here is the log from dd just to assure you I used it properly.
    50+0 records in
    50+0 records out
    52428800 bytes transferred in 2.272881 secs (23067111 bytes/sec)
    The clip is of the first minute of the show.

    I added the clip to the media library as s00e99 of the TV show.

    Step 2 Open Plex Version 1.8.1.4139 (Plex Pass release channel) and replicate issue

    Before I did this test I also backed up my media server directory in ~/Library/ before updating, since I was going to revert back to 1.4.4 after the bug test.

    To be safe, I had at one point enabled verbose mode a long time ago, so I backed up the current logs and started fresh after disabling verbose mode. For some reason verbose mode stuck even though I turned it off, but I did not realize until after the test.
    I apologize in advance.

    So I basically just opened Plex and updated it to 1.8.1 and the library containing the media clip to get it to appear (which is called Scan Library as of 1.8.1), cleared the log directory, and tried playing it using debug logging. I made sure to wait for Plex's network activity to clear up so it could download the proper codecs for 1.8.1... which it did, undoubtedly.

    The first attempt at transcoding you will see in the log is where I tried playing the full episode.
    It failed.

    The second attempt at transcoding you will see in the log is where I tried playing the clip.
    It failed.

    I then quit Plex to prevent irrelevant information from junking up the report.

    I have attached the logs (even if not very helpful.) I also attached the full system report that generates when Plex Transcoder "unexpectedly quits," as it seems the most helpful of all.

    Notes

    If you need me to, I can play a media file that does transcode fine and upload the log 'for proof' purposes, please inform me, and I'll be happy to oblige.

    If you need, I could probably re-upload the log without verbose statements after making a script to delete lines with "VERBOSE" in it, but since you guys are so adamant about not turning verbose on I figure you were prepared for something like this to happen anyway.

    If you are looking for the name of the show in question it is "Lucky Star." I reason it would be helpful when searching the logs.

    I also added VLC's metadata information on the video below so you are aware of what the transcoder is working with.

    Stream 0
    Type: Video
    Codec: H264 - MPEG-4 AVC (part 10) (avc1)
    Language: Japanese
    Resolution: 1280x738
    Display resolution: 1280x720
    Frame rate: 23.976216
    Decoded format: Planar 4:2:0 YUV 10-bit LE
    Stream 1
    Type: Audio
    Codec: FLAC (Free Lossless Audio Codec)...
    Language: Japanese
    Channels: Stereo
    Sample rate: 48000 Hz
    Bits per sample: 16
    Stream 2
    Type: Subtitle
    Codec: SubStation Alpha subtitles (ssa )
    Language: English
    Stream 3
    Type: Subtitle
    Codec: SubStation Alpha subtitles (ssa )
    Language: English

  • miniluigi008miniluigi008 Posts: 20Members, Plex Pass Plex Pass
    edited August 2017

    @sa2000
    I am uploading the sample file to Dropbox, so I will edit this post with the link when finished.

    EDIT: Here is the link.
    https://www.dropbox.com/s/qdp5rtjq3xuw98b/LuckyStarEp1Clip.mkv?dl=0
    Please let me know when you have received it so I can remove it from Dropbox.

  • miniluigi008miniluigi008 Posts: 20Members, Plex Pass Plex Pass

    @sa2000 Was this issue reproducible?

  • sa2000sa2000 Posts: 31,256Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @miniluigi008 said:
    @sa2000 Was this issue reproducible?

    Thanks for the sample

    I have not been able to reproduce the transcoder failure. Tried Google Chrome and Mozilla Firefox and tried without subs, with first ASS subtitles and with second ASS subtitles. Also tried different versions of Firefox. No failures.

    Could be platform specific. Will try and get it tested on a Mac

    The sample needs to stay on dropbox for download by other Plex team members/development

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • sa2000sa2000 Posts: 31,256Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @miniluigi008 said:
    @sa2000 Was this issue reproducible?

    Error has been reproduced now when selecting subtitle on a Mac
    It will be referred to the development team

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • sa2000sa2000 Posts: 31,256Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @miniluigi008 said:

    https://www.dropbox.com/s/qdp5rtjq3xuw98b/LuckyStarEp1Clip.mkv?dl=0
    Please let me know when you have received it so I can remove it from Dropbox.

    Please keep the file there until i let you know that the development team have got it

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • miniluigi008miniluigi008 Posts: 20Members, Plex Pass Plex Pass

    Alright, I'll keep it there.

  • miniluigi008miniluigi008 Posts: 20Members, Plex Pass Plex Pass

    @sa2000
    I don't mean to seem hasty or anything, but I was wondering about the progress on this issue and whether the development team has received the file.

  • sa2000sa2000 Posts: 31,256Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @miniluigi008 said:
    @sa2000
    I don't mean to seem hasty or anything, but I was wondering about the progress on this issue and whether the development team has received the file.

    I am sorry but it is still in the queue to get picked up

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • miniluigi008miniluigi008 Posts: 20Members, Plex Pass Plex Pass

    @sa2000

    I saw that 1.8.3 is available, is there any news that it has been picked up?
    Thanks again for checking for me.

  • miniluigi008miniluigi008 Posts: 20Members, Plex Pass Plex Pass
    edited October 2017

    @sa2000

    EDIT: Nevermind, issue is not fixed but I mistakingly marked it as so when it streamed fine to my iOS device.
    It still crashes on macOS.

    I think maybe I had resumed a previously transcoded clip on iOS from the previous version (as I was already watching part of the episode.) [Yep, that was the case. Tried a different episode and it failed.]

  • miniluigi008miniluigi008 Posts: 20Members, Plex Pass Plex Pass
    edited October 2017

    @sa2000

    Is there a way to remove an accepted answer?

  • sa2000sa2000 Posts: 31,256Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member

    @miniluigi008 said:
    @sa2000

    Is there a way to remove an accepted answer?

    I have edited your post and unset the Yes for the answer

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • miniluigi008miniluigi008 Posts: 20Members, Plex Pass Plex Pass

    Thank you very much @sa2000 ! Give the team my thanks, too!

  • nomaednomaed Posts: 2Members

    Version 1.10.1.4602 here, still crashes when trying to stream with external .srt file (utf-8 encoded).

«1
Sign In or Register to comment.