If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Master Buglist for Plex for Kodi.

danjames92danjames92 Posts: 3,241Members, Plex Pass Plex Pass
edited August 15 in Plex for Kodi

In the hope that this client gets updated some day, here is some information regarding the bugs of the current Plex for Kodi client. Feel free to comment with suggestions / examples / log files.

Device - Odroid C2 running Raybuntu's LibreELEC-based Krypton V17 builds. (eMMC 8GB flash drive running OS)
AVR - Yamaha RX-V675 (5.1) via HDMI / CEC / ARC
Passthrough - AVR supports all codecs bar DTS:X / Dolby Vision. Enabled.
Burn Subtitles - Automatic
Local Quality - Original Quality
Remote Quality - Original Quality

FIXED ISSUES:

*Movies that contain multiple parts do not seamlessly transition. FIXED.

OUTSTANDING BUGS:

  • Upon leaving the add-on, 3 loading dots endlessly spin and does not return the Kodi homescreen. Force reboot required.
  • Switching between managed users causes crashes at least 80% of the time.
  • Add-on refuses to connect to the internet despite other addons display no issue i.e. HDHomerun yet returns later. SSL issue?
  • "Playback Failed!" - Inconsistent and impossible to reproduce on the fly. Just happens intermittently for me.
  • When pressing play on a stream, playback will not always start and sit on a orange background. Could be related to refresh rate switching.
  • When scrolling along On Deck and new items load in, the artwork next to the newly loaded show turns grey intermittently.

FEATURES YET TO BE IMPLEMENTED:

  • TV theme music.
  • Pre-roll Video and Trailers
  • Live Music Lyrics integration.
  • Plex Companion.
  • Label support.
  • Chapter support.

LIMITATIONS:

  • No Plex Companion support currently. Kodi remotes function as a workaround currently.
  • No Alexa support due to above.
Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub

 

Comments

  • dannywsudannywsu Posts: 176Members, Plex Pass Plex Pass

    I'm with you, I'd love an update. Despite all of this, the Kodi version is still better than several other Plex apps.

    PMS | Custom HTPC w/ AMD FX-8320, 256 GB SSD, & 8gb Ram  |  Storage | 16 TB Drobo  |  Clients | Nvidia Shield (2017), Vizio M43-C1, Apple TV 4, Roku 3, Roku 2 XD, Xbox 360, Amazon fireTV stick  |  Mobile Clients | 2 x iPhone 6s, iPad Mini 4, iPad Mini 2

    TV | Sharp 60LE847 |  Receiver | Onkyo TX-NR616, 7.1 DTS-MA and True-HD  |  Remote | Logitech Harmony 700  |  Automation | SabNZBD+, deluge, Sonarr, & Radarr  |  Server Monitoring | PlexPy & HTPC Manager

  • danjames92danjames92 Posts: 3,241Members, Plex Pass Plex Pass

    @dannywsu said:
    I'm with you, I'd love an update. Despite all of this, the Kodi version is still better than several other Plex apps.

    Agreed but let's keep this to bugs shall.we? There are plenty of discussion threads already.

    Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub

     

  • HitsVilleHitsVille Posts: 441Members, Plex Pass Plex Pass
    edited August 16

    Device - Dedicated PC running LibreELEC official 8.1.0 generic x86/64 (60GB SSD for O/S)
    AVR - Yamaha RX-V377 (5.1) via HDMI
    Control - Harmony hub, remote & keyboard via bluetooth
    Passthrough - Enabled.
    Burn Subtitles - Automatic
    Local Quality - Original Quality
    Remote Quality - Original Quality
    PMS - Windows 10 64 bit using SMB paths

    A`> @danjames92 said:

    In the hope that this client gets updated some day, here is some information regarding the bugs of the current Plex for Kodi client. Feel free to comment with suggestions / examples / log files.

    • Upon leaving the add-on, 3 loading dots endlessly spin and does not return the Kodi homescreen. Force reboot required.

    Never experienced this

    • Switching between managed users causes crashes at least 80% of the time.

    100% of the time for me.

    • Add-on refuses to connect to the internet despite other addons display no issue i.e. HDHomerun yet returns later. SSL issue?
    • "Playback Failed!" - Inconsistent and impossible to reproduce on the fly. Just happens intermittently for me.
    • When pressing play on a stream, playback will not always start and sit on a orange background. Could be related to refresh rate switching.

    Again never experienced these.

    • When scrolling along On Deck and new items load in, the artwork next to the newly loaded show turns grey intermittently.

    Hadn't really noticed until today but yeah if scrolling through fast every 7th or 8th item is grey for a moment. Is this just caching? I just wonder because scrolling through the same list a second time and all images are loaded with no grey boxes.

    HitsVille

  • PukinatorPukinator Posts: 178Members, Plex Pass Plex Pass
    edited August 16

    The most annoying bug for me is, that the audio gets out of sync. I think first this is due to framedrops which don't get properly synced up with audio.
    I'm using an Odroid C2 @danjames92 do you also have those problems?

    And I have another bug, I can't enter certain shows on the deck, they just won't open. However when I go to the library and pick it from there it works.

  • foghatfoghat Posts: 340Members, Plex Pass Plex Pass

    @Pukinator said:
    The most annoying bug for me is, that the audio gets out of sync. I think first this is due to framedrops which don't get properly synced up with audio.
    I'm using an Odroid C2 @danjames92 do you also have those problems?

    And I have another bug, I can't enter certain shows on the deck, they just won't open. However when I go to the library and pick it from there it works.

    I never had audio 'get' out of sync while watching something. But on multiple occasions, audio has been out of sync right from the start and I need to compensate with the audio offset. I know PFK is using the kodi player, but I can't help but wonder if sometimes something gets lost in translation.

    I have not had this happen to me since I've started using PKC. May be just been lucky to this point.

  • danjames92danjames92 Posts: 3,241Members, Plex Pass Plex Pass
    edited August 16

    @Pukinator said:
    The most annoying bug for me is, that the audio gets out of sync. I think first this is due to framedrops which don't get properly synced up with audio.
    I'm using an Odroid C2 @danjames92 do you also have those problems?

    And I have another bug, I can't enter certain shows on the deck, they just won't open. However when I go to the library and pick it from there it works.

    No sync issues here but I do use Raybuntu's build, not official LibreELEC. I also have av sync on my amp is switched on.

    Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub

     

  • PukinatorPukinator Posts: 178Members, Plex Pass Plex Pass

    Then I'm gonna try out the Raybuntu build

  • danjames92danjames92 Posts: 3,241Members, Plex Pass Plex Pass

    @Pukinator said:
    Then I'm gonna try out the Raybuntu build

    I would. I found it vastly superior to LibreELEC.

    Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub

     

  • PukinatorPukinator Posts: 178Members, Plex Pass Plex Pass

    In what ways?

  • danjames92danjames92 Posts: 3,241Members, Plex Pass Plex Pass

    @Pukinator said:
    In what ways?

    No GUI jumps when skipping forward, general patches to things like VC-1. Just look at the github patch notes for a better idea.

    Mac Mini (2.7GHz, Late 2012, Windows 10, Kodi DSPlayer) | SATV 16GB | Panasonic TX-P50GT50B | Yamaha RX-V675 | Q Acoustics 2010i (FL, FR, Left S, Right S), Q2000ci Center, Q2070si Sub

     

  • keithahkeithah Posts: 1,294Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    OUTSTANDING BUGS:

    • Upon leaving the add-on, 3 loading dots endlessly spin and does not return the Kodi homescreen. Force reboot required.
    • Switching between managed users causes crashes at least 80% of the time.

    Both of these should be fixed in 0.1.0.

    • Add-on refuses to connect to the internet despite other addons display no issue i.e. HDHomerun yet returns later. SSL issue?

    I haven't had this issue. How reproducible is it? Hard to guess without logs what is happening.

    • "Playback Failed!" - Inconsistent and impossible to reproduce on the fly. Just happens intermittently for me.

    Hard to guess without logs.

    • When pressing play on a stream, playback will not always start and sit on a orange background. Could be related to refresh rate switching.

    I haven't ever had this happen either.. logs would be helpful.

    • When scrolling along On Deck and new items load in, the artwork next to the newly loaded show turns grey intermittently.

    Kodi limitation. Faster devices the problem is not as apparent. We do more artwork loading than likely any other addon ever and the pipeline is not optimized for this.

  • SumOfOneIntegerSumOfOneInteger Posts: 3Members, Plex Pass Plex Pass

    While playing a video on Plex for Kodi on a Raspberry Pi with a Flirc V1 installed I encountered a bug. Sbout 20 seconds into a video, the video begins jumping back randomly by around 30 seconds, then jumps forward 15 seconds, then continues jumping back and forth in this loop until I stop the playback.

    After stopping playback and starting the video again, it starts from where it jumped back to, but after around the 20 second mark, it happens again. The only solution is to remove the Flirc. I'm able to reproduce the issue consistently every time I attempt to play a video.

    I've made sure there isn't ghost buttons. I covered the Flirc to make sure it wasn't picking anything up, I cleared the Flirc's remote configuration, and I hid the remote in the back of a drawer.

    I've tried this on Recalbox 4.1 running Kodi 17.1 and LibreELEC 8.0.2.

  • keithahkeithah Posts: 1,294Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    If you could make a new thread and include logs we can pinpoint the issue:
    https://forums.plex.tv/discussion/246912/reporting-plex-for-kodi-issues#latest

Sign In or Register to comment.