If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Xbox One X 4k/HDR support? Is Plex EVER getting an Xbox update?

swanleeswanlee Posts: 24Members, Plex Pass Plex Pass

So the Xbox One X natively supports HEVC/10Bit I seem to remember plex admins said this was the reason why Plex did not natively stream 4K/HDR

Will the plex app support 4K/HDR native streaming with the Xbox one X? Also is the Plex app EVER getting a new Xbox update?

«1

Answers

  • caltraskcaltrask Posts: 138Members, Plex Pass Plex Pass

    Any info regarding the new Xbox One X and Plex would be awesome.

  • br3nn88br3nn88 Posts: 64Members, Plex Pass Plex Pass

    Im happy to hear/read any news about plex app getting an update for xbox in general. I feel for a piece of amazing hardware for the living room is being left out by the plex devs. I love my xbox not for gaming but for media. I get my optic out for sonos playbar, i get DTS encoding straight on the box to DD to allow sonos playbar to fully work. It as a 4k player, and it as HDMI IN (where my nintendo switch is) :)

    O because of the IR blaster i get to use my media IR remote for xbox along with playbar and lastly it cost me only £8 for a TV tuner so i have freeview, ;)

    I just wished plex would hurry and release an update to allow alexa support, and next ep auto etc. ;)

    GEEK88 - PLEX PASS Lifetime
    Geek88 Youtube Channel

  • kinoCharlinokinoCharlino Posts: 1,294Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    The update has landed: https://forums.plex.tv/discussion/comment/1540197/#Comment_1540197

    4K support is in there and we're investigating HDR support :)

    Search our Knowledge Base for more help

  • derekrasconderekrascon Posts: 11Members, Plex Pass Plex Pass

    @kinoCharlino said:
    The update has landed: https://forums.plex.tv/discussion/comment/1540197/#Comment_1540197

    4K support is in there and we're investigating HDR support :)

    Yes!!! Thanks Plex Team for all your hard work and releasing this update!

    Are you guys also investigating better audio-pass-through support? DTS, DTS-HD, TrueHD, Dolby Atmos, and etc... This is mainly the reason why I use the Nvidia Shield Plex app. Everything Direct Plays! All you have to say is yes... :wink: Please...

  • kinoCharlinokinoCharlino Posts: 1,294Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @derekrascon said:
    Are you guys also investigating better audio-pass-through support? DTS, DTS-HD, TrueHD, Dolby Atmos, and etc... This is mainly the reason why I use the Nvidia Shield Plex app. Everything Direct Plays! All you have to say is yes... :wink: Please...

    Good points on the SHIELD, it does Direct Play and pass-through (audio) just about everything. But to answer your question, yes we are investigating better audio pass-through support for the Xbox One, but unfortunately I don't have an ETA to provide. More to come in v2 :)

    Search our Knowledge Base for more help

  • jmckeejmckee Posts: 4,970Members, Plex Pass, Plex Ninja Plex Ninja

    @derekrascon said:
    Are you guys also investigating better audio-pass-through support? DTS, DTS-HD, TrueHD, Dolby Atmos, and etc... This is mainly the reason why I use the Nvidia Shield Plex app. Everything Direct Plays! All you have to say is yes... :wink: Please...

    They definitely are, but before they could do that the app needed to move to the new framework. This major change allows the developers access to a lot of new features that the old app could not.

  • derekrasconderekrascon Posts: 11Members, Plex Pass Plex Pass

    Thanks guys!

  • ASFxASFx Posts: 56Members, Plex Pass Plex Pass

    @kinoCharlino said:
    The update has landed: https://forums.plex.tv/discussion/comment/1540197/#Comment_1540197

    4K support is in there and we're investigating HDR support :)

    Nice! If 4k support is in there, please add that to the update notes along with anything else that is new, because right now the update notes just mention the new UI. Thanks for the 4k support and im looking forward to HDR support as well! :D

  • jmckeejmckee Posts: 4,970Members, Plex Pass, Plex Ninja Plex Ninja

    @ASFx said:
    Nice! If 4k support is in there, please add that to the update notes along with anything else that is new, because right now the update notes just mention the new UI. Thanks for the 4k support and im looking forward to HDR support as well! :D

    The reason that 4K support isn't mentioned in the notes is because the app has had 4K support for some time. (Even the non One S version supports decoding 4K material, it just can't output it).

  • ASFxASFx Posts: 56Members, Plex Pass Plex Pass

    @jmckee said:

    @ASFx said:
    Nice! If 4k support is in there, please add that to the update notes along with anything else that is new, because right now the update notes just mention the new UI. Thanks for the 4k support and im looking forward to HDR support as well! :D

    The reason that 4K support isn't mentioned in the notes is because the app has had 4K support for some time. (Even the non One S version supports decoding 4K material, it just can't output it).

    Ah that makes sense. Now i'm even more excited to get my One X next month. :smile:

  • TheVMasterTheVMaster Posts: 39Members, Plex Pass Plex Pass

    eh...so the app doesn't do 4K support yet? It keeps transcoding here ;(

  • MoussaMoussa Posts: 1,483Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @TheVMaster The app supports direct playback of 4K HEVC and MPEG4 content. If you're still seeing video transcoding are you using subtitles that need to burned in?

  • TheVMasterTheVMaster Posts: 39Members, Plex Pass Plex Pass

    Not using any subtitles :(

  • MoussaMoussa Posts: 1,483Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @TheVMaster Are you using original quality? If you're playing HEVC content is the audio stream supported? If the audio stream needs transcoding then the video stream will be transcoded to H.264 as the streaming protocol we use (HLS) doesn't support HEVC.

  • EnochLightEnochLight Posts: 143Members, Plex Pass Plex Pass

    @kinoCharlino said: More to come in v2 :)

    Fantastic! Please don't take another year to update v2.... :/

  • TheVMasterTheVMaster Posts: 39Members, Plex Pass Plex Pass

    @Moussa Let me check. I'm indeed using original quality. Eh...so if I'm correct, a HEVC with a AC3 5.1 audio stream should Direct Play?
    I've found a movie, the Audio does Direct Stream (AC3 5.1) and the video still does transcoding (HEVC to H.264).

  • MoussaMoussa Posts: 1,483Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @TheVMaster That should direct play but there may be other factors at play. If you enable logging to the server in the app and then post some server logs we can have a look.

  • justinglock40justinglock40 Posts: 58Members, Plex Pass Plex Pass

    maybe the .mkv extension is tripping you up?

  • MuskehoundMuskehound Posts: 27Members, Plex Pass Plex Pass

    I'm having the exact same problem (and have for every 4K file I've ever tried on my One S). I've located the part of the log which looks like it's relevant.

    Oct 19, 2017 22:05:06.742 [0x70000999c000] DEBUG - Audio Stream: 49488, Subtitle Stream: 0
    Oct 19, 2017 22:05:06.743 [0x70000999c000] DEBUG - MDE: analyzing media item 20017
    Oct 19, 2017 22:05:06.743 [0x70000999c000] DEBUG - MDE: [Movie Title]: Direct Play is disabled
    Oct 19, 2017 22:05:06.743 [0x70000999c000] DEBUG - MDE: [Movie Title]: media must be transcoded in order to use the hls protocol
    Oct 19, 2017 22:05:06.743 [0x70000999c000] DEBUG - MDE: [Movie Title]: selected audio stream is not the first audio stream and direct play stream selection is not enabled
    Oct 19, 2017 22:05:06.743 [0x70000999c000] DEBUG - MDE: [Movie Title]: no direct play video profile exists for http/mkv/hevc/truehd
    Oct 19, 2017 22:05:06.744 [0x70000999c000] DEBUG - [Movie Title] - video.width limitation applies: 3840 > 1920
    Oct 19, 2017 22:05:06.744 [0x70000999c000] DEBUG - [Movie Title] - audio.channels limitation applies: 8 > 6
    Oct 19, 2017 22:05:06.744 [0x70000999c000] DEBUG - MDE: [Movie Title]: no remuxable profile found, so video stream will be transcoded
    Oct 19, 2017 22:05:06.744 [0x70000999c000] DEBUG - Scaled up video bitrate to 237177Kbps based on 4.500000x fudge factor.
    Oct 19, 2017 22:05:06.744 [0x70000999c000] DEBUG - Scaled maximum bitrate for resolution reduction to 59294Kbps.
    Oct 19, 2017 22:05:06.744 [0x70000999c000] DEBUG - MDE: [Movie Title]: selected media 0 / 20017
    Oct 19, 2017 22:05:06.744 [0x70000999c000] DEBUG - Streaming Resource: Adding session 0x7f96943dbdd0:tr0hp4nw145vvb2b430x7pir which is using transcoder slot.  Used slots is now 1
    Oct 19, 2017 22:05:06.744 [0x70000999c000] DEBUG - Streaming Resource: Added session 0x7f96943dbdd0:tr0hp4nw145vvb2b430x7pir
    Oct 19, 2017 22:05:06.744 [0x70000999c000] DEBUG - Streaming Resource: Reached Decision id=8344 codes=(General=1001,Direct play not available; Conversion OK. Direct Play=3000,App cannot direct play this item. Direct play is disabled. Transcode=1001,Direct play not available; Conversion OK.) media=(id=20017 part=(id=20453 decision=transcode container=mpegts protocol=hls streams=(Video=(id=49486 decision=transcode bitrate=59294 encoder=libx264 width=1920 height=1080) Audio=(id=49488 decision=copy channels=6 rate=48000))))
    Oct 19, 2017 22:05:06.747 [0x700009790000] DEBUG - Completed: [192.168.1.243:49985] 200 GET /video/:/transcode/universal/decision?hasMDE=1&path=%2Flibrary%2Fmetadata%2F8344&mediaIndex=0&partIndex=0&protocol=hls&fastSeek=1&directPlay=0&directStream=1&subtitleSize=100&audioBoost=100&location=lan&session=z4w8rv5m4cawut3lnvfzvbd1&subtitles=burn&Accept-Language=en (14 live) TLS GZIP 34ms 1139 bytes (pipelined: 11)
    

    Here's the specs of the file. Previous to playing, I manually chose the 2nd audio (the AC3 one) and no subtitles. Direct Play/Stream is enabled on the player and server. I'm not sure if it's because the audio stream I'm using isn't the primary one that's causing the issue?

    Video
    ID                          : 1
    Format                      : HEVC
    Format/Info                 : High Efficiency Video Coding
    Format profile              : Main 10@L5.1@High
    Codec ID                    : V_MPEGH/ISO/HEVC
    Duration                    : 2 h 15 min
    Bit rate                    : 45.0 Mb/s
    Width                       : 3 840 pixels
    Height                      : 2 160 pixels
    Display aspect ratio        : 16:9
    Frame rate mode             : Constant
    Frame rate                  : 23.976 (24000/1001) FPS
    Color space                 : YUV
    Chroma subsampling          : 4:2:0 (Type 2)
    Bit depth                   : 10 bits
    Bits/(Pixel*Frame)          : 0.227
    Stream size                 : 42.7 GiB (84%)
    Default                     : Yes
    Forced                      : No
    Color range                 : Limited
    Color primaries             : BT.2020
    Transfer characteristics    : PQ
    Matrix coefficients         : BT.2020 non-constant
    Mastering display color pri : R: x=0.680000 y=0.320000, G: x=0.265000 y=0.690000, B: x=0.150000 y=0.060000, White point: x=0.312700 y=0.329000
    Mastering display luminance : min: 0.0050 cd/m2, max: 1000.0000 cd/m2
    
    Audio #1
    ID                          : 2
    Format                      : TrueHD
    Format profile              : TrueHD+Atmos / TrueHD
    Codec ID                    : A_TRUEHD
    Duration                    : 2 h 15 min
    Bit rate mode               : Variable
    Bit rate                    : 7 508 kb/s
    Maximum bit rate            : 11.3 Mb/s
    Channel(s)                  : Object Based / 8 channels
    Channel positions           : Object Based / Front: L C R, Side: L R, Back: L R, LFE
    Sampling rate               :  / 48.0 kHz
    Frame rate                  : 1 200.000 FPS (40 SPF)
    Compression mode            : Lossless
    Delay relative to video     : 32 ms
    Stream size                 : 7.12 GiB (14%)
    Language                    : English
    Default                     : Yes
    Forced                      : No
    
    Audio #2
    ID                          : 3
    Format                      : AC-3
    Format/Info                 : Audio Coding 3
    Format settings, Endianness : Big
    Codec ID                    : A_AC3
    Duration                    : 2 h 15 min
    Bit rate mode               : Constant
    Bit rate                    : 640 kb/s
    Channel(s)                  : 6 channels
    Channel positions           : Front: L C R, Side: L R, LFE
    Sampling rate               : 48.0 kHz
    Frame rate                  : 31.250 FPS (1536 SPF)
    Bit depth                   : 16 bits
    Compression mode            : Lossy
    Delay relative to video     : 31 ms
    Stream size                 : 622 MiB (1%)
    Language                    : English
    Service kind                : Complete Main
    Default                     : No
    Forced                      : No
    
  • jmckeejmckee Posts: 4,970Members, Plex Pass, Plex Ninja Plex Ninja

    @Muskehound said:
    Oct 19, 2017 22:05:06.743 [0x70000999c000] DEBUG - MDE: [Movie Title]: no direct play video profile exists for http/mkv/hevc/truehd
    Here's the specs of the file. Previous to playing, I manually chose the 2nd audio (the AC3 one) and no subtitles. Direct Play/Stream is enabled on the player and server. I'm not sure if it's because the audio stream I'm using isn't the primary one that's causing the issue?

    Based on that log entry, it does look like the case that the app isn't able to switch to the second audio stream directly in the file. Which starts a giant chain reaction: Because the file is being remuxed, HEVC can't be sent in the new hls stream, this causes the video to transcode to h264, but then because the xbox one's h264 decoder has trouble with 4K h264 the 4K is downscaled to 1080p. The log mentions stuff about the original audio stream in the MDE, but the transcode request does specify to copy the AC3 stream over.

    I have mentioned this to Moussa just to double check that is indeed what is currently happening. If they are looking at changing this behavior typically an ETA won't be released. But I would imagine that this is a feature that if they can fix the issue, that they will.

«1
Sign In or Register to comment.