If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Unable to install on OSX

philpw1philpw1 Posts: 14Members, Plex Pass Plex Pass
edited August 22 in OpenPHT

I unzip, drop the app in the apps folder, and nothing happens. In the log file I see the following errors:-

22:37:12 T:140736026817472 ERROR: special://masterprofile/guisettings.xml, Line 0
Failed to open file
22:37:12 T:140736026817472 ERROR: Unable to load special://masterprofile/guisettings.xml, creating new special://masterprofile/guisettings.xml with default values
22:37:12 T:140736026817472 ERROR: DeleteFile - cant delete file </Users/wesleyphillpot/Library/Application Support/OpenPHT/userdata/guisettings.xml>. trying lower case </users/wesleyphillpot/library/application support/openpht/userdata/guisettings.xml>
22:37:12 T:140736026817472 ERROR: Unable to save settings to special://masterprofile/guisettings.xml
22:37:12 T:140736026817472 ERROR: special://masterprofile/guisettings.xml, Line 0
Failed to open file
22:37:12 T:140736026817472 FATAL: Create: Failed to reset settings

I've tried v 1.8 and 1.71 but same issue in both. Likely I'm being dense and there's something I'm missing here and it's not quite as simple as the PMP install?

Answers

  • lukecrolukecro Posts: 65Members, Plex Pass Plex Pass

    I run OpenPHT on a Mac, no problems - you should be able to just drop the app into Applications, and that's basically it....

    Have you had previous builds of PHT or OpenPHT installed before? If so, you might want to try a clean install - delete the old PHT and OpenPHT apps and related library/resource/settings files and folders, then try a new install.

    Also - check your folder permissions. Make sure you have full read/write permissions on folders on your Mac that OpenPHT needs... e.g., Check out this old PHT thread that describes what looks like a very similar issue to what you're running into, with some possible solutions: https://forums.plex.tv/discussion/122008/plex-home-theater-simply-doesnt-work-on-my-mac

Sign In or Register to comment.