Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

OpenPHT 1.8.0 fails to play second file of multipart movies on OSX

kroeatschgekroeatschge Members, Plex Pass Posts: 8 Plex Pass

hi there,

I recently switched to openPHT 1.8.0.148 on Mac OSX 10.12.6.
Now I came across an issue with playing movies with multiple parts.

When playing the movie and arriving where OpenPHT tries to access the 2nd file, it gives an error and stops playing.
There is no way I could continue past that point.
Naming of the multipart movies is correct, it works in web player, plex home theater and plex media player.

My Plex-Server runs on a Synology DS214play, DSM 6.1.3
I'm on a wired LAN connection.

In the OpenPHT.log I can see that it fails to access the server:

09:55:31 T:123145395433472 DEBUG: CActiveAE::ClearDiscardedBuffers - buffer pool deleted
09:55:40 T:140735842051008 DEBUG: ------ Window Deinit (DialogKaiToast.xml) ------
09:55:41 T:123145398116352 DEBUG: CPlexGlobalTimer::Process firing callback manualServerManager - spent -3 in queue
09:55:41 T:123145398116352 DEBUG: CPlexGlobalTimer::Process waiting 3425 milliseconds for serverDataLoader...
09:55:41 T:123145402408960 DEBUG: CPlexGlobalTimer::SetTimeout adding timeout: manualServerManager at pos 1 [60000]
09:55:41 T:123145402945536 DEBUG: Previous line repeats 1 times.
09:55:41 T:123145402945536 DEBUG: CurlFile::Open(0x7fbe66d9ca10) http://10.0.0.2:32400/
09:55:41 T:123145402945536 INFO: easy_aquire - Created session to http://10.0.0.2
09:55:41 T:123145402945536 ERROR: CCurlFile::Open failed with code 401 for http://10.0.0.2:32400/
09:55:41 T:123145402945536 WARNING: CPlexManualServerManager::OnJobComplete failed to find a server on http://10.0.0.2:32400/
09:55:44 T:140735842051008 DEBUG: WinSystemOSX: Fullscreen window Finder obscures XBMC!
09:55:45 T:123145398116352 DEBUG: CPlexGlobalTimer::Process firing callback serverDataLoader - spe

anyone has an idea on how to fix this, without the need to merge the files together?

Best regards,
kro

Best Answer

  • dan-the-man-dan-the-man- Members, Plex Pass Posts: 453 Plex Pass
    Accepted Answer

    its well known i wouldnt worry, but i suspect its not going to get fixed anytime soon, the dev wants to spend his time on doing a complete rewrite from scatch of the whole app using a newer Kodi

    i would just join the files personally - the most realistic option right now given the above

Answers

  • dan-the-man-dan-the-man- Members, Plex Pass Posts: 453 Plex Pass

    Hi, this is a known issue unfortunately.

  • kroeatschgekroeatschge Members, Plex Pass Posts: 8 Plex Pass

    Hi daniel. Thx for the info.
    Do you know if it's posted on gut hub already?
    Otherwise l'll post it there.
    Thx

  • dan-the-man-dan-the-man- Members, Plex Pass Posts: 453 Plex Pass
    Accepted Answer

    its well known i wouldnt worry, but i suspect its not going to get fixed anytime soon, the dev wants to spend his time on doing a complete rewrite from scatch of the whole app using a newer Kodi

    i would just join the files personally - the most realistic option right now given the above

  • bemarsbemars Members Posts: 6 ✭✭

    I confirm, as in this thread, that this works fine for me: this is a two part movies named respectively Le Comte de Monte Cristo pt1.mkv and Le Comte de Monte Cristo pt2.mkv. Both are in the same folder named …/1954 Le Comte de Monte Cristo and the second part is read successfully after the first one by OpenPHT (and on other devices, local as remote: PMP, web-app, iOS app).

    Software: Plex Server 1.10.1.4602, OpenPHT 1.8.0, MacOS 10.12.6 on a 2012 Mac Mini

  • kroeatschgekroeatschge Members, Plex Pass Posts: 8 Plex Pass
    edited February 6

    @bemars: Is the Server and Player on the same machine?
    That might cause my issue. I'm having the player on a mac mini but the server on a Synology DiskStation.

    Anyways I'll try your naming convention as well. I'm using this convention:
    Folder:
    Le Comte de Monte Cristo (1954)
    Files:
    Le Comte de Monte Cristo (1954)-cd1.mkv
    Le Comte de Monte Cristo (1954)-cd2.mkv

    thx

  • bemarsbemars Members Posts: 6 ✭✭

    Yes, indeed, the server and the OpenPHT player are on the same machine. Remotely, from an iMac with an Ethernet connexion, the bug occurs :'(

Sign In or Register to comment.