If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Two different networks

frozenxisfrozenxis Posts: 7Members ✭✭

Hi.

I have the following situation:

House 1 : (external ip: 1.2.3.4)
1. router(ip:192.168.100.1) with port forwarding (53->53, 80->880, 443->4443, 32400->32400)
2. ubuntu(ip: 192.168.100.188) headless server(Version 15.10) with Plex (Version 3.14.1) & plexconnect (Version: 0.5-dev-230417)
3. plexconnect goes on 880 and 4443 because i have Apache running on same machine

House 2 : (external ip: 5.6.7.8)
1. router(ip:192.168.1.1)
2. apple tv 3(ip:192.168.1.13) with dns: 1.2.3.4 and certificate installed from 1.2.3.4/trailers.cer (success) because http://trailers.apple.com/trailers.cer doesn't work

00:25:34 DNSServer: DNS request received!
00:25:34 DNSServer: Source: ('5.6.7.8', 53482)
00:25:34 DNSServer: Domain: trailers.apple.com
00:25:34 DNSServer: ***intercept request
00:25:34 DNSServer: -> DNS response: 192.168.100.188

Apple TV apps like netflix and youtube work ok and i can see them in the log, but Trailers is going "Trailers is unavailable" Every. Single. Time.

Is there something wrong in my setup?

[PlexConnect]
enable_plexgdm = False
ip_pms = 192.168.100.188
port_pms = 32400
enable_dnsserver = True
port_dnsserver = 53
ip_dnsmaster = 8.8.8.8
prevent_atv_update = True
enable_plexconnect_autodetect = False
ip_plexconnect = 192.168.100.188
hosttointercept = trailers.apple.com
port_webserver = 880
enable_webserver_ssl = True
port_ssl = 4443
certfile = ./assets/certificates/trailers.pem
loglevel = High
logpath = .

Answers

  • frozenxisfrozenxis Posts: 7Members ✭✭

    i tried shutting down apache and starting Plex on 80 and 443, remade the router forwarding... still doesn't work

    15:00:00 WebServer: WebServer: Serving HTTP on 192.168.100.188 port 80.
    15:00:00 WebServer: ***
    15:00:00 WebServer: started: 15:00:00
    15:00:00 WebServer: ***
    15:00:00 WebServer: WebServer: Serving HTTPS on 192.168.100.188 port 443.
    15:00:00 WebServer: ***
    15:00:49 WebServer: serving *.cer: /trailers.cer

    downloaded again the certificate from appletv using 1.2.3.4/trailers.cer, tried from http://trailers.apple.com/trailers.cer and doesn't work

    15:01:02 DNSServer: DNS request received!
    15:01:02 DNSServer: Source: ('5.6.7.8', 53868)
    15:01:02 DNSServer: Domain: trailers.apple.com
    15:01:02 DNSServer: ***intercept request
    15:01:02 DNSServer: -> DNS response: 192.168.100.188

    after this.. "Trailers unavailable"

  • hutchpuppyhutchpuppy Posts: 3Members ✭✭

    Check this setting on your Plex Media Server,

    "Settings>Server>Network>List of networks that are allowed without auth"

    0.0.0.0/0.0.0.0 is what you may need.

    If only at house 1, and ATV was on the same LAN as server, then you would need 192.168.100.0/255.255.255.0, 192.168.1.0/255.255.255.0 (house 2)

    I know these aren't your real external IP's, but if so they would need to be in there also 1.2.3.4/x.x.x.x, 5.6.7.8/x.x.x.x

    If using WAN/Internet connections from house to house, I believe you MUST use the MyPlex login to have server be discovered (when external IP changes on modem). Then the above changes would not be needed. For this scenario. you would then need to add some info in the ATVSettings.cfg file for the login info. myplex_user = and myplex_auth =
    To get the auth hash value, login manually one ATV, then check the ATVSettings file, and you see the hash value, now place that in the myplex_auth = and this will apply to all of you ATV's.

  • frozenxisfrozenxis Posts: 7Members ✭✭
    edited September 14

    hi.

    thank you for your answer. yes you are right, those aren't my real ip's :))
    so i tried what you said, put these
    1.2.3.4/255.255.255.0, 5.6.7.8/255.255.255.0, 0.0.0.0/0.0.0.0
    in Settings>Server>Network>List of networks that are allowed without auth

    it still doesn't work. did i set them correct?x.x.x.x is the network mask right?

  • frozenxisfrozenxis Posts: 7Members ✭✭
    edited September 15

    i tried setting the DNS on my laptop to 1.2.3.4
    i can see all the websites i acces in my server's PlexConnect log. But when i acces trailers.apple.com it doesn't go thru.

    21:55:22 DNSServer: DNS request received!
    21:55:22 DNSServer: Source: ('5.6.7.8', 52085)
    21:55:22 DNSServer: Domain: trailers.apple.com
    21:55:22 DNSServer: ***intercept request
    21:55:22 DNSServer: -> DNS response: 192.168.100.188
    21:55:23 DNSServer: DNS request received!
    21:55:23 DNSServer: Source: ('5.6.7.8', 60499)
    21:55:23 DNSServer: Domain: trailers.apple.com
    21:55:23 DNSServer: ***intercept request
    21:55:23 DNSServer: -> DNS response: 192.168.100.188

    if i ping from my laptop trailers.apple.com with the DNS set to 1.2.3.4 i get this:

    92 bytes from 192.168.100.8: Destination Host Unreachable
    Vr HL TOS Len ID Flg off TTL Pro cks Src Dst
    4 5 00 5400 5d87 0 0000 3f 01 36ae 192.168.1.103 192.168.100.188

  • frozenxisfrozenxis Posts: 7Members ✭✭

    do you guys think setting up a VPN would work?
    1.2.3.4->ubuntu being the vpn server
    5.6.7.8->router->ATV being the client

  • moody_bluemoody_blue Posts: 2,777Members, Plex Pass, Plex Ninja Plex Ninja
    edited October 15

    @frozenxis If you had an ATV2 in house2 you could install PlexConnect on it, but this is not possible on ATV3. There are only two ways to have a remote ATV3 working with Plex:

    1. Have in the remote location another machine (RasPI for example) where you can install PlexConnect. Then, when you login with your credentials, this ATV3 will see the home1 server as a remote server
    2. Create a VPN between both houses, so that both ATV's are in the same subnet as the machine running PlexConnect

    QNAP TS-253A 4G QTS 4.3.3.0229 + PMS 1.9.3 + QPython2 2.7.12.0 + PlexConnect 0.5-dev-230417

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP

    No support via PM unless requested by me

Sign In or Register to comment.