If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

BUG: Strange behavior of Recommended settings for original video quality

tomyuntomyun Posts: 26Members, Plex Pass Plex Pass
edited October 19 in iOS

I have some 1080p movies and their bitrates are only 7-8 Mbps for video. Including audio stream should not exceed 20 Mbps by any means.

Incorrect bitrate for Recommended setting?

The first issue is that Recommended setting doesn't seem to work correctly for these low rate video streams. Here are some steps to reproduce. The only way to get them direct play was to use Maximum (20 Mbps) instead of Recommended setting.

  1. Use Recommended settings for video streaming (Settings - Video Quality - Home Streaming - Recommended)
  2. Play any 1080p movie, then it's being transcoded to 20 Mbps as if it's set to Maximum.
  3. Manually select Play Original Quality in the Playback Settings would fix it (direct play / streaming rather than transcoding)
  4. Then if you go back to Settings, Home Streaming is now set to Maximum instead of Recommended.
  5. Play any 1080p movie, then it's being transcoded again like step 2 above.
  6. Now it's repeating step 3 and so on.

.

Incorrect bitrate for Chromecast?

Now there's another issue when casting them to Chromecast. Casting 1080p with either Recommended or Maximum settings would always lead to transcoding and it seems like the app fails to pick up correct bitrates for "original video quality". Here are steps to reproduce.

  1. Play any 1080p movie and start casting, then the movie is being transcoded to 20 Mbps. Interestingly, Playback Settings show Play Original Quality as 20 Mbps when it's supposed to be much lower like 7-8 Mbps.

  1. Select Play Original Quality then the list suddenly changes its title to "Original" from "20 Mbps". Now movie is on direct play.

The issue looks like iOS specific since there was no problem when casting from Chrome browser on the desktop.

Comments

  • yohannmonnieryohannmonnier Posts: 8Members, Plex Pass Plex Pass

    Hi there, I have the same problem. Would be cool if it could be fixed

  • cawightoncawighton Posts: 7Members, Plex Pass Plex Pass

    +1. Same issue here.

  • yohannmonnieryohannmonnier Posts: 8Members, Plex Pass Plex Pass

    Is there any news ?

  • tomyuntomyun Posts: 26Members, Plex Pass Plex Pass

    I have no idea if the dev has ever read this report.

  • yohannmonnieryohannmonnier Posts: 8Members, Plex Pass Plex Pass

    On apple TV this is working perfectly... may some plex iOS dev get there one day :pensive:

Sign In or Register to comment.