Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

PLEX App causing Network drop issues on Apple TV forcing Restart of ATV4

siriusfilmssiriusfilms Posts: 5Validating, Plex Pass Plex Pass

Sounds weird, but it's true. Sometimes when I launce Plex on Apple TV it will connect to the server, but if it does it will only start to play a movie for a little while. I think it bufferes and then it loses connection.

I try to reconnect and the Plex App is very unresponsive and none of my other Apps can get to the internet or local services. I have another App called Channels for IPTV from my Silicon Dust HDHomeRun and even that stops working. The network IP address is there but I'm guessing IP Packets aren't flowing. The only solution is to reboot the Apple TV, but the same scenario reoccurs after reboot.

I have another AppleTV 4 in my bedroom and the same thing has happened but it seems affected less often and recently stopped exhibiting the issue. Last night I watch most of a movie. However tonight the Apple TV in the Family Room repeated its usual network connection issues.

I"m an engineer (not software, but good at troubleshooting), so I'll share all the details to avoid any assumptions on what I'm dealing with. Here is the hardware in use:
1. 1 Plex Server on home/office Tower PC for a few years

  • recently (in past 60 days) upgraded from Win7 x64 to Win 10 with new SSD
  • old Win7 SSD is still in machine so I can boot back to it if something in Win10 is missing
  • main media drive is an internal 4TB on same PC so this was untouched except for a rewrite of NTFS permissions
  • Plex Server was a fresh reinstall on new Win10 OS
  • Database folder recreated on OS Drive under new User AppData folder
    • (was previously 12GB folder on a separate internal Data drive and was still available if boot to Win7)
  • Renamed Plex server to reference new Win 10 PC nam
  • New Win10 server is using same Static IP on LAN as previous Win7 Plex Server
    ** mentioning both above because it might have something to do with linked servers in my Plex.tv account.
  1. 1 MacBook
  2. 1 Win10 Laptop
  3. 2 Apple TV 4
  4. 4 iPads
  5. 2 iPhones
  6. 1 Fire TV
  7. 1 Fire Stick
  8. 1 Echo Show

All the above devices EXCEPT my Apple TV 4s work. All iOS devices don't lose network, but I have seen them have trouble connecting to Plex Server. It usually seems to be a Server issue and I'll restart the Plex Server Application. The second Apple TV did have this issue for a little while but I deleted both Apple TVs from the Plex Server's list of Devices and that second Bedroom Apple TV worked better.

I booted into Win7 and removed/unclaimed that original Plex Server from my Plex account. I also deleted all devices associated. I then went back into Win10 and removed and reclaimed that server. Nothing really changed immediately, but a couple nights later I had to rebuild all my libraries (over 1000 movies, 45k photos, 10k songs, YUCK) and DVR setup to HDHomeRun.

I thought this was enough of a clean start. Apple TV in bedroom worked better, but NOT Family Room. The Apple TV lost connection to Plex Server and required complete reboot of AppleTV4. I'm going to see if my other Apple TV4 exhibits the issue tonight and if it doesn't I might just WIPE and restore to Factory Defaults my AppleTV4 in Family room and reinstall Plex on fresh tvOS. I'm less confident this is the issue because no other App has network issues. Plex is the only one that breaks it at the OS level. I have even uninstalled and reinstalled PLEX 3 times and relinked it to my Plex.tv account dozens of times.

Any ideas on what could be causing all this?
What should I test next?

Answers

  • darciliciousdarcilicious Posts: 620Members, Plex Pass Plex Pass

    Is the AppleTV wired or wireless? Is your PMS wired or wireless?

  • siriusfilmssiriusfilms Posts: 5Validating, Plex Pass Plex Pass

    The Apple TV that is experiencing issues is is sort of wired and wirelessly connected, but this shouldn't be the issue. It is connected to a Ruckus commercial grade dual radio 2.4GHz/5GHz AP in a Controller Managed Wireless Mesh to a Ruckus 802.11ac compatible mesh node. I consistently stream MPEG2 IPTV content from a SiliconDust HDHomeRun Cable Tuner to the Channels App (and recently Plex App) on Apple TV.

    The other Apple TV is wireless and connects to another 802.11ac Ruckus AP.

    The Plex Media Server is 1GB wired to a Cisco GB managed switch and the network traffic is routed through a Ubiquiti EdgePoE.

    Just now it seemed to work better as it let me connect to the server and start a movie, but then 12 seconds into the movie it said connection wasn't fast enough. Then it loses connection to the server and the LAN completely.

    Quitting the App to get to the Home screen requires HOLDING the Menu button. Then going back to the Channels App or any local or internet dependent App fails until rebooting the Apple TV.

    I'm going to try just using the Wi-Fi on the Apple TV but I think my wired to wireless mess was better.

    What other ideas do you or does anyone have?

  • siriusfilmssiriusfilms Posts: 5Validating, Plex Pass Plex Pass

    Ok, I unplugged the ethernet and it seems to be working better on Wi-Fi.
    I even skipped around in the timeline and it didn't hiccup at all. I think I've read opinions that the ethernet sucks on Apple TV 4, so maybe I just need to position the device for solid Wi-Fi signal.

    Please confirm.

Sign In or Register to comment.