Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Samsung Play Methods Request & Error's

CollivaahCollivaah Posts: 5Members, Plex Pass Plex Pass

Hi Orca,

First of all, I just want to say that I am incredibly impressed with the app that you have created all on your own. It was the reason I was able to get into Plex in the first place and I hope that the team at Plex recognize that and treat you accordingly!

Onto the first actual question, I'm aware how the play methods currently work, eg:

Auto - Check if can direct play, otherwise direct stream/transcode (doesn't look at remote quality setting)
Direct Play - Direct play
Direct Stream - Check quality setting and then stream / transcode as necessary
Transcode - transcode all to quality settings.

I've noticed that on the other official plex clients, while they don't have the play methods you have selected above, it all seems to hinge around the bitrate / quality setting requested. EG if quality setting is 8Mbps 1080p, anything under that will direct play if client is capable.

Is this something that could be integrated into your "Auto" play method? I find that this is too hard to explain to my end users watching from my plex server and as such, I just set it to direct stream by default.

EG, Auto - check quality setting > check if can direct play > play accordingly (transcode / direct play per client capabilities).

Also, they also appear to be affected by the 2.008 known bug with direct play from remote. It seems to transcode all the time.

Lastly, I often get the error "Unable to connect to the content server" whether it is on LAN or Remote (TV = UA60JU6400, same TV at both LAN and Remote). I have fiddled with the HTTPS side of things (eg, disabled secure connections on plex, no change, turned on "secure connections" in samsung client & preferred in plex settings to not gain either). LAN happens very infrequently, but does happen every now and then (generally only with TV shows). Last night I was attempting to watch a movie via direct play remote and was not able to watch it whatsoever due to this error. Direct stream worked successfully.

I'd love to be able to troubleshoot this error further if you can provide some guidance. Perhaps just an explanation of the error may satisfy my needs for now as well as I may be able to troubleshoot from there.

PS, does anyone elses PMS log get flooded with these errors:
[1284] WARN - Held transaction for too long (..\Library\MetadataItem.cpp:6665): 0.499203 seconds
[3076] WARN - LongPoll: Got error, closing.

PSS, apologies, as I was typing the questions, more questions came into my head and I just kept typing!

Windows Home Server 2011
E3-1240v2
8GB RAM

Sign In or Register to comment.