If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Can't connect to server after installing 1.8.4.4249 Upgrade

taximan42taximan42 Posts: 18Members ✭✭

I have a Sharp Roku TV and Sony TV both of which connected before the update. Now Sony is saying it can't find a Plex server and the Roku TV keeps asking me to enter a pass code at rokutv.com/activate. Now what?

Best Answers

  • taximan42taximan42 Posts: 18Members ✭✭
    Accepted Answer

    Success. I was able to use my Amazon Fire to link the Sharp Roku to Plex! Both TVs are now connected. I appreciate all your help and patience. Keith

Answers

  • nokdimnokdim Posts: 884Members, Plex Pass, Plex Ninja, TunerTester Plex Ninja

    Can you get to your server i.e. http://192.168.x.x:32400 or http://10.x.x.x?

    Or locally on PC where plex runs http://127.0.0.1:32400

  • taximan42taximan42 Posts: 18Members ✭✭

    Yes. And both devices were accessible before the server software upgrade. The Sharp Roku devices shows as being connected on the server PC page but the TV itself says it needs to have the 4 digit activation code initiated. And the Sony TV still says it can't find the server. The Sony shows up on the device page but not the Sharp Roku. See attached.

  • nokdimnokdim Posts: 884Members, Plex Pass, Plex Ninja, TunerTester Plex Ninja

    So you can do 2 things:

    in each client you can specify the IP of the PMS under Settings --> Advanced --> Manual Connections and not need to jack with the 4 digit code thing but will not work outside your house.

    Or

    Sounds like your remote access is broken so you need to check under Settings --> Server --> Remote Access and see whats going on:

  • taximan42taximan42 Posts: 18Members ✭✭

    I don't have a Remote Access link on Settings .

  • nokdimnokdim Posts: 884Members, Plex Pass, Plex Ninja, TunerTester Plex Ninja

    click "Server" and it should be under there not under "web"

  • taximan42taximan42 Posts: 18Members ✭✭

    Changed the Remote Access setting. Restarted computer to clear everything. Sony says "direct connection not available." Sharp still asking for access. Sony is hard-cabled to my network via a LinkSys router. Sharp is wireless-connected. No changes made to network after Plex upgrade.

  • nokdimnokdim Posts: 884Members, Plex Pass, Plex Ninja, TunerTester Plex Ninja

    Ok so looks like you should have port 16654 setup for port forwarding on your linksys?

    That port shows as unreachable on your public IP listed above from the internet so you need to check your port forwarding.
    (I would also recommend you not post your public IP on here for security reasons)

    nokdim@Nokdim-NAS:~$ tn 98.230.184.141 16654
    Trying 98.230.184.141...

  • taximan42taximan42 Posts: 18Members ✭✭

    Any idea why the update would create this problem? It was working fine before.

  • taximan42taximan42 Posts: 18Members ✭✭

    Getting WAY out of my technical knowledge here. Your suggestion...I would Enable Dynamic Routing and add a Destination IP with form xx.xxx.xxx.xxx 16654?

  • nokdimnokdim Posts: 884Members, Plex Pass, Plex Ninja, TunerTester Plex Ninja

    Well your screen shot shows port 16654 above so I am assuming at some point you configured port forwarding on your linksys? and no not enable dynamic routing for sure that's something else.

    What model linksys is it? this is their standard port forwarding guide

  • taximan42taximan42 Posts: 18Members ✭✭

    It's an EA7500. I still have to wonder why everything worked before the upgrade. I've used this router with Plex for well over a year. Is it possible to revert to the previous version?

  • nokdimnokdim Posts: 884Members, Plex Pass, Plex Ninja, TunerTester Plex Ninja

    I am not sure why it stopped working, maybe UPNP was happy and now its not?

    I would suggest you just get your port forwarding setup and verified, this is the guide for that device.

    Setup port forwarding to whatever port you have specified in your remote access config page which looked like it was set to 16654 and make sure it is good by going to canyouseeme.org and input the port you setup and make sure it shows Success.

    Once that is happy you probably want to make sure your setting are all set and restart Plex.

  • taximan42taximan42 Posts: 18Members ✭✭

    About 4 weeks ago I had to switch to Comcast but since I've had my own router I just put the output of their router to one of my Linksys Cat 5 ports. Thanks for the LinkSys documentation. I'll give that a try. Thanks for your help "nokdim".

  • taximan42taximan42 Posts: 18Members ✭✭

    Not quite there. I used the private plex IP as the device IP. Are the external and internal ports correct? Should one them be 32400? Should I try the "manually specify public port" option?



  • taximan42taximan42 Posts: 18Members ✭✭

    Very interesting. I disabled remote access, manually specified port 16654, and removed Single Port Forwarding from my Linksys router. I'm now able to access Plex on my Sony Android Smart TV that is connected to the LAN through my router. But I'm unable to connect through my Sharp Roku TV that uses wireless to connect. A DirectTV Genie is connected to the LAN for TV access. And canyouseeme only shows what's on my Comcast router IP and I can't change it to my router IP.

    Again, I was able to connect to both before the Plex upgrade. Is it possible to get the previous version of Media Server? I'm willing to uninstall and reconnect my libraries.

  • taximan42taximan42 Posts: 18Members ✭✭
    Accepted Answer

    Success. I was able to use my Amazon Fire to link the Sharp Roku to Plex! Both TVs are now connected. I appreciate all your help and patience. Keith

Sign In or Register to comment.