If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Windows 10 Meta data not downloading

daveragedaverage Posts: 10Members, Plex Pass Plex Pass

Hi all
Just recently I have had this problem whenever I reboot the windows machine that I have PMS installed on. It seems to be a permissions issue, but just can't seem to fix it. I am on Windows 10 using Version 3.20.5 of plex.

Plex works fine, but it won't update meta data etc. I had a trawl through the logs and found that it was not able to run the tvdb agent (same for movies as well). When you go to this url

http://127.0.0.1:32400/system/agents/search?mediaType=2&id=18724&identifier=com.plexapp.agents.thetvdb&duration=-1&episodic=1&filename=C%253A%255Cmedia%255CTV%255CThe%2520Tick%2520(2016)%255CSeason%252001%255CThe%2520Tick%2520-%2520S01E06%2520-%2520The%2520Tick%2520vs%252E%2520El%2520Seed%252Emp4&lang=en&openSubtitlesHash=18c9fae8cf054215&plexHash=54b2efe11bab2f8ed37d79bd618f061d9e421863&episode=6&episodic=1&season=1&show=The%20Tick&year=2016&manual=1

<SearchResponse status="Unhandled exception" code="5" details="Traceback (most recent call last): File "C:\Program Files (x86)\Plex2\Plex Media Server\Resources\Plug-ins-3497d6779\System.bundle\Contents\Code\agentservice.py", line 213, in search def info_lock(): File "C:\Program Files (x86)\Plex2\Plex Media Server\Resources\Plug-ins-3497d6779\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\api\threadkit.py", line 189, in _lock_decorator_inner return f(*args, **kwargs) File "C:\Program Files (x86)\Plex2\Plex Media Server\Resources\Plug-ins-3497d6779\System.bundle\Contents\Code\agentservice.py", line 215, in info_lock if identifier not in Core.messaging.plugin_list(): return SearchResponse(**AgentResponse.AgentNotFound) File "C:\Program Files (x86)\Plex2\Plex Media Server\Resources\Plug-ins-3497d6779\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components\messaging.py", line 191, in plugin_list xml_str = self._core.networking.http_request('http://127.0.0.1:32400/:/plugins', timeout=None, cacheTime=0).content File "C:\Program Files (x86)\Plex2\Plex Media Server\Resources\Plug-ins-3497d6779\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components\networking.py", line 265, in content return self.__str__() File "C:\Program Files (x86)\Plex2\Plex Media Server\Resources\Plug-ins-3497d6779\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components\networking.py", line 243, in __str__ self.load() File "C:\Program Files (x86)\Plex2\Plex Media Server\Resources\Plug-ins-3497d6779\Framework.bundle\Contents\Resources\Versions\2\Python\Framework\components\networking.py", line 181, in load f = self._opener.open(req, timeout=self._timeout) File "C:\Program Files (x86)\Plex2\Plex Media Server\python27.zip\urllib2.py", line 429, in open response = self._open(req, data) File "C:\Program Files (x86)\Plex2\Plex Media Server\python27.zip\urllib2.py", line 447, in _open '_open', req) File "C:\Program Files (x86)\Plex2\Plex Media Server\python27.zip\urllib2.py", line 407, in _call_chain result = func(*args) File "C:\Program Files (x86)\Plex2\Plex Media Server\python27.zip\urllib2.py", line 1228, in http_open return self.do_open(httplib.HTTPConnection, req) File "C:\Program Files (x86)\Plex2\Plex Media Server\python27.zip\urllib2.py", line 1201, in do_open r = h.getresponse(buffering=True) File "C:\Program Files (x86)\Plex2\Plex Media Server\python27.zip\httplib.py", line 1136, in getresponse response.begin() File "C:\Program Files (x86)\Plex2\Plex Media Server\python27.zip\httplib.py", line 453, in begin version, status, reason = self._read_status() File "C:\Program Files (x86)\Plex2\Plex Media Server\python27.zip\httplib.py", line 417, in _read_status raise BadStatusLine(line) BadStatusLine: '' "/>

you get the following, However, go to it on my other server and you get the details for the show.

I also can't add new libraries, getting a "Can't save" error. However, if I go to the same instance from another machine using the internal ip (192.168.0.3), I can save!

HELP (please)

Tagged:

Best Answers

Answers

  • daveragedaverage Posts: 10Members, Plex Pass Plex Pass

    Hi. With a bit more digging, this error is coming up in the moviedb log
    CRITICAL (core:574) - Exception starting plug-in

    Attached are the non-verbose logs.

  • daveragedaverage Posts: 10Members, Plex Pass Plex Pass

    So, in addition (again). I uninstalled completely and reinstalled. When I went to run it I got an error in the wizard saying "Plex Media Server."

  • daveragedaverage Posts: 10Members, Plex Pass Plex Pass

    Well. It worked by itself for a bit, now after another reboot it has stopped. Please has anyone else had this!?

  • JuiceWSAJuiceWSA Posts: 6,769Members ✭✭✭✭✭

    Full set of log files please:
    https://support.plex.tv/hc/en-us/articles/200250417-Plex-Media-Server-Log-Files
    Drag zip to message.

    Tony

    FileBot For Easy Plex File Naming: http://www.filebot.net/

    Automated Plex Naming With Filebot: https://forums.plex.tv/discussion/191687/plex-naming-schemes-for-filebot

    Plex Friendly Handbrake Guide - DVDs/BluRays: https://forums.plex.tv/discussion/comment/1335697/#Comment_1335697

    Plex Clients: AFTVs, Androids, PMP, Rokus (running RARflix: http://mkvxstream.blogspot.com/2014/09/roku-plex-setup-guide.html ) Link May Work - May Not

  • daveragedaverage Posts: 10Members, Plex Pass Plex Pass

    Apologies - full log here.

  • mscottsimmonsmscottsimmons Posts: 3Members, Plex Pass Plex Pass

    I'm having similar issues. I have also heard from other users that when they reverted back to Windows 7 the issue was resolved, maybe suggesting a compatibility issue with Windows 10. Inconsistent at best as I have occasionally had the meta data download after moving the files out of the library, scan, then back into the library and scanned again. So far I have only noticed issues with TV episodes. I follow the naming convention: Show Title S##E##

    My log files are attached as well.

  • JuiceWSAJuiceWSA Posts: 6,769Members ✭✭✭✭✭

    @mscottsimmons said:
    I'm having similar issues. I have also heard from other users that when they reverted back to Windows 7 the issue was resolved, maybe suggesting a compatibility issue with Windows 10. Inconsistent at best as I have occasionally had the meta data download after moving the files out of the library, scan, then back into the library and scanned again. So far I have only noticed issues with TV episodes. I follow the naming convention: Show Title S##E##

    My log files are attached as well.

    Your naming looks 'pretty good':

    Sep 19, 2017 22:43:39.994 [2116] DEBUG - Adding file for scanner: F:\TV Shows\Friends\Season 8\Friends S08E01.mkv

    'Perfect', would be:

    F:\TV Shows\
    .....Friends\
    .........Season 08\
    ...........Friends - S08E01.mkv

    But... we'll go by that for now.

    You're not using MP4 files - at least not the ones I saw, but if you're having trouble with some, note if they're MP4 files - if so the solution above should help if not cure the issue.

    @OttoKerner / @astrofisher should have a peek at the rest of the logs to see if the usual suspects show up - not particularly associated with poor naming and/or structuring.

    Tony

    FileBot For Easy Plex File Naming: http://www.filebot.net/

    Automated Plex Naming With Filebot: https://forums.plex.tv/discussion/191687/plex-naming-schemes-for-filebot

    Plex Friendly Handbrake Guide - DVDs/BluRays: https://forums.plex.tv/discussion/comment/1335697/#Comment_1335697

    Plex Clients: AFTVs, Androids, PMP, Rokus (running RARflix: http://mkvxstream.blogspot.com/2014/09/roku-plex-setup-guide.html ) Link May Work - May Not

  • daveragedaverage Posts: 10Members, Plex Pass Plex Pass

    Hi> @JuiceWSA said:

    @daverage said:
    Apologies - full log here.

    Just picked this out quickly:

    Sep 19, 2017 08:49:57.408 [6396] DEBUG - Adding file for scanner: C:\media\TV\The Tudors\Season 01\The Tudors - S01E01 - In Cold Blood.mp4
    Sep 19, 2017 08:49:57.409 [6396] DEBUG - Adding file for scanner: C:\media\TV\The Tudors\Season 01\The Tudors - S01E01 - In Cold Blood.nfo
    

    1) you are using MP4 files - maybe infected with bogus metadata in their Title Fields - borking your match
    2) you have an NFO file - that if not set up correctly will confuse Plex - borking your match

    2 - whack the nfo file.

    1 - Either remove possible embedded metadata in the Title Field of MP4/M4V files or Move Local Media Assets. Plex will read this info and prefer it over a perfect file name/structure, but you can combat that situation by moving Local Media Assets to the bottom of every agent list you can find. All tabs in TV Show and Movies here:
    https://support.plex.tv/hc/en-us/articles/200241558-Agents
    Just drag LMA to the bottom of the list and drop it. If you do have embedded metadata this will cure the issue, if you don't it won't matter. LMA will do what it has to from the bottom.

    Renaming/restructuring is best performed OUTSIDE the library and you'll need to write a new bundle for the show so The Plex Dance® was invented:

    The Plex Dance®:

    1) remove show/movie from library
    2) update library
    3) empty trash
    4) clean bundles
    https://support.plex.tv/hc/en-us/articles/200392106-Library-Actions <--- update library, empty trash, clean bundles
    5) bring names and structures into compliance/ or the ultimate bundle reboot operation
    6) replace corrected show/movie into library
    7) update library

    All Steps. In Order. No Shortcuts.

    Ohhhh

    Moving the agent seems to have worked!!!! Thank you!

  • daveragedaverage Posts: 10Members, Plex Pass Plex Pass
    edited September 20

    Arg - spoke too soon. Rebooted the server and same issue again. Leading me to believe there is some odd permission issue coming in from 127.0.0.1

    I did also follow your steps to the letter again, no joy.

  • OttoKernerOttoKerner Posts: 25,735Members, Plex Pass, Plex Ninja Plex Ninja

    @daverage said:
    Apologies - full log here.

    Your system log is riddled with errors. Are you trying to use 'Jumbo Frames' in your local network?
    Have you ever user 'TCPOptimizer' or similar software which manipulates the TCP/IP stack of Windows?
    Is the system clock on your media server correctly set?
    Have you installed an anti-virus software or a 3rd party firewall which inspects encrypted packets?
    Disable Settings - Server - Network - 'Show Advanced' - "Support for IPv6"
    see also https://support.plex.tv/hc/en-us/articles/206910047-Windows-Repeated-crashing-of-Plex-Media-Server

    Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • daveragedaverage Posts: 10Members, Plex Pass Plex Pass

    Hi

    Thanks for the things to check.

    I have used TCPOptimizer, but have MTU set to 1500, I have also reset back to windows defaults to try that.
    I also ran the microsoft fix for tcp as well as resetting the autotune fix (set to normal rather than experimental)
    Disabled antivirus and firewall to test and still no joy.
    Have tried with IPv6 both disabled and enabled, and still the same issue.

    Plex has never crashed, it's just this odd issue of the agent search not always working and when it does, stopping after a reboot.

    New log attached!

  • daveragedaverage Posts: 10Members, Plex Pass Plex Pass

    Thanks sa2000. That was my though, I had something hijacking 127.0.0.1. It’s definitly not running as a service or running more than once. I am manually loading it for the time being to ensure it is running as an administrator.

    However before that it was just being launched under the plex user - and the problem was the same.

  • sa2000sa2000 Posts: 29,173Members, Plex Pass, Plex Ninja, Plex Team Member Plex Team Member
    edited September 21

    @daverage said:
    Thanks sa2000. That was my though, I had something hijacking 127.0.0.1.

    This was a recent example of some adware malware hijacking 127.0.0.1
    http://forums.plex.tv/discussion/comment/1510913/#Comment_1510913
    http://forums.plex.tv/discussion/comment/1510942/#Comment_1510942

    Symptoms are different but just shows how easy it is for malware to hijack 127.0.0.1

    Lets double check LAN Settings in Internet Options and see if Proxy setting is ticked and if it is, what port is showing in Advanced Proxy setting

    Then we can do netstat to find it - if there is one

    • Start / Search for cmd
    • Right click on result Command Prompt and then select Run As Administrator
    • In the command window, you type
      netstat -a -b > %localappdata%\netstat_2017-Sep-21a.txt

    • when completed, locate file %localappdata%\netstat_2017-Sep-21a.txt
      and attach it

    @daverage said:
    It’s definitly not running as a service or running more than once. I am manually loading it for the time being to ensure it is running as an administrator.

    However before that it was just being launched under the plex user - and the problem was the same.

    So it is running is a windows user account administrator or running in plex windows user account but with option Run As Administrator ?

    Is LocalAppDataPath used in the registry ? I had very weird outcomes before when there is a relative as opposed to absolute path in LocalAppDataPath and the Plex Media Server.exe launched with Run As Administrator - ended up with creating paths below C:\Program Files (x86)\Plex\Plex Media Server !

    Anyway, a digression...

    The following logged warnings have only been seen before when Plex Media Server.exe runs without a desktop session e.g. when run as scheduled task or service

    Sep 20, 2017 19:50:23.831 [10216] WARN - Shell_NotifyIcon(NIM_ADD) failed: 0x5b4
    Sep 20, 2017 19:50:23.831 [10216] ERROR - DisplayIcon failed
    Sep 20, 2017 19:50:23.831 [10216] ERROR - TrayIcon::Create failed
    Sep 20, 2017 19:50:28.831 [10216] DEBUG - TrayIcon::WindowProc received DisplayIcon timer message
    Sep 20, 2017 19:50:28.831 [10216] WARN - Shell_NotifyIcon(NIM_ADD) failed: 0x3f0
    Sep 20, 2017 19:50:33.818 [10216] DEBUG - TrayIcon::WindowProc received DisplayIcon timer message
    Sep 20, 2017 19:50:33.818 [10216] WARN - Shell_NotifyIcon(NIM_ADD) failed: 0x3f0
    Sep 20, 2017 19:50:38.819 [10216] DEBUG - TrayIcon::WindowProc received DisplayIcon timer message
    Sep 20, 2017 19:50:38.819 [10216] WARN - Shell_NotifyIcon(NIM_ADD) failed: 0x3f0
    Sep 20, 2017 19:50:43.828 [10216] DEBUG - TrayIcon::WindowProc received DisplayIcon timer message
    Sep 20, 2017 19:50:43.828 [10216] WARN - Shell_NotifyIcon(NIM_ADD) failed: 0x3f0
    Sep 20, 2017 19:50:48.820 [10216] DEBUG - TrayIcon::WindowProc received DisplayIcon timer message
    Sep 20, 2017 19:50:48.820 [10216] WARN - Shell_NotifyIcon(NIM_ADD) failed: 0x3f0
    Sep 20, 2017 19:50:53.819 [10216] DEBUG - TrayIcon::WindowProc received DisplayIcon timer message
    Sep 20, 2017 19:50:53.819 [10216] WARN - Shell_NotifyIcon(NIM_ADD) failed: 0x3f0
    Sep 20, 2017 19:50:58.819 [10216] DEBUG - TrayIcon::WindowProc received DisplayIcon timer message
    

    May be worth exploring.

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • daveragedaverage Posts: 10Members, Plex Pass Plex Pass

    Ok, I have nailed the issue. It is an app called psiphon. It is a proxy, that is meant to only redirect traffic I tell it to - but a recent update seems to have borked it and it is blocking localhost now. I had disabled it, but it was a boot order thing. If it launcehd first, plex didn't work, second and it was fine. Anyway - all fixed, thanks for the help everyone!!!

  • mscottsimmonsmscottsimmons Posts: 3Members, Plex Pass Plex Pass

    @JuiceWSA Thanks for the feedback. I made those naming changes to the impacted TV episodes as a part of the plex 'dance' you stepped through. The result is the same. Specifically all of my Big Bang Theory season 10 has no metadata downloaded. To your point about file types I have very few MP4 files and use almost exclusively the MKV containers.

    I'd appreciate any other thoughts and guidance.

    Thanks!

Sign In or Register to comment.