If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

[Transcoder] [eac3_eae @ 0x14d9400] EAE timeout! EAE not running, or wrong folder? Could not read

RonUSMCRonUSMC Posts: 2Members, Plex Pass Plex Pass
edited September 17 in Docker

Hi, I've read the other threads but it seems that this is a bit different? What I have not tried yet is to set the /tmp folder outside of Plex yet as I am using the official docker image and that setting wasn't available, so before I went messing around I wanted to post here.

I did verify my inotify,

# increase the number of inotify watches
fs.inotify.max_user_watches=524288

I searched logs and found these entries.

ERROR - [Transcoder] [eac3_eae @ 0x14d9400] EAE timeout! EAE not running, or wrong folder? Could not read '/config/tmp/pms-437bf3b7-8d0c-4e31-b04a-af60c6ab03c5/EasyAudioEncoder/Convert to WAV (to 8ch or less)/15p643li5cc3nt0keauc61wn_28028-1-0.wav'
ERROR - [Transcoder] [eac3_eae @ 0x14d9400] error reading output
ERROR - [Transcoder] Error while decoding stream #0:1: Input/output error
DEBUG - Auth: We found auth token (xxxxxxxxxxxxxxxxxxxx), enabling token-based authentication.
DEBUG - Auth: Came in with the master token, authorization succeeded.
DEBUG - Request: [127.0.0.1:47108 (Loopback)] PUT /video/:/transcode/session/15p643li5cc3nt0keauc61wn/9feb1bd3-633b-49fa-9432-714a5787ac81/progress?progress=-698740304058.2&size=-22&remaining=-1&speed=-3200635895808.0 (13 live) Signed-in Token (RonUSMC)
DEBUG - Completed: [127.0.0.1:47108] 206 PUT /video/:/transcode/session/15p643li5cc3nt0keauc61wn/9feb1bd3-633b-49fa-9432-714a5787ac81/progress?progress=-698740304058.2&size=-22&remaining=-1&speed=-3200635895808.0 (13 live) 0ms 326 bytes
ERROR - [Transcoder] [eac3_eae @ 0x14d9400] EAE timeout! EAE not running, or wrong folder? Could not read '/config/tmp/pms-437bf3b7-8d0c-4e31-b04a-af60c6ab03c5/EasyAudioEncoder/Convert to WAV (to 8ch or less)/15p643li5cc3nt0keauc61wn_28028-1-1.wav'
ERROR - [Transcoder] [eac3_eae @ 0x14d9400] error reading output
ERROR - [Transcoder] Error while decoding stream #0:1: Input/output error

The only logs that I could see that were different..

DEBUG - Job running: EAE_ROOT='/config/tmp/pms-437bf3b7-8d0c-4e31-b04a-af60c6ab03c5/EasyAudioEncoder' FFMPEG_EXTERNAL_LIBS='/config/Library/Application\ Support/Plex\ Media\ Server/Codecs/798f007-1247-linux-ubuntu-x86_64/' XDG_CACHE_HOME='/config/Library/Application Support/Plex Media Server/Cache/' XDG_DATA_HOME='/usr/lib/plexmediaserver/Resources/' X_PLEX_TOKEN='xxxxxxxxxxxxxxxxxxxx' '/usr/lib/plexmediaserver/Plex Transcoder' '-codec:0' 'h264' '-codec:1' 'eac3_eae' '-eae_prefix:1' '4cvjju66w5cyu20kzbw5pef9_' '-noaccurate_seek' '-i' '/tvshows/...' '-map' '0:0' '-codec:0' 'copy' '-map' '0:1' '-metadata:s:1' 'language=eng' '-codec:1' 'aac' '-ar:1' '48000' '-channel_layout:1' 'stereo' '-b:1' '256k' '-f' 'dash' '-min_seg_duration' '5000000' '-skip_to_segment' '1' '-time_delta' '0.0625' '-manifest_name' 'http://127.0.0.1:32400/video/:/transcode/session/4cvjju66w5cyu20kzbw5pef9/92b1e4e5-bc13-4788-baad-54f8a5502838/manifest' '-avoid_negative_ts' 'disabled' '-map_metadata' '-1' '-map_chapters' '-1' '-movflags' '+faststart' 'dash' '-start_at_zero' '-copyts' '-vsync' 'cfr' '-y' '-nostats' '-loglevel' 'quiet' '-loglevel_plex' 'error' '-progressurl' 'http://127.0.0.1:32400/video/:/transcode/session/4cvjju66w5cyu20kzbw5pef9/92b1e4e5-bc13-4788-baad-54f8a5502838/progress'
ERROR - JobManager: child process returned: 13 (Permission denied)

Which leads me to believe there is a permission error somewhere? I haven't done any configuring on this, even the inotify entry was already present.

running official docker, up to date, pms 1.8.4.4249

Looking in the docker log, I found this...

Sep 17 06:25:01 Tower /USR/SBIN/CRON[5995]: (root) CMD (test -x /usr/sbin/anacron || ( cd / && run-parts --report /etc/cron.daily ))
tail: ‘/var/log/syslog’ has become inaccessible: No such file or directory
tail: ‘/var/log/syslog’ has appeared; following end of new file

I don't know if that is relevant or not.

Oh, system specs ..

UnRaid on Ryzen 5 1600 w/ 16g RAM. PMS and all the dockers are on an SSD cache drive.

Answers

Sign In or Register to comment.