If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Weak Signal

bdhx2bdhx2 Posts: 17Members Plex Pass

Since purchasing my shield and becoming a plex pass member a couple months ago I have had an ongoing issue with a weak signal message when watching live TV. On several occasions the live TV screen freezes and becomes pixelated. I have tested the same channels using the live channels app and the HDhomerun app with no issues. I am currently on the 1.9 beta version and I am using two HDhomerun Connect tuners with the most current firmware. This seems to happen on any OTA channels that I receive. Any ideas on what the issue may be? is there a way to test the channel signal strength within Plex?

«13

Comments

  • JohnnieWalkerPlexServerJohnnieWalkerPlexServer Posts: 13Members ✭✭

    I just downloaded the HDhomerun signal strength app on my android phone and it found my connect tuner instantly and gave me signal strength and quality readings, really easy to use.

    In fact I noticed the SNR quality level was fluctuating alot, so I found that just by moving the aerial cable I was able to greatly improve the SNR quality rating.

  • bdhx2bdhx2 Posts: 17Members Plex Pass

    OK, thanks. I just downloaded that app. While watching a local channel on Plex Live TV the signal strength on the app shows 100%. However, I still get a weak signal message on Plex and the screen freezes from time to time. Watching the same channel on the Live Channels app results in no weak signal messages and no screen freezes. If this was an equipment issue I would think it would happen no matter what program I use to watch TV, which leads me to believe it is something through the Plex Live TV app. I really hope I can figure this out.

  • JohnnieWalkerPlexServerJohnnieWalkerPlexServer Posts: 13Members ✭✭

    Yep, that was pretty much my conclusion, I've given up trying to make Plex Live TV and DVR work on my Nvidia Shield, read my post here: https://forums.plex.tv/discussion/288529/too-many-issues-to-be-a-serious-replacement-for-tivo-etc#latest

  • bdhx2bdhx2 Posts: 17Members Plex Pass

    Just read it and I agree. I will continue to use the shield as a plex server for my movie library but I have just about given up on trying to use the Plex Live TV/DVR. Looks like I will just stick with my Tivo OTA for awhile longer.

  • yooshawyooshaw Posts: 45Members, Plex Pass Plex Pass

    @bdh334@gmail.com said:
    OK, thanks. I just downloaded that app. While watching a local channel on Plex Live TV the signal strength on the app shows 100%. However, I still get a weak signal message on Plex and the screen freezes from time to time. Watching the same channel on the Live Channels app results in no weak signal messages and no screen freezes. If this was an equipment issue I would think it would happen no matter what program I use to watch TV, which leads me to believe it is something through the Plex Live TV app. I really hope I can figure this out.

    What is the quality reading on the app saying? Quality is much more important than the strength reading. A 50% quality reading at 100% strength is still going to give a bad picture.

    But agree though, if Live Channels brings in the picture well, so should PLEX.

  • bdhx2bdhx2 Posts: 17Members Plex Pass

    Quality reading shows 98%

  • kinoCharlinokinoCharlino Posts: 1,427Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee
    edited September 22

    The Live Channels/HdHomeRun apps aren't a good comparison as those pass off the live feed with minimal processing, if any at all. With Plex its going through PMS, recorded for time-shifting, and then transcoded for each respective client device for playback – so a bit more work is going on. Weak signal is a bit of a generic warning. It could mean that the transcoder is being starved if the Shield PMS is running out of resources.

    @bdh334@gmail.com : in reviewing your logs, I see you had 1 recording and 1 live tv session (using Chrome as the player) going simultaneously. That maxes out the 2 tuners of the Connect, but the Shield should be able to handle 2 streams. In your DVR settings, do you have "Convert Video While Recording" set to "Transcode?" If that was off, then the recording would not have been transcoding and only the live tv stream via Chrome would have been transcoding, leaving you with 1 transcode which the Shield should be able to handle. If "transcode" was enabled while recording, then you'd be looking at 2-3 transcodes. It is an experimental feature, so if its on try disabling it, as it's possible the Shield was pushed beyond its capabilities. Another thing to test is to see if on the Shield you still get the weak signal warning when only watching live tv, without the other tuner recording.

    Shield is a solid PMS, but it has more limits than a well-equipped server. It can typically handle 3-4 simultaneous transcodes, though mileage will vary depending on the specifics of the media.

    Search our Knowledge Base for more help

  • kinoCharlinokinoCharlino Posts: 1,427Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    I would also suggest making sure Shield PMS is up-to-date. The last few releases had DVR and transcoder-specific fixes.

    Search our Knowledge Base for more help

  • bdhx2bdhx2 Posts: 17Members Plex Pass

    Thank you for looking into this. I do still get the "weak signal" message when only watching live tv. I also have the transcode option turned off on my hdhomerun connect settings within Plex DVR settings. I am running the most up to date releases on the Shield and Plex Media Server. I am not sure what the logs were showing as recording recently since I have not attempted to record anything in awhile since I have not been able to watch live TV smoothly. I can make sure that only the shield is on live tv and send another log file if you think that would help.

  • kinoCharlinokinoCharlino Posts: 1,427Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @bdh334@gmail.com said:
    I can make sure that only the shield is on live tv and send another log file if you think that would help.

    Yes please, that could prove helpful. Just make sure you get the weak signal warning in that test. Thanks!

    Search our Knowledge Base for more help

  • bdhx2bdhx2 Posts: 17Members Plex Pass

    OK, attached is a new log.

  • Sa_Les_SkiSa_Les_Ski Posts: 26Members, Plex Pass Plex Pass

    I am having this same issue was well. After a minute of watching Live TV on my Shield Pro (coming from PMS on my desktop) I will get a pause and the Weak Signal notification. From then on, I will get intermittent pauses anywhere from 20 seconds later to 2 minutes later, all lasting about 2-3 seconds.

    Quality is still top notch. It doesn't skip either, just pauses. So after 10 minutes of this with 10-15 pauses, I can skip ahead about a minute.

    I don't get this problem via the web, or my Pixel XL. I do however get it on my Shield TV Pro, Android TV Mi Box (a lot) and my 2014 Samsung Note 10.1.

    PC running PMS is only using about 40% RAM on 10% CPU. If I DVR the TV show, and play it after, there is no issue what-so-ever. It is only with Live TV.

    I have also tried the Tuner setting of OFF and TRANSCODE with no difference.

    Any help would be appreciated. This is bothering me quite a bit (and my wife even more, so therefore it's bothering me more ) :wink: Logs attached.

  • MeadorsMeadors Posts: 1Members, Plex Pass Plex Pass

    Having just read through these accounts, I'd only like to share that I'm having the very same issues with "weak signal" using my SiliconDust HD HomeRun device as the tuner. Perfect signal/picture in the HomeRun app is unwatchable via the Plex Live function. Other Plex functions work properly. Is the Live TV function not ready for prime time?

  • kinoCharlinokinoCharlino Posts: 1,427Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @Meadors said:
    Having just read through these accounts, I'd only like to share that I'm having the very same issues with "weak signal" using my SiliconDust HD HomeRun device as the tuner. Perfect signal/picture in the HomeRun app is unwatchable via the Plex Live function. Other Plex functions work properly. Is the Live TV function not ready for prime time?

    Thanks for the report. We are still looking into this. Only certain users are experiencing this with Live TV. We have many users who aren't getting this, including on Shield, so it seems for most it is ready for prime time. Hopefully we will get more info on what's going on with you guys, as this is certainly not ideal. Thanks!

    Search our Knowledge Base for more help

  • bdhx2bdhx2 Posts: 17Members Plex Pass

    Thank you for looking into this. Just some further observation for me anyway...I shut down the plex media server running on my Nvidia Shield and started a plex media server on my PC. With the server running on the PC I have not had any weak signal messages or freezing screens while using the Plex DVR/Live TV features through the Plex app on the Nvidia Shield. So for me it appears the issue is with the media server on the shield or the shield itself.

  • kinoCharlinokinoCharlino Posts: 1,427Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @bdh334@gmail.com said:
    Thank you for looking into this. Just some further observation for me anyway...I shut down the plex media server running on my Nvidia Shield and started a plex media server on my PC. With the server running on the PC I have not had any weak signal messages or freezing screens while using the Plex DVR/Live TV features through the Plex app on the Nvidia Shield. So for me it appears the issue is with the media server on the shield or the shield itself.

    Thanks for the added info. Yes, this is isolated to the Shield. Engineering is working on tracing down what's causing the Shield to run out of resources for PMS, which is essentially what's causing this warning message.

    Search our Knowledge Base for more help

  • bdhx2bdhx2 Posts: 17Members Plex Pass

    Thank you for the update

  • jfpauljfpaul Posts: 16Members, Plex Pass Plex Pass

    I am having the same issue. Whenever weak signal or pause/skipping occurs, the HDHomeRun Signal Meter app shows the "Net Rate" drop to 0 for me. I'm using the HDHomeRun Extend and have tested various transcode configurations in the Shield. 1080i streams seem to be trouble and perhaps others but that's primarily what I've been debugging with. I've tried looking at cpu load on the shield and appears to not be loaded at the time the transcoding problems occur. I'm guessing the PMS thread responsible for capturing the stream is getting starved somewhere and can't keep up? I'm no expert at Android software development so this is total speculation.

    Also, I have a question re: HDHomeRun Extend "Transcode Configuration" setting. It appears that this isn't even looked at by PMS? Could some please confirm? I presume that the settings in Plex override anything set in the Extend configuration because when I chance any of the values it appears to make no difference in video stream bitrate/quality when watching in Plex client.

    I'm using the latest beta PMS, HDHomeRun Extend 20170815 firmware. I'm a beta user and am using PMS 1.9.2.4285. The problems come when I use "Original Format", "Highest Quality, or "High Quality (30fps)" transcode settings.

  • ChewbaccamanChewbaccaman Posts: 14Members, Plex Pass Plex Pass

    Not just limited to the shield. Get the same issue on my firetv 2. Server is from my pc and using a hdhomerun prime. No similiar issue with the hdhomerun app or wmc. Just isolated to Plex. Of course this happens after I move all my series recordings over to Plex.

  • MDLAV8RMDLAV8R Posts: 5Members, Plex Pass Plex Pass

    Another Shield (1st gen) owner (and brand new Plex Pass lifetime member) experiencing same “weak signal” issues described above with Plex live tv. HDHR4 Connect. Latest non-beta PMS. ATV4. 128gb microSD adopted internal storage on Shield. Also have a Channel Master DVR showing 100% signal strength and no pixelation/stuttering at same point where HDHR is connected to antenna with 2-way split. HDHR app is smooth as well. PQ with Plex live tv is beautiful until delay/pixelation pops in every few minutes. No real pattern to its appearance or frequency. Once it happens audio drifts a bit until tapping rewind and then it syncs up again. Happy to send in logs to help.

«13
Sign In or Register to comment.