If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

All Synced Content is Failing to Play

So, within the last couple of weeks, no matter what video I sync to my Surface Pro 4 (Windows 10), I am getting the following error.

MR_MEDIA_ENGINE_ERR_SRC_NOT_SUPPORTED HRESULT - 0xC00D36B2

I have been using this for months very successfully, but all of sudden, this is happening. Also, this is happening on no matter what type of conversion. I have been using original but I have tried 3MBs 720p as well. Also, all of these videos are .mkv files.

Server version is 1.9.2.4285 and it says that is up to date. Also, my Windows 10 app states that it is up to date too (3.2.20-25990c77)
Any help would be greatly appreciated

Answers

  • chaosmakerchaosmaker Posts: 459Members, Plex Pass Plex Pass

    I think it has something to do EAC3 not being recognised as a codec that will run in the app and the server doesn't transcode the audio to an AC3 or AAC track because it doesn't think it needs to. Technically you could try changing the profile and ask it to transcode audio into a different format and it might work then (I haven't tried myself, only had this issue with a couple of files and then I just used VLC to play them)

  • tuvhughestuvhughes Posts: 13Members, Plex Pass Plex Pass
    edited September 26

    Sorry, this didn't work. Also, I really would like a solution where I can stay in Plex and not have to use an external player. Any other thoughts? Also, just to make sure, I copied an actual .mkv file to the Surface and played it with VLC and it played just fine. So it definitely has to do with something within Plex.

  • chaosmakerchaosmaker Posts: 459Members, Plex Pass Plex Pass

    can you post the filemedia info for the file that is not working? I still think it is some audio codec issue. Might be worth trying out some different transcodes adding them to the library and then syncing them over to see whether it still occurs. When you changed the profiles you did restart the plex server right?

  • chaosmakerchaosmaker Posts: 459Members, Plex Pass Plex Pass

    you can also try to add the files in your video folder on your windows computer but it has to be mp4 with aac audio to be picked up by the app if I remember correctly

  • tuvhughestuvhughes Posts: 13Members, Plex Pass Plex Pass

    OK, so only mp4's now? I don't quite understand as this has been working for months. This just stopped working in the last week or two. I have attached the media info for a typical file. It's not one file that this is affecting, it is all files.

    As for the profiles, sorry, I could not find how to change the audio profiles in Plex. I see the different video streams to convert to but no audio. Can you point me in that direction?

  • tuvhughestuvhughes Posts: 13Members, Plex Pass Plex Pass

    Ok, I've done some more digging and i think i have isolated it to the audio, just as you thought. It comes down to files with normal AC-3 5.1 play just fine. But newer files with EAC-3 5.1 don't. I've read some other threads where this seems to be an issue on other platforms too, and the solution is to disable audio passthrough. However, on the Windows 10 app, I don't have any place, that I can find, where you can change the audio stream, or anything for audio for that matter.

  • chaosmakerchaosmaker Posts: 459Members, Plex Pass Plex Pass

    As I said it has to do with EAC3 apparently it is sufficiently different for the app to fail while everything else is happy with using a standard AC3 decoder. If you look here "C:\Program Files (x86)\Plex\Plex Media Server\Resources\Profiles" at least on windows machines, you'll find the profiles plex uses for the different apps/environments. I think the one we are thinking about is the Windows 10 Mobile one - the desktop applies to PMP I think (but I am not sure!!).
    Anyway, I don't think plex server distinguishes AC3 from EAC3 and it seems that transcoding EAC3 to AAC doesn't work either properly (maybe something with the transcoder?!). In any case if you do change something here, it will be reset next time you install plex again. You can put your update version here "C:\Users\YOURUSERNAME\AppData\Local\Plex Media Server\Profiles" and it should load it on start. I've had the same issue but I am not sure how to solve it really...
    Maybe something for the plex server/transcoder people?!

  • tuvhughestuvhughes Posts: 13Members, Plex Pass Plex Pass

    Ok, Plex transcoder people, how about it?

  • andulescuandulescu Posts: 1Members, Plex Pass Plex Pass

    I can confirm that I'm having the exact same problem, files with EAC3 fail to play on a Dockerized Plex install v1.9.3.4290.

    Any ideas? Is this a Plex bug that will be fixed in the next release?

  • chaosmakerchaosmaker Posts: 459Members, Plex Pass Plex Pass

    It is technically not a bug because the windows app can play EAC3 as far as I understand but for some reason the app is not doing so. The fact that the app hasn't been updated in months makes me thing we won't get a better version - plus there are a couple more bugs that need to be squashed... (see my bug list)
    For now you can edit the profile and remove eac3 from the compatibility list in there and it should work...

  • tuvhughestuvhughes Posts: 13Members, Plex Pass Plex Pass

    Is anyone from Plex out there? Why isn't this working?

  • ma3s7r0ma3s7r0 Posts: 10Members, Plex Pass Plex Pass

    Please? That's really annoying. I can't sync files having audio encoded with eac. That really sucka, especially though my windows 10 tablet is able to play eac.

  • chaosmakerchaosmaker Posts: 459Members, Plex Pass Plex Pass

    Check the other threads on "respect the customer" and my bug list (it has those bugs in it already). The only workaround I can think of is changing the transcoding profile in the plex server installation and change AC3 to something different like AAC - that should make it work I believe but I haven't tried yet.

  • graff1337graff1337 Posts: 15Members, Plex Pass Plex Pass

    I can confirm this "bug".

    You can work around this by browsing to the synced content with the File Explorer and play it with a media player of your choice (I use VLC media player). Of course the content will not be marked as watched, but you could do that manually within the Plex client.

    The synced content is stored at: C:\Users\xxx\AppData\Local\Packages\CAF9E577.Plex_aam28m9va5cke\LocalState\SyncStorage\sync\

    Just open the file explorer (WINDOWS + E) and type/copy into the address bar:
    %localappdata%\Packages\CAF9E577.Plex_aam28m9va5cke\LocalState\SyncStorage\sync\

    Depending on the amount of content you have synced it could be hard to find it in this folder structure. The "Date Modified" column of the File Explorer might be a good indicator if you remember when your content was synced.

    Note that the native Windows10 media player (I believe it's called "Films & TV") will also fail to play any item with the same error message, hence use a capable player, e.g. VLC media player.

Sign In or Register to comment.