If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Help ! FreeNas Box With Plex Jails Plugin -Was working OK until upgrade to 1.9.2.4285 - now dead

mikrofaxmikrofax Posts: 8Members, Plex Pass Plex Pass

Hi Guys I was running Plex v1.8.1.4139 with no issues.

I saw the alert there was a new version so I did what I normally do on my FreeNas box.

1.Login to your FreeNAS go to shell in WebGUI
2.type: 'jls' (without ' ' ) and take the note of the # of jail of your Plex installation
3.type: jexec # csh' (where # is the number of the jail noted in last step)
4.type: fetch -o PMS_Updater.sh https://raw.githubusercontent.com/mstinaff/PMS_Updater/master/PMS_Updater.sh
5.type: chmod 755 PMS_Updater.sh
6.type: ./PMS_Updater.sh -u -p -a

I did all that - no issues - I rebooted my FreeNas box

Now my Plex media web interface is unavailable

I have no idea what I did wrong.

Would love some pointers and help. Was there an issue with this distribution ?

Also, please know I am a Windows guy - I have no idea how to use Unix/Linux etc so I need an step by step idiots guide to fix this.

Grateful for any gentle help :)

Tagged:

Best Answer

  • mikrofaxmikrofax Posts: 8Members, Plex Pass Plex Pass
    Accepted Answer

    OK this seems to have fixed it - I had to delete the PlugIn - reinstall - reestablish my File shares and its all working again. Thanks for all the support !

Answers

  • craigmcewencraigmcewen Posts: 8Members, Plex Pass Plex Pass

    Hey!

    Have you been able to get your Plex back up and running yet?
    If not... In the freenas web gui click on Jails and ensure that your Plex Media Server is up and running.
    If not, click start jail at the bottom of the page.
    If it is, Open up a cmd window in windows and ping the IP address assigned to Plex... Any response??
    If no response, try giving your modem a reboot and then restart your Plex jail...

    Let us know how you go

  • mikrofaxmikrofax Posts: 8Members, Plex Pass Plex Pass

    Hi thanks for the tips - Its running and its pinging OK - but its not available thru the web site anymore. Within the FreeNas web interface it says "Click **here **to access your Plex Media Server!" and the **here ** is a link to the following URL http://10.1.10.2:32400/web which always use to work and now it doesn't.

  • craigmcewencraigmcewen Posts: 8Members, Plex Pass Plex Pass

    This could be a slow process, or it could be quick!
    Have you previously configured your PMS for external access? Is it linked to your plex account? As in are you able to see your plex server from an Plex media player on a phone/tv/other pc or if you have Plex Pass can you see it online?
    (trying to narrow the issue down)
    Open your freenas web ui > shell > type in jls
    Is plexmediaserver running?
    If so are you being blocked by your modem/firewalls from the Plex port (32400)?
    If connected, not being blocked... Freenas Web UI > Jails > Double click on your Plex Jail > check or un check the VIMAGE > Save > Restart the jail ... That is best set checked so test both checked and un checked (restarting between attempts) and see if you have any joy there..

    When you check your the port at your modem, just ensure that you can see your plex IP address assigned in the modem "attached devices" section... Also clear out your browser cache / use a different browser as your browser could potentially be blocking you also... But you still should be able to see your PMS using another player whilst connected to your local network...

    See how you go, got a fair bit to keep you busy!

    If your to technical, I could offer to remote in and have a look for you if you wanted to install Team Viewer... But see how you go!

  • mikrofaxmikrofax Posts: 8Members, Plex Pass Plex Pass

    Hi thanks for all those tips - I will work thru these ideas today and revert with responses later today - thanks again :)

  • mikrofaxmikrofax Posts: 8Members, Plex Pass Plex Pass

    **Hi

    OK so I ran thru all these different things and I could not find anything wrong.

    In summary to your questions,
    **

    Have you previously configured your PMS for external access?
    Yes before this failure and it had worked but then disconnected it for external access

    Is it linked to your plex account?
    Yes I have always had a plex pass

    As in are you able to see your plex server from an Plex media player on a phone/tv/other pc or if you have Plex Pass can you see it online?

    Answer is NO to all questions

    (trying to narrow the issue down)
    Open your freenas web ui > shell > type in jls
    Is plexmediaserver running?

    Yes it is running

    If so are you being blocked by your modem/firewalls from the Plex port (32400)?

    No don't think its being blocked - I can ping it and it replies - its also showing on my local network scanner

    If connected, not being blocked... Freenas Web UI > Jails > Double click on your Plex Jail > check or un check the VIMAGE > Save > Restart the jail ... That is best set checked so test both checked and un checked (restarting between attempts) and see if you have any joy there..

    tried it with it checked and unchecked - no difference.

    When you check your the port at your modem, just ensure that you can see your plex IP address assigned in the modem "attached devices" section...

    Yes I can see it

    Also clear out your browser cache / use a different browser as your browser could potentially be blocking you

    tried that - no joy

    also... But you still should be able to see your PMS using another player whilst connected to your local network...

    See how you go, got a fair bit to keep you busy!

    If your to technical, I could offer to remote in and have a look for you if you wanted to install Team Viewer... But see how you go!

    happy to let you have a go ! but the thing to remember here is I didn't change anything on my network except just run the latest update to the latest version - that's when it all stopped working - so I'm wondering if there is something in the build that I downloaded that killed it - to test that theory is it possible to do a 'downgrade' update and go back to the previous build ? If so I have no idea how to do that - thanks for your help - Mike

  • craigmcewencraigmcewen Posts: 8Members, Plex Pass Plex Pass
    via Email
    Hey!
    Not looking too good, I updated to the same version of PMS when it first
    came out and had no issues at all.

    If you want I can remote in and have a look at it with you, its sounding
    like it's gotta be something so minor just being missed....

    If you want me to remote in, download Teamviewer Quick Support at:
    https://download.teamviewer.com/download/TeamViewerQS.exe

    Install the software, when it starts it will display "Your ID" and
    "Password"

    Flick me an email and I'll remote across to you.
    Email address is: craig@youritlink.com.au
  • mikrofaxmikrofax Posts: 8Members, Plex Pass Plex Pass

    Will email you now.

  • craigmcewencraigmcewen Posts: 8Members, Plex Pass Plex Pass
    via Email
    No worries!
  • mikrofaxmikrofax Posts: 8Members, Plex Pass Plex Pass

    OK I was just about to email and I noticed something new. The PlexMedia Service was Offline and would not go back online - this is new - it _was _running - so somehow it turned itself off. It would not go back on. So ... I removed the whole service from my FreeNAS - I had no choice at this point. Reinstalled it and the newly installed service - installed OK and was running AND was available for access via a web browser - so its come back to life. BUT ... now I have a new problem. When trying to add my existing media folders and files back to my new Plex Server its not seeing the folders on the NAS device -All my media folders are under the /mnt folder but none are being listed so I'm wondering if this is a permissions issue. Does the newly installed Plex media server need to have explicit access to the mounted volumes on NAS ? If so I have no idea how to do that. Would that be some sort of access permission thing somewhere ?

  • mikrofaxmikrofax Posts: 8Members, Plex Pass Plex Pass
    Accepted Answer

    OK this seems to have fixed it - I had to delete the PlugIn - reinstall - reestablish my File shares and its all working again. Thanks for all the support !

  • craigmcewencraigmcewen Posts: 8Members, Plex Pass Plex Pass
    via Email
    Awesome! Welcome back to Plex!
Sign In or Register to comment.