If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Is it possible to manually set the audio codec for Chromecast (AAC,AC3)?

The Master ChrisThe Master Chris Posts: 2Members, Plex Pass Plex Pass

Hello

I have two TV sound system at home. One TV is connected to Sonos sound system (Playbar + Play 1) and the other one is connected to a Sony Soundbar. Each TV has a Chromecast.

The different sound systems supports the following audio codecs:

  • The Sony Playbar supports only AAC.
  • The Sonos Playbar supports AC3.

I use for streaming always the Android Plex App. There you can set different streaming quality. The problem is now if I want to stream in 1080p (8 MBit) to the Chromecast with the Sony Playbar, no sound is playing. The reason is the Plex Server convert the audio stream in the auto codec AC3, but the Sony Soundbar does not support this codec. If I stream with 720p (2 MBit), the Plex Server convert the audio stream to the audio codec AAC.

I also tried to change the DLNA profile for the Chromecast, but this has no influence. The reason is the Plex Server loads the Chromecast Augmented profile which is seen in the log file.

Oct 03, 2017 12:45:26.489 [0x7f4019bff700] DEBUG - TranscodeUniversalRequest: using augmented profile Chromecast

INFO - [Chromecast] [MDE] Augmented profile: { "directPlay": { "mp4": { "mimeType": "video/mp4; codecs=\"avc1.42E01E\"", "video": { "codecs": { "h264": {} }, "maxBitDepth": 8, "maxFrameRate": 60, "maxLevel": 42, "maxWidth": 1920, "maxHeight": 1080, "maxBitrate": 8000, "maxVideoResolution": "1080" }, "audio": { "codecs": { "aac": { "maxSamplingRate": 48000, "maxChannels": 2 }, "mp3": {}, "ac3": {} } } }, "mkv": { "mimeType": "video/webm", "video": { "codecs": { "h264": {}, "vp8": {} }, "maxBitDepth": 8, "maxFrameRate": 60, "maxLevel": 42, "maxWidth": 1920, "maxHeight": 1080, "maxBitrate": 8000, "maxVideoResolution": "1080" }, "audio": { "codecs": { "aac": { "maxSamplingRate": 48000, "maxChannels": 2 }, "mp3": {}, "vorbis": { "maxChannels": 2 }, "ac3": {} } } } }, "directStream": { "video": { "codecs": { "h264": {} }, "maxBitDepth": 8, "maxLevel": 42, "maxWidth": 1920, "maxHeight": 1080, "maxBitrate": 8000, "maxVideoResolution": "1080" }, "audio": { "codecs": { "aac": { "maxSamplingRate": 48000, "maxChannels": 2 }, "mp3": {}, "opus": {} }, "maxChannels": 6 } } }

If I stream with 1080p (8 Mbit). The Plex Server does the following decision :

Oct 03, 2017 13:00:47.783 [0x7f4019bff700] DEBUG - Streaming Resource: Reached Decision id=10124 codes=(General=1001,Direct play not available; Conversion OK. Direct Play=3000,App cannot direct play this item. Direct play is disabled. Transcode=1001,Direct play not available; Conversion OK.) media=(id=12534 part=(id=12552 decision=transcode container=mkv protocol=http streams=(Video=(id=25388 decision=transcode bitrate=7246 encoder=libx264 width=1920 height=1080) Audio=(id=25389 decision=transcode bitrate=321 encoder=ac3 channels=6 rate=48000))))

And here you can see, the Plex Server takes the AC3 codec

Audio=(id=25389 decision=transcode bitrate=321 encoder=ac3 channels=6 rate=48000)

If I stream with 720p (2 Mbit). The Plex Server does the following decision :

Oct 03, 2017 12:38:09.757 [0x7f4019bff700] DEBUG - Streaming Resource: Reached Decision id=10124 codes=(General=1001,Direct play not available; Conversion OK. Direct Play=3000,App cannot direct play this item. Direct play is disabled. Transcode=1001,Direct play not available; Conversion OK.) media=(id=12534 part=(id=12552 decision=transcode container=mkv protocol=http streams=(Video=(id=25388 decision=transcode bitrate=1724 encoder=libx264 width=720 height=406) Audio=(id=25389 decision=transcode bitrate=162 encoder=aac channels=2 rate=48000))))

And here you can see, the Plex Server takes the AAC codec

Audio=(id=25389 decision=transcode bitrate=162 encoder=aac channels=2 rate=48000)

My questions are now:

  • Is there a way to set inside the Plex for Android App or in the Plex Sever the audio codec manually?
  • Where is this "Streaming Resource: Reached Decision" made? Can I change this decisions?

Thank you for the help

Regards,

Chris

Answers

  • Jose00Jose00 Posts: 44Members, Plex Pass Plex Pass

    Short answer, you can't natively play AAC as the support for it was dropped (sorry multichannel AAC, 2 channel AAC will still play). http://forums.plex.tv/discussion/216688/plex-for-chromecast#latest . You should try to play around with your profile for Chromecast and see what you can do. You can't do anything with the augmented profile.
    I'm not sure though why you get different audio output depending on what resolution you stream out however. I suspect the 'device' you use to start playing the video (ie Plex for Android?) is overwriting settings as well. Try a different (older) version of the app and see if it improves (ie 5.9.x).

  • The Master ChrisThe Master Chris Posts: 2Members, Plex Pass Plex Pass

    Hi
    Thanks for your answer. I will test it with a older Plex for Android app.

    Regards,

    Chris

Sign In or Register to comment.