Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Jumpy Playback -- Unwatchable

RogersNeighborhoodRogersNeighborhood Members, Plex Pass Posts: 56 Plex Pass

I'm trying to play shows that were recorded over the air, using the HD HomeRun Extend (with hardware transcoding).

  • My PMS is plexmediaserver_1.5.3.3580-4b377d295_amd64 (Debian / Ubuntu)
  • TV: Samsung UN55JU6400 J-series (2015) model
  • Plex App version: 2.008 PMS version 1.5.3580-4b377d295

PMS transcoding is turned off, since they're transcoded by the HD HomeRun extend.

The video files are 1080p resolution:

  • Track ID 0: video (MPEG-4p10/AVC/h.264)
  • Track ID 1: audio (AC-3/E-AC-3)

It is so jumpy that it is unwatchable on the Samsung Smart TV,. Subtitles are garbled, so it seems to be dropping data packets. However, the SAME media files play perfectly fine on an older Vizio smart TV via its Plex app.

Any ideas how to fix this?

Linux Administrator
Raspberry Pi Hobbyist
piforall.com

Tagged:

Answers

  • OrcaOrca Plex for Samsung Developer Members, Plex Pass, Plex Ninja Posts: 7,620 Plex Ninja

    The HD Homerun is transcoding the movies? I 'm not sure I understand what you mean. You really need the server to that.
    Anyway, the videos are probably in a format that the TV can't play reliably in direct play mode.
    The vizio app is an official Plex app, and that mostly play everything through the transcoder.

    BTW, that PMS version is rather old, we are at 1.9.4 for the public version.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • RogersNeighborhoodRogersNeighborhood Members, Plex Pass Posts: 56 Plex Pass

    Yes, the HD HomeRun Extend does the transcoding. That is why I chose that particular model. That allows me to use a low-power server, with PMS transcoding disabled.

    These video files play well on other platforms (web, iOS, Visio). Some even work with the Samsung app, but some are unwatchable (on the Samsung app only).

    You’re correct, I could update my PMS to a newer version. I’ll do that, and will report back here.

    Linux Administrator
    Raspberry Pi Hobbyist
    piforall.com

  • OrcaOrca Plex for Samsung Developer Members, Plex Pass, Plex Ninja Posts: 7,620 Plex Ninja

    I'm sorry but I think you are mistaken.
    The only time the HDHomerun is using transcoding is when Plex is using it to record a video from it (DVR).
    Any other file that needs transcoding will need the PMS to do it.

    (I have the exact same model : HDHR3-4DC)

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • RogersNeighborhoodRogersNeighborhood Members, Plex Pass Posts: 56 Plex Pass
    edited April 1

    I don’t understand what we’re disagreeing about. Yes, you’re correct. The HDHomeRun Extend does the transcoding on the fly, and passes the output to the Plex DVR, which writes the ready-to-play (via “Direct Play”) video files to my storage. I’m clearly not a Plex expert (Plex-pert?) — but I think that’s how it works. Did I miss something? Why is further transcoding needed? The only video files I have come from the Plex DVR, by way of the HDHomeRun Extend.

    Thanks.
    Jack

    Linux Administrator
    Raspberry Pi Hobbyist
    piforall.com

  • CollivaahCollivaah Members, Plex Pass Posts: 35 Plex Pass

    Hi @RogersNeighborhood , your HDHomeRun Extend is transcoding to create the file, tvshow1.mp4. But that is where it ends. It does not do any transcoding further to that.

    When one of your PLEX clients attempts to watch the tvshow1.mp4, they then workout whether they can watch it natively, or require transcode or anything along those lines. The codecs you are referring to are very standard and most devices should be able to "direct play"/"direct stream" it. If they cannot play it natively, the PMS will have to transcode it for the client to watch. HDHomeRun Extend cannot do this, HDHomeRun's transcoding is to create the file, once the file is created, it's out of its hands.

    This is the difference that @Orca is referring to.

    Regardless, update your PMS to 1.9.4 and see if that helps.

    Can you see if the video is transcoding on your Samsung TV? (pressing the Up arrow will bring up the bar, on the right hand side, it will saying "Direct Playing - blah blah" or "Direct Streaming - blah blah" or "Transcoding - blah blah".

    IT System Administrator

    PMS: E3-1240v2, 8GB RAM, Windows
    Clients:
    Samsung Smart Hub UA60JU6400 (x2),
    Samsung Tizen UA40K5500 (x2),
    Chromecast 2 (x3),
    Chromecast Ultra,
    Playstation 3,
    Playstation 4 (x2)

  • OrcaOrca Plex for Samsung Developer Members, Plex Pass, Plex Ninja Posts: 7,620 Plex Ninja

    Ah that's what you mean, you direct play the pre-recorded files.I have no issues with it, but I have a 2014 model.
    Have you tried the "samsung-dance" ?:

    • Unplug the TV from the wallsocket for a minute or two, to clear the TV's cache.
    • Then try again.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • RogersNeighborhoodRogersNeighborhood Members, Plex Pass Posts: 56 Plex Pass

    Thanks for replies, @Orca and @Collivaah.

    My video files are actually .mkv format, And I’m pretty certain that’s what Plex DVR gets from the HDHR. Since I do direct play, no further processing is needed. Yes, Plex shows it is “direct playing” or “direct streaming” or similar.

    I’ll try the “Samsung dance” when I have a chance.

    Thanks.
    Jack

    Linux Administrator
    Raspberry Pi Hobbyist
    piforall.com

  • RogersNeighborhoodRogersNeighborhood Members, Plex Pass Posts: 56 Plex Pass

    Alrighty, here's the update. First, I gave bad info about my Plex Media Server version. I copied that from an old post, but I forgot that I upgraded a day or so after Plex added DVR control to PMS. Nevertheless, I was still behind, so I upgraded to the latest version for my platform: 1.9.4.4325

    I also did the "Samsung dance" -- that is, I left it disconnected for an entire weekend. No luck there, either.

    I tried tweaking the buffering settings, but they only made things worse. I also tried different modes (Direct streaming was a colossal fail).

    The inconsistent things irritate me...
    The jumpy files play fine on other devices (which suggests that the problem is the Samsung TV or the app, not the files).
    There are other files that play fine on the Samsung (which suggests that the problem is the files, not the TV or the app).

    Any other suggestions?

    Linux Administrator
    Raspberry Pi Hobbyist
    piforall.com

  • OrcaOrca Plex for Samsung Developer Members, Plex Pass, Plex Ninja Posts: 7,620 Plex Ninja

    If they play fine on other Plex devices, it's because most official Plex devices use transcoding, or they support that format natively. Just because they are labeled as "mkv" doesn't mean they are within the specs a Samsung TV needs, to be able to play them directly. MKV is just a container. It all depends on which codecs are used to compress the media files, what bitrates are available in the video, etc. I think the AVC codec might be the problem here.
    My guess is that you recorded the videos straight from the HDHomerun and not with the Plex DVR feature.
    Plex DVR records the files as ".ts" files (at least it does that for me) not as mkv. which implies that the conversion is already done by the server during recording.

    So you have three options.

    • Add the HDHomerun to Plex for DVR use and let Plex handle it, if you haven't done so yet. (needs a powerful server)
    • Enable transcoding in the app and have the PMS transcode the file into a playable format. (needs a powerful server)
    • Manually convert the MKV files to something the TV can direct play like h264/AC3

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • RogersNeighborhoodRogersNeighborhood Members, Plex Pass Posts: 56 Plex Pass

    @Orca

    I only record one way, and that’s via Plex. Your assumption that it’s receiving the stream as .mkv should be correct. That’s consistent with what I was told on an HDHomeRun forum. And you’re absolutely correct, .mkv is just a container and it has multiple tracks.

    Letting Plex do my transcoding is not an option, because of the server requirements. I only built this setup after extensive research to confirm that I would not need to do transcoding on the server. It is sized appropriately for the intended use, but not for transcoding.

    What really puzzles me is, why some shows work, but others (in the same TV series) don’t. All are recorded the same way.

    Jack

    Linux Administrator
    Raspberry Pi Hobbyist
    piforall.com

  • bsteele02bsteele02 Members, Plex Pass Posts: 1 Plex Pass

    @Orca - I have the same problem. If I have Plex DVR record using the HDHomerun Extend doing transcoding, playback on my Samsung TV via the plex app is very jumpy. If I disable transcoding during recording which gives me a MPEG2 .ts file rather than a MPEG4 .ts file, it plays back just fine on the TV. There's something going on with direct play of the MPEG4 .ts file on Samsung. It looks fine during fairly still scenes, but as soon as there is any major change in the picture like the camera panning it gets really jumpy.

    @RogersNeighborhood - I suggest you disable transcoding in the tuner configuration on your Plex server and just let it record the native MPEG2 format. It will use more disk space, but it will direct play just fine on your TV without the need for any server side transcoding during playback.

  • OrcaOrca Plex for Samsung Developer Members, Plex Pass, Plex Ninja Posts: 7,620 Plex Ninja

    I'm aware of the issues with the format Plex DVR and Live TV are producing. I reported it already a few times.
    The solution needs to come from the server, not much I can do about it.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • RogersNeighborhoodRogersNeighborhood Members, Plex Pass Posts: 56 Plex Pass

    I just copied one of the shows (.mkv format, MPEG4), to a flash drive and plugged it directly into the TV. This bypasses Plex completely. Playback was exactly the same -- jumpy and unwatchable. So this issue is NOT a Plex issue. It is the TV.

    @bsteele02 - Thanks for the tip, I just now saw your reply. I guess I don't get notifications from this forum.
    I didn't see a way to "disable" it but there was an option for "original format". I'm giving that a try.

    Jack

    Linux Administrator
    Raspberry Pi Hobbyist
    piforall.com

Sign In or Register to comment.