If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Roku Plex Ac3 audio sync issues

phimdo2003phimdo2003 Posts: 2Members

I just got a new Roku Premeire+ and running plex. aac 5.1 and DTS 5.1 works great on it but whenever i try a ac3 5.1, there is about a 3 sec audio sync issue (sound comes firdst before video). These files works fine on plex for Chromecast and Amazon fire stick.

I tried every possible combinations of direct play / directstream options in the roku plex but nothing fixes the issue. I tried changing the audio options on Roku and some options either did not do anything or gave no audio.

Hdmi plugs directly in my receiver Onkyo TX-NR646. Running the latest Plex Media Server on a laptop supporting a 4th gen i5 processor. It can transcode most of everything I throw at it including multiple HEVC streams.

I love the roku in both video quality and processing speed. I also like how it can play DTS without transcoding it. It's just that I have many files with ac3 audio and this is a major issue. I hope there is a simple work around that does not involve changing the audio format to stereo to force a transcode to stereo. I do not mind forcing a transcode from ac3 to aac but do not know how to do it.

Comments

  • JuiceWSAJuiceWSA Posts: 6,437Members ✭✭✭✭✭

    Roku has issues with lips and the sound of the words living in the same zip code.
    Here's hoping Windows 8 for Roku helps - but I have my doubts.

    I was watching a program last night (Direct Play, no less) - lips and words got all out of whack - switched to PMP to finish the program and all was well.

    The best you can hope for at this time is a 'backup plan'.
    Roku has an index finger buried up a nostril to the second knuckle and they're diggin' for gold.

    Tony

    FileBot For Easy Plex File Naming: http://www.filebot.net/

    Automated Plex Naming With Filebot: https://forums.plex.tv/discussion/191687/plex-naming-schemes-for-filebot

    Plex Friendly Handbrake Guide - DVDs/BluRays: https://forums.plex.tv/discussion/comment/1335697/#Comment_1335697

    Plex Clients: AFTVs, Androids, PMP, Rokus (running RARflix: http://mkvxstream.blogspot.com/2014/09/roku-plex-setup-guide.html ) Link May Work - May Not

  • nagle3092nagle3092 Posts: 70Members, Plex Pass Plex Pass

    @phimdo2003 said:
    I just got a new Roku Premeire+ and running plex. aac 5.1 and DTS 5.1 works great on it but whenever i try a ac3 5.1, there is about a 3 sec audio sync issue (sound comes firdst before video). These files works fine on plex for Chromecast and Amazon fire stick.

    I tried every possible combinations of direct play / directstream options in the roku plex but nothing fixes the issue. I tried changing the audio options on Roku and some options either did not do anything or gave no audio.

    Hdmi plugs directly in my receiver Onkyo TX-NR646. Running the latest Plex Media Server on a laptop supporting a 4th gen i5 processor. It can transcode most of everything I throw at it including multiple HEVC streams.

    I love the roku in both video quality and processing speed. I also like how it can play DTS without transcoding it. It's just that I have many files with ac3 audio and this is a major issue. I hope there is a simple work around that does not involve changing the audio format to stereo to force a transcode to stereo. I do not mind forcing a transcode from ac3 to aac but do not know how to do it.

    Same issue here, works fine in emby for roku for me though so my guess is the plex app.

  • phimdo2003phimdo2003 Posts: 2Members

    I figured it out. It may not be a perminant fix up when it acts up, unplug it for about 10 sec and plug it back it. Everything including ac3 works again for a few days before it get off sync again. Unplug again to temporarily fix issue. Not perfect but I can live with that

Sign In or Register to comment.