If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Can't see my server under Network in Windows

Hi!
I'm really new to this world of servers; I've managed to run my own server to access all of my multimedia content with an Ubuntu Server 14.04 and Samba.
When I started my server, everything was Ok, and, from a Windows machine (with W7), could transfer files because the Server appeared in my PC in Network/Computer, now the Server is in Media Devices and it opens in Windows Media Player.
I have also a Mac, and from there I can connect to the server directly, so... I suppose that the problem is in my Windows machine.
I would be really happy if someone can help me!
Thanks in advance.

Tagged:

Best Answers

Answers

  • orizagaostiorizagaosti Posts: 6Members ✭✭

    @OttoKerner said:
    No need to faff around with Windows settings.
    If your SMB server is missing in the network neighbourhood, simply go up to the address bar of Windows file explorer.
    put your mouse pointer in it and type 2 backslashes \\, followed by either the local IP address of your SMB server or the SMB host name.
    e.g. \\192.168.2.34 + hit Enter

    Afterwards you can create a shortcut to this host and or its file shares

    Thank you!! You are a Genius!

  • orizagaostiorizagaosti Posts: 6Members ✭✭
    edited October 12

    @trumpy81 said:
    You are correct, the issue is with your Win 7 machine (Microsoft messed with SMB in Windows), but it can be tricky to get things working again as some fixes work and others don't.

    The only thing I can suggest is to disable the Master Browser on the Win7 machine. To do that, open 'Services' and then disable the 'Computer Browser' service. Reboot the the modem/router and everything connected to it, including any wireless devices.

    Fingers crossed, your Linux machine will once again appear in Windows Explorer > Network.

    If that does not help, then use Google to search 'can't see my NAS windows 7' and follow the advise given for a NAS, it is the same for your Linux machine as most NAS use Linux.

    Thanks! I tried first OttoKerner's solution, because was easier… and that solved the problem.
    Although, thank you for your answer and the confirmation that the problem was with the W machine.

Sign In or Register to comment.