If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

tvOS/iOS: Forced subtitles are not shown (without transcoding)

HanterdroHanterdro Posts: 54Members, Plex Pass Plex Pass
edited October 12 in Apple TV

I recognized yesterday that the Plex App of tvOS and iOS no longer shows forced subtitles.

My files are all MP4s with SRT subtitles.

If I play the same file on macOS with Quicktime or on tvOS via the Computer app the forces subtitles are shown.

Selecting in the tvOS player other non forced subtitles works (even without transcoding :-) ). Only if the subtitle mode is "automatic" where the forced subtitles should appear is not working.
Selecting the forced subtitle in the Plex splash screen of the movie before I start the movie has also no effect.

A few month ago this worked since years... Must be an update from the last months.

On tvOS 10 and 11 forced subtitle are broken. Must be a Plex issue.

Some Subler screenshots of a movie with forced subtitles:

https://imgur.com/a/98DCf
https://imgur.com/a/tndT8

Answers

  • ersanersan Posts: 25Members, Plex Pass Plex Pass

    Leaving the subtitles setting automatic doesn't show forced subtitles for me (I would assume that qualifies as a bug by itself), but if I select them in the splash screen before I play it they do work.

  • HanterdroHanterdro Posts: 54Members, Plex Pass Plex Pass

    Selecting them in the splash screen (before starting the video) doesn't work for me.

    But I recognized a few minutes ago, when I switch from automatic to none oder an other subtitle and than back to automatic the forced subtitles works again. At least until I restart the movie.
    This is no solution, it's more a workaround for this annoying problem.

    Let's hope that the Plex developers read this and working on a bugfix.

Sign In or Register to comment.