If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Music periodically fails to start playing even when it's synced

GuyGizmoGuyGizmo Posts: 86Members, Plex Pass Plex Pass

This is a fairly annoying bug I'm encountering on more or less a daily basis. I'll open my music library and select a track to play, and Plex will set there with the "spinning" animation as though it can't load it. This also happens for tracks that are synced to my phone. I have "Prefer synced content" enabled in the app's settings.

If I force quit Plex using the iOS task manager and relaunch it, it will successfully play the track afterwards.

I've attached a log that I saved immediately after the last time I experienced this bug. My actions right before saving the log were:

  1. Open Plex on my iPhone
  2. It connects to my media library using LTE
  3. Select a track from my music library that is synced to my phone
  4. Waited a few seconds as Plex played the spinning animation
  5. Stopped playback
  6. Tried playing the track again
  7. Waited a few seconds as Plex played the spinning animation
  8. Saved the log file
Tagged:

Answers

  • GuyGizmoGuyGizmo Posts: 86Members, Plex Pass Plex Pass

    I did a complete reset and restore of my iPhone in the hopes it would squash this bug (and perhaps a few others), but to no avail -- I still often encounter this bug. Here's another log from the last time it happened.

  • rsfisherrsfisher Posts: 2Members, Plex Pass Plex Pass

    I'm having a very similar problem that seems to happen when I transition from WiFi to cellular networks. If I'm at work listening to music over WiFi and leave my office to get in my car, it starts the spinning animation when I try to play it in my car over cellular. And this is for items that are synced to my iPhone.

  • str3ssstr3ss Posts: 28Members, Plex Pass Plex Pass

    Seeing something similar here.

    Here's the tail end of my log files from when this is happening.

    Nov 11, 2017 19:07:43.081 [0x70000020a000] DEBUG - Client [84DE3E57-E2F7-42C2-9BAD-051DDB4A5927] reporting timeline state playing, progress of 38957/278256ms for guid=, ratingKey=1402307 url=, key=/library/metadata/1402307, containerKey=, metadataId=1402307
    Nov 11, 2017 19:07:43.081 [0x70000020a000] DEBUG - [Now] User is str3ss (ID: 1)
    Nov 11, 2017 19:07:43.081 [0x70000020a000] DEBUG - [Now] Device is iOS (R2P6).
    Nov 11, 2017 19:07:43.081 [0x70000020a000] DEBUG - [Now] Profile is iOS
    Nov 11, 2017 19:07:43.081 [0x70000020a000] DEBUG - [Now] Updated play state for /library/metadata/1402307.
    Nov 11, 2017 19:07:43.083 [0x70000020a000] DEBUG - Statistics: (84DE3E57-E2F7-42C2-9BAD-051DDB4A5927) Reporting active playback in state 0 of type 10 (scrobble: 0) for account 1
    Nov 11, 2017 19:07:43.086 [0x700000429000] DEBUG - Completed: [::ffff:166.172.63.161:50766] 200 GET /:/timeline?bufferedTime=4&duration=278256&key=%2Flibrary%2Fmetadata%2F1402307&location=cellular&playQueueItemID=55356&ratingKey=1402307&state=playing&time=38957&timeStalled=52 (16 live) TLS GZIP 6ms 465 bytes (pipelined: 1)
    Nov 11, 2017 19:07:47.558 [0x7000003a6000] DEBUG - Auth: authenticated user 1 as str3ss
    Nov 11, 2017 19:07:47.558 [0x700000b53000] DEBUG - Request: [::ffff:166.172.63.161:28309 (WAN)] GET /:/timeline?bufferedTime=0&duration=278256&key=%2Flibrary%2Fmetadata%2F1402307&location=cellular&playQueueItemID=55356&ratingKey=1402307&state=buffering&time=43870 (17 live) TLS GZIP Signed-in Token (str3ss)
    Nov 11, 2017 19:07:47.559 [0x700000b53000] DEBUG - Client [84DE3E57-E2F7-42C2-9BAD-051DDB4A5927] reporting timeline state buffering, progress of 43870/278256ms for guid=, ratingKey=1402307 url=, key=/library/metadata/1402307, containerKey=, metadataId=1402307
    Nov 11, 2017 19:07:47.559 [0x700000b53000] DEBUG - [Now] User is str3ss (ID: 1)
    Nov 11, 2017 19:07:47.560 [0x700000b53000] DEBUG - [Now] Device is iOS (R2P6).
    Nov 11, 2017 19:07:47.560 [0x700000b53000] DEBUG - [Now] Profile is iOS
    Nov 11, 2017 19:07:47.560 [0x700000b53000] DEBUG - [Now] Updated play state for /library/metadata/1402307.
    Nov 11, 2017 19:07:47.561 [0x700000b53000] DEBUG - Statistics: (84DE3E57-E2F7-42C2-9BAD-051DDB4A5927) Reporting active playback in state 2 of type 10 (scrobble: 0) for account 1
    Nov 11, 2017 19:07:47.568 [0x7000003a6000] DEBUG - Completed: [::ffff:166.172.63.161:28309] 200 GET /:/timeline?bufferedTime=0&duration=278256&key=%2Flibrary%2Fmetadata%2F1402307&location=cellular&playQueueItemID=55356&ratingKey=1402307&state=buffering&time=43870 (16 live) TLS GZIP 9ms 465 bytes (pipelined: 1)
    Nov 11, 2017 19:07:48.892 [0x7000003a6000] DEBUG - Auth: authenticated user 1 as str3ss
    Nov 11, 2017 19:07:48.893 [0x700000b53000] DEBUG - Request: [::ffff:127.0.0.1:50353 (Loopback)] GET /diagnostics/logs (17 live) GZIP Signed-in Token (str3ss)
    Nov 11, 2017 19:07:48.893 [0x700000b53000] DEBUG - Diagnostics: Building logfile zip
    Nov 11, 2017 19:07:56.296 [0x7000003a6000] DEBUG - Auth: authenticated user 1 as str3ss
    Nov 11, 2017 19:07:56.297 [0x700000c59000] DEBUG - Request: [::ffff:127.0.0.1:50354 (Loopback)] GET /diagnostics/logs (17 live) GZIP Signed-in Token (str3ss)
    Nov 11, 2017 19:07:56.297 [0x700000c59000] DEBUG - Diagnostics: Building logfile zip
    
Sign In or Register to comment.