If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plexconnect not working with Plex Server version 1.9.4

FreakNLFreakNL Posts: 158Members, Plex Pass Plex Pass

Anyone else facing issues with videos not playing while using Plex Server version 1.9.4 (or 1.9.5)?

Had to downgrade to 1.9.2 to get things working again.

Some videos do work, most of them don't. Error message on ATV = "An error occurred loading this content."

«1

Comments

  • Cleaner_2000Cleaner_2000 Posts: 139Members, Plex Pass Plex Pass

    Same issue here. I downgrade to server version 1.9.2 to fix the problem.

  • Cleaner_2000Cleaner_2000 Posts: 139Members, Plex Pass Plex Pass

    Is there still a specialist who could take the matter?

  • foyrerfoyrer Posts: 2Members, Plex Pass Plex Pass

    Same issue.
    Plexconnect works fine with version 1.9.3.4290.
    On 1.9.4.4325 I get the same error message on ATV "An error occurred loading this content."
    There is not a single error log entry in the plexconnect log.

    But there are following log entries in the PMS debug log:

    Oct 15, 2017 11:01:52.401 [0xb0bffb40] DEBUG - Auth: authenticated user 1 as xxxxx
    Oct 15, 2017 11:01:52.401 [0xb0bffb40] DEBUG - Auth: Came in with a super-token, authorization succeeded.
    Oct 15, 2017 11:01:52.401 [0xad7ffb40] DEBUG - Request: [192.168.1.1:49307 (Subnet)] GET /:/timeline?ratingKey=5773&key=/library/metadata/5773&duration=4489840&state=stopped&time=-1 (9 live) TLS GZIP Signed-in Token (xxxxx)
    Oct 15, 2017 11:01:52.402 [0xad7ffb40] DEBUG - Client [DY3M47HMFF54] reporting timeline state stopped, progress of -1/4489840ms for guid=, ratingKey=5773 url=, key=/library/metadata/5773, containerKey=, metadataId=5773
    Oct 15, 2017 11:01:52.402 [0xad7ffb40] DEBUG - [Now] User is xxxxx (ID: 1)
    Oct 15, 2017 11:01:52.402 [0xad7ffb40] DEBUG - [Now] Device is (ATV).
    Oct 15, 2017 11:01:52.402 [0xad7ffb40] DEBUG - [Now] Profile is iOS
    Oct 15, 2017 11:01:52.402 [0xad7ffb40] DEBUG - [Now] Updated play state for /library/metadata/5773.
    Oct 15, 2017 11:01:52.402 [0xad7ffb40] DEBUG - Statistics: (DY3M47HMFF54) Reporting active playback in state 3 of type 4 (scrobble: 0) for account 1
    Oct 15, 2017 11:01:52.402 [0xad7ffb40] DEBUG - Streaming Resource: Terminating session 0xa7912e54:DY3M47HMFF54 which is using transcoder slot. Used slots is now 0
    Oct 15, 2017 11:01:52.402 [0xad7ffb40] DEBUG - Streaming Resource: Terminated session 0xa7912e54:DY3M47HMFF54 with reason Client stopped playback.
    Oct 15, 2017 11:01:52.402 [0xad7ffb40] DEBUG - Streaming Resource: Removing session 0xa7912e54:DY3M47HMFF54
    Oct 15, 2017 11:01:52.402 [0x923ffb40] DEBUG - Killing job.
    Oct 15, 2017 11:01:52.402 [0x923ffb40] DEBUG - Signalling job ID 14758 with 9
    Oct 15, 2017 11:01:52.403 [0x923ffb40] DEBUG - Job was already killed, not killing again.

    Oct 15, 2017 11:01:52.403 [0x923ffb40] DEBUG - Stopping transcode session DY3M47HMFF54

  • moody_bluemoody_blue Posts: 3,034Members, Plex Pass, Plex Ninja Plex Ninja

    I do not have any problems so far (PlexConnect 0.5-dev-230417 and PMS 1.9.5). Can you please post a film sample so that I can test on my side ?

    QNAP TS-253A 4G QTS 4.3.4.0435 + PMS 1.11.0.4666 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

  • NeedlephoenixNeedlephoenix Posts: 46Members, Plex Pass Plex Pass
    edited October 2017

    Same issue here, had to downgrade to https://downloads.plex.tv/plex-media-server/1.9.3.4290-9798172d4/Plex-Media-Server-1.9.3.4290-9798172d4.exe - triple checked 1.9.5 Plex Pass still has issues.

  • Cleaner_2000Cleaner_2000 Posts: 139Members, Plex Pass Plex Pass

    @moody_blue said:
    I do not have any problems so far (PlexConnect 0.5-dev-230417 and PMS 1.9.5). Can you please post a film sample so that I can test on my side ?

    Where should I upload the sample file?

  • FreakNLFreakNL Posts: 158Members, Plex Pass Plex Pass

    Just in case , cleaner_2000;

    Did you verify that your sample file Did not play either?

    Maybe you can upload it to Some free web space provider?

  • moody_bluemoody_blue Posts: 3,034Members, Plex Pass, Plex Ninja Plex Ninja
    edited October 2017

    @Cleaner_2000 Thanks for the sample. I was able to reproduce the problem. Your film has AC3-6ch audio tracks. PMS should transcode them to AAC-2ch when Dolby Digital=Off in ATV Settings. I think that we have a PMS bug that I will report, but in the meantime we have a problem with PlexConnect.

    Note: I was not aware of the problem because I use AC3-6ch a lot, my amplifier accepts it, therefore I have Dolby Digital=On, but as soon as I've switched it to off I've got the problem. And setting it to On is no solution for you, audio will be mute unless you have a Dolby capable amplifier.

    A temporary solution (not acceptable in the long term) is to optimize for TV, this will convert the audio track from AC3 to AAC.

    QNAP TS-253A 4G QTS 4.3.4.0435 + PMS 1.11.0.4666 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

  • Cleaner_2000Cleaner_2000 Posts: 139Members, Plex Pass Plex Pass

    @moody_blue said:
    A temporary solution (not acceptable in the long term) is to optimize for TV, this will convert the audio track from AC3 to AAC.

    What does that mean, can I change the settings of my ATV3?

  • moody_bluemoody_blue Posts: 3,034Members, Plex Pass, Plex Ninja Plex Ninja

    Found the problem. The iOS profile always had this line <Setting name="HlsExtraMultiChannelAudioStream" value="ac3" /> but PMS was ignoring it. It means that AC3 can be streamed to iOS devices (including ATV3).

    So the best temporary solution would be to remove that line from the iOS profile (iOS.xml file).

    QNAP TS-253A 4G QTS 4.3.4.0435 + PMS 1.11.0.4666 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

  • moody_bluemoody_blue Posts: 3,034Members, Plex Pass, Plex Ninja Plex Ninja
    edited October 2017

    @Cleaner_2000 said:
    What does that mean, can I change the settings of my ATV3?

    The ATV3 can pass the AC3 stream to its HDMI and optical ports, but cannot convert AC3 to AAC. If you have an AC3 capable TV (or an AC3 capable amplifier), they will play AC3 audio (2ch or 6ch). Otherwise you will have no sound.

    To avoid this, I have developed (it's in the last PlexConnect version in the iBaa repository) a new ATV parameter, called Dolby Digital, whose default is Off, that used to force PMS to transcode any AC3 stream to AAC. That is the intended behaviour. And users willing to benefit from AC3 can turn it to On.

    But this new line in the iOS profile <Setting name="HlsExtraMultiChannelAudioStream" value="ac3" negates what I have developed. My hopes are that the ATV3 is the same generation of the iPad4, and Plex had to solve a similar problem in the iPad4. I will interlock with the developer to know when this fix will be available, and will try to test if it will solve the ATV3 problem, otherwise I will have to think on a solution.

    The fact is, who has AC3 capable players wants 6ch sound when available. And the other users want to play sound even when there are no AAC tracks in the film. So we need to have both options when using the same profile.

    QNAP TS-253A 4G QTS 4.3.4.0435 + PMS 1.11.0.4666 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

  • Cleaner_2000Cleaner_2000 Posts: 139Members, Plex Pass Plex Pass

    Thanks for your explanation. Would not it be better for the future to adapt Plexconnect?

  • moody_bluemoody_blue Posts: 3,034Members, Plex Pass, Plex Ninja Plex Ninja

    Frankly I would prefer to convince Plex to allow us to have our own profile so that we are less "vulnerable" to changes in the iOS.xml profile.

    QNAP TS-253A 4G QTS 4.3.4.0435 + PMS 1.11.0.4666 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

  • Cleaner_2000Cleaner_2000 Posts: 139Members, Plex Pass Plex Pass

    @moody_blue said:
    Frankly I would prefer to convince Plex to allow us to have our own profile so that we are less "vulnerable" to changes in the iOS.xml profile.

    Thats a good idea!!!

  • Cleaner_2000Cleaner_2000 Posts: 139Members, Plex Pass Plex Pass

    With a modified ios.xml it runs again under serverversion 1.9.4.4325. Many thanks to @moody_blue.

  • moody_bluemoody_blue Posts: 3,034Members, Plex Pass, Plex Ninja Plex Ninja
    edited October 2017

    Changing the profile will work, yes. But I have prepared a new version of PlexAPI.py, can you please test it with the standard iOS profile ? It works in my case. Just replace the existing PlexAPI.py file and restart PlexConnect.

    QNAP TS-253A 4G QTS 4.3.4.0435 + PMS 1.11.0.4666 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

  • Cleaner_2000Cleaner_2000 Posts: 139Members, Plex Pass Plex Pass

    In this way everything works as it should.

  • moody_bluemoody_blue Posts: 3,034Members, Plex Pass, Plex Ninja Plex Ninja
    edited October 2017

    Thanks. Now the challenge is to convince @roidy to apply it to github because I have no author access to iBaa/PlexConnect, it may take a while. I've already contacted him.

    QNAP TS-253A 4G QTS 4.3.4.0435 + PMS 1.11.0.4666 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

  • moody_bluemoody_blue Posts: 3,034Members, Plex Pass, Plex Ninja Plex Ninja

    Thanks to @roidy the fix has been applied to https://github.com/iBaa/PlexConnect

    QNAP TS-253A 4G QTS 4.3.4.0435 + PMS 1.11.0.4666 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

  • FreakNLFreakNL Posts: 158Members, Plex Pass Plex Pass

    Awesome!

    Will test tommorow, but I dont expect any issues :)

    Thx guys!

«1
Sign In or Register to comment.