If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Roku2 issue and workaround

jwrayjwray Posts: 1,268Members, Plex Pass Plex Pass
The Roku2 has a known issue that results in videos not playing.

Here are some work around binaries.

For Mac replace (or set aside) the binary in ~/Library/Application Support/Plex/Plex Media Server.app/Contents/MacOS with

http://www.plexapp.com/elan/pms-roku2-workaround.zip

For windows, here is the replacement binary. Sorry, I'm not a windows user so I don't know where it goes exactly. Can a knowledgeable windows user please add to the thread with the location?

http://www.plexapp.com/elan/pms-roku2-win32.zip

See original thread for more details.

http://forums.plexapp.com/index.php/topic/28292-roku-2/

Jonny
«1

Comments

  • hozedheadhozedhead Posts: 238Members ✭✭
    C:\Program Files\Plex\Plex Media Server in Windows XP

    PMS 0.9.6.9 Windows XP SP3
    Roku N1000 Software v3.1 Build 1167

  • mh58mh58 Posts: 9Members, Plex Pass Plex Pass
    So, still no Linux/Ubuntu fix available?

    PMS on Ubuntu 14.04 and Synology DS1513+
    Roku 2050x and 3050x, Vizio P-Series

  • CatintonCatinton Posts: 11Members Plex Pass
    Under Application Support their was no Plex folder or Plex app. I went ahead and went under applications and did show contents and found the folder archive that way and copied it in their but still no luck for me just starts to load a video and stops. I also coppied the Plex app so it would match up with your file path and of course closed plex and re-opened but no luck. Any ideas this program looks really cool but doesn't work for me at all right now really.
  • jwrayjwray Posts: 1,268Members, Plex Pass Plex Pass
    jtizzle07 wrote:

    Under Application Support their was no Plex folder or Plex app. I went ahead and went under applications and did show contents and found the folder archive that way and copied it in their but still no luck for me just starts to load a video and stops. I also coppied the Plex app so it would match up with your file path and of course closed plex and re-opened but no luck. Any ideas this program looks really cool but doesn't work for me at all right now really.


    You are looking in the wrong application support folder. It's the one under your home directory, which is what ~ means, not the one on the root of the drive.

    Jonny
  • CatintonCatinton Posts: 11Members Plex Pass
    Jonny Wray wrote:

    You are looking in the wrong application support folder. It's the one under your home directory, which is what ~ means, not the one on the root of the drive.

    Jonny


    Thanks that worked!
  • DianogaDianoga Posts: 26Members, Plex Pass Plex Pass
    Any updates on a Linux workaround?
  • jwrayjwray Posts: 1,268Members, Plex Pass Plex Pass
    There are a lot of Linux builds. Which specific versions are people interested in?
  • stormeriderstormerider Posts: 759Members, Plex Pass Plex Pass
    I'm interested in the Ubuntu build... I run x64 if there's a build specific to that, though I think they're all 32-bit builds at the moment.
    Former member of the Plex for Roku development team

    Units Owned: Roku 1 XD, Roku 2 XS

    watched-fanart.jpg
  • CatintonCatinton Posts: 11Members Plex Pass
    Don't know if this is in the right thread or not but the fix you had me do is working. But I have noticed that when watching stuff it takes it forever to load then every so often it will do it again. Very annoying because it can take up to a couple of min for it to load. I have the quality set to auto don't know if this makes a difference or not.
  • friedflixfriedflix Posts: 2,013Members, Plex Pass Plex Pass
    jtizzle07 wrote:

    Don't know if this is in the right thread or not but the fix you had me do is working. But I have noticed that when watching stuff it takes it forever to load then every so often it will do it again. Very annoying because it can take up to a couple of min for it to load. I have the quality set to auto don't know if this makes a difference or not.


    Could you post your setup so folks could try to help? This fix works flawlessly for me, load times are almost instant, playback is smooth. I have a Roku2 connected by ethernet back to a switch. My PMS is running on a Mac Mini C2D running the latest Plex build and the workaround on Snow Leopard.
  • DianogaDianoga Posts: 26Members, Plex Pass Plex Pass
    Jonny Wray wrote:

    There are a lot of Linux builds. Which specific versions are people interested in?


    I am also interested in the Ubuntu build
  • jwrayjwray Posts: 1,268Members, Plex Pass Plex Pass
    jtizzle07 wrote:

    Don't know if this is in the right thread or not but the fix you had me do is working. But I have noticed that when watching stuff it takes it forever to load then every so often it will do it again. Very annoying because it can take up to a couple of min for it to load. I have the quality set to auto don't know if this makes a difference or not.


    As cfriedberg says, without more details this is impossible to troubleshoot, as there are lots of variables here. Taking a while to load is usually an indicator of transcoding, but a couple of minutes is on the high side.

    Have you tried different quality settings to see if it makes a difference, much better way of finding out that me guessing.

    What's your set up (PMS platform, wireless, etc), what's the media format you are having issues with, subtitles or not?

    Jonny
  • steveransfordsteveransford Posts: 2Members
    For many of us, who aren't "geeks", taking the time to give full directions (for example, what is the "binary" file I am looking for) would be most helpful.



    Jonny Wray wrote:


    The Roku2 has a known issue that results in videos not playing.

    Here are some work around binaries.

    For Mac replace (or set aside) the binary in ~/Library/Application Support/Plex/Plex Media Server.app/Contents/MacOS with

    http://www.plexapp.com/elan/pms-roku2-workaround.zip

    For windows, here is the replacement binary. Sorry, I'm not a windows user so I don't know where it goes exactly. Can a knowledgeable windows user please add to the thread with the location?

    http://www.plexapp.com/elan/pms-roku2-win32.zip

    See original thread for more details.

    http://forums.plexapp.com/index.php/topic/28292-roku-2/

    Jonny
  • jcostomjcostom Posts: 4Members, Plex Pass Plex Pass
    Jonny Wray wrote:

    There are a lot of Linux builds. Which specific versions are people interested in?


    I'd be interested in a fix for the "official" Ubuntu builds from Plex's repo:

    deb http://www.plexapp.com/repo lucid main

    (straight from my /etc/apt/sources.list)

    The current package from that repo is 0.9.3.5ubuntu1
  • sikofittsikofitt Posts: 3Members
    So no ubuntu/linux fix?
  • Just4FunJust4Fun Posts: 1Members
    Another request for the Ubuntu (11.04, 64 bit) fix.

    Thank you for an excellent product.
  • rickdabate@outlook.comrickdabate@outlook.com Posts: 64Members, Plex Pass Plex Pass
    My first time setting up the PMS, I got this issue of "No Video Playing". However, my issue happens on both the Roku2 and the Roku HD. Once I replaced this binary, the Roku2 works, but not the RokuHD.

    Any idea why?
  • jwrayjwray Posts: 1,268Members, Plex Pass Plex Pass
    Rick D. wrote:

    My first time setting up the PMS, I got this issue of "No Video Playing". However, my issue happens on both the Roku2 and the Roku HD. Once I replaced this binary, the Roku2 works, but not the RokuHD.

    Any idea why?


    Are you on wireless? Have you set the quality to 2mb or less?

    Jonny
  • ChronoStriker1ChronoStriker1 Posts: 36Members, Plex Pass Plex Pass
    Request work around for Unraid/Slackware version
  • rickdabate@outlook.comrickdabate@outlook.com Posts: 64Members, Plex Pass Plex Pass
    Jonny Wray wrote:

    Are you on wireless? Have you set the quality to 2mb or less?

    Jonny


    How do you do that? I keep seeing suggestions for this. Do you do this on the server or through the client?
«1
Sign In or Register to comment.