Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

iOS App remote to QNAP connection works on 3G/4G but not on wifi

AdHimselfAdHimself Posts: 8Members ✭✭
edited November 2017 in iOS

Hi Guys,

I've asked this question before, then when it randomly worked I came back to let the forum know; but then it stopped again.

I have a QNAP running PMS via a static IP, the router is forwarding port 32500 to the QNAP IP to 32400.
I am able to access remotely via PWA with no problems at all and it shows I have a working remote connection.

I've checked the QNAP jumbo frames are correct and added an exception on the QNAP itself to recognise the ports.

I have no idea what's going on... but I can sometimes connect via the iOS app and most other times not. The annoying thing is I can invite my friend to access my library and he can access it with no problem. I've tried inviting myself via a different account and I have the same intermittent connection.

I've tried adding a pin and having no pin, resetting my qnap, stopping and starting the app again on qnap, reinstalling on qnap, reinstalling the app on my phone, resetting it's cache, resetting up port forwarding, changing the external port, logging out and back in, restarting my phone and I can't figure out why it's not working on only my phone if I have full access to the library on PWA. I thought it was because I signed up to the iOS beta, but so did my friend and he has no issues.

So I'm not sure what's going on, if anyone can lend a hand I'd really appreciate it. I'm ripping my hair out.


  • AdHimselfAdHimself Posts: 8Members ✭✭

    OK, so after further testing I've found out that I can access my Plex media server remotely via 3G and 4G with no issues at all, but as soon as I switch to my works, library, college wifi it immediately doesn't connect.

    So what am I doing wrong? Any help would be greatly appreciated!

  • sergiou87sergiou87 Plex for iOS Developer SpainPosts: 726Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Can you make it not work with your wifi, then switch to 3G/4G to make it work, and immediately after share your client logs with me? (here or in a private message)

    Instructions: https://support.plex.tv/hc/en-us/articles/201636593-iOS-Logs

  • AdHimselfAdHimself Posts: 8Members ✭✭
    edited November 2017

    Thanks for getting back to me. I'm able to access my media server on my own wifi without any problems, it's only when I try to connect remotely. So I'll recreate the issues when I'm at work on their wifi in a couple of days and post the log.

  • AdHimselfAdHimself Posts: 8Members ✭✭

    Hi Sergiou87, I'll PM you the log zip.

  • AdHimselfAdHimself Posts: 8Members ✭✭

    After some digging and some help with from Sergiou87 I've managed to narrow it down.

    The reason I can't connect to PMS on my QNAP via iPhone is that it doesn't connect properly. As far as I can tell, all ports are correctly specified, forwarded and open all going to the correct IP addresses.

    However, I have some QNAP iOS apps that I can use that points to my media. They don't work right away but after some attempts to reconnect to my external IP, they work, then as soon as they are able to connect PMS works and the iOS Plex app is able to connect.

    So the question is, why is this happening?

Sign In or Register to comment.