If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

2.009 Audio Selection Issue

Since upgrading the client app to version 2.009 the audio selection does not work anymore.

Independent of the audio selection always the first audio track within the MKV container is used. The issue seems to be related to the Samsung client as on other clients (Android, Web/Browser) the selection works as expected.

My settings are:
Hardware: BD-H6500 (2014 modell)
Client: 2.009
PMS: 1.9.4.4325-1bf24oa65 running on a QNAP NAS

Answers

  • WeBo69WeBo69 Posts: 3Members ✭✭

    New insights:
    The problem only occurs with "auto" and "direct play".
    The audio selection works when using "direct streaming" or "transcoding".

  • chaosmakerchaosmaker Posts: 417Members, Plex Pass Plex Pass

    I have noticed that too but didn't have another file to test. Had to manually change the audio by using the green button (at least that works for me)

  • chadnohchadnoh Posts: 8Members ✭✭
    edited November 9

    Same issue on my TV... very very annoying, unable to select the language, or correct subtitles. To bypass I found the same workaround than you I use the direct streaming option or transcoding. But performance really bad on my side.
    So with auto or direct play that issue appears, @Orca are you awared about that ?


    Samsung TV UE48H6400
    Philips Bluray BDP5700
    Amplifier Yamaha RXV-477
    NAS Synology DS415+

  • chaosmakerchaosmaker Posts: 417Members, Plex Pass Plex Pass

    Tried using the green button during playback to change it? Does that work?

  • chadnohchadnoh Posts: 8Members ✭✭

    No when you try do that the input for audio is set to "unknow" and the subtitles are locked to 1/1 (however more are present), and set on which subtitles selected before you launch the movie/file.
    This doen't appears for each movie/file, just for some kind of .mkv files, and no issue with other players (Ios, android, web...).
    Following 3 mkv files details, the first without issue and the other with... maybe it's linked with AC3 audio format.




    Samsung TV UE48H6400
    Philips Bluray BDP5700
    Amplifier Yamaha RXV-477
    NAS Synology DS415+

  • OrcaOrca Plex for Samsung Developer Posts: 7,382Members, Plex Pass, Plex Ninja Plex Ninja

    I checked it and the audio selection is working fine, as far as I can see.
    (the audio output switching (DTS/DD/PCM) is still broken though in 2.009)

    I can see why the app would have issues with these videos.

    What kind of subtitles are subt , those are not supported.
    Also your TV doesn't support DTS HD or the A52 codec.

    The only way (possibly) to play these files is with transcoding.
    (which is what the other players do by default, that's why they work)

    I would advise to use more normalized settings (MKV, H264, DTS/AC3, SRT/ASS) when you rip files.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • chaosmakerchaosmaker Posts: 417Members, Plex Pass Plex Pass

    @Orca However what I noticed is that if you have 2 languages in your mkv, and you have, lets say french as the first, regardless of what I set in the app it'll play the french. I can then switch it to english using the green button? Have you seen that happen in your tests?

  • OrcaOrca Plex for Samsung Developer Posts: 7,382Members, Plex Pass, Plex Ninja Plex Ninja

    I can't reproduce that. I have a movie with 3 different language tracks.
    If I select the they will keep that setting and play the correct language.

    You can check if the app is able to update the server correctly by doing this:

    • Open the video in Plex web and check what track is currently selected.
    • Open the video on the TV app and make a change to the audio track.
    • Now refresh the webpage by going back and then re-selecting the video.
    • The track should now show the change you made in the app.

    If that's not the case you might have an issue with some firewall that is blocking inbound requests to your server.
    Also check if maybe the track labeled as language X is actually recorded in language X.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • WeBo69WeBo69 Posts: 3Members ✭✭

    @chaosmaker, @orca :

    Audio track selection using the green button works for me too but only if the first track was chosen in the app.
    If the second track was chosen then I can't change the audio track in "Audio and Subtitle Settings" menu.

    Interestingly in both cases "Audio unknown" is displayed in the "Audio and Subtitle Settings" menu. In the first case, I can change "unknown" to any of the two available audio tracks and the spoken language changes immediately. In the second case, no selection is available at all.

    I don't know if it is of any relevance for this problem but I recently have also updated the firmware of my BD-H6500 to version 1113.

  • OrcaOrca Plex for Samsung Developer Posts: 7,382Members, Plex Pass, Plex Ninja Plex Ninja

    Thanks for explaining what you did, I could reproduce the problem that way.
    When the second stream was selected. I could not always select the first track any more.
    The track two and three still worked fine. Weird, because I can see in the log, the actions work correctly.
    I'll see if I can figure it out.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • OrcaOrca Plex for Samsung Developer Posts: 7,382Members, Plex Pass, Plex Ninja Plex Ninja

    Looks like it's a timing issue. The Samsung API is firing the "stream is ready" event before it does have all tracks loaded.
    If I wait half a second before changing the tracks, the problem is gone. The problem doesn't occur on the first track, because it's already the correct one and no changing is needed when starting playback.

    Have you checked if your answer might be in the User Manual?
    My Samsung environment:

    2010 BD-C5500 Blu-Ray,
    2011 UE46D7000 LED-TV,

    2012 BD-ES6000 Blu-Ray,

    2014 UE55HU8500L UHD LED TV

    If you enjoy this free app, you can buy me a beer by making a Donation

  • chadnohchadnoh Posts: 8Members ✭✭

    Hi @Orca,

    Thanks for the invest, and thanks to @WeBo69 for help, it always hard to explain an issue.
    I hope you will be able to patch that issue in next release, on my side I use "direct streaming" or "transcoding" to bypass. Or I use the mobile or web client to stream on chromecast.


    Samsung TV UE48H6400
    Philips Bluray BDP5700
    Amplifier Yamaha RXV-477
    NAS Synology DS415+

Sign In or Register to comment.