If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Thomson 49UC6406 not playing videos

addamkaaddamka Posts: 9Members, Plex Pass Plex Pass

Yesterday we bought a Thomson 49UC6406 UHD TV.
Its running Android TV 6.0.1
I installed the latest version from plex app (6.7.1.2498), successfully connected to my debian based PMS (1.9.6.4401).

When i try to play any video, i got a black screen only. With forward/backward i can see the actual frame.
After that the sound completely muted on the TV, and i must reboot it.

Long time ago i noticed some similar issue when playing movies on my phone (Xiaomi Redmi Pro), but after i setup the audio its worked.

Logs attached from PMS and from the TV.

Kodi + Plex addon working, so i can use my TV with plex, but i want to stay with the official app.

Tagged:

Answers

  • Corpo666Corpo666 Posts: 11Members ✭✭

    Hi,

    I've a 65UC6406, which uses the same firmware as yours (and a lot of other Thomson & TCL devices, like C7006/C7026 series) and I have a similar problem.

    As soon as I use direct play (no transcoding), there's no playback : player is stuck on a fixed frame. If I ask plek to transcode, it works. The only stuff that I have which works in direct play is SD with Mp3 audio ...

    Strange stuff is that the same files play fine with VLC

  • addamkaaddamka Posts: 9Members, Plex Pass Plex Pass

    @Corpo666 said:
    Hi,

    I've a 65UC6406, which uses the same firmware as yours (and a lot of other Thomson & TCL devices, like C7006/C7026 series) and I have a similar problem.

    As soon as I use direct play (no transcoding), there's no playback : player is stuck on a fixed frame. If I ask plek to transcode, it works. The only stuff that I have which works in direct play is SD with Mp3 audio ...

    Strange stuff is that the same files play fine with VLC

    On another topic i uploaded some ABD debugging log to the devs, maybe they can see some interesting info in it.

    I try to conntact Thomson (tcl) on their official site, but the contact form broken, so no message sent...
    Maybe i try tcl.eu next time.

    I see Android 7 feature promo in TCL-s twitter, so maybe we can get an update soon.

  • Corpo666Corpo666 Posts: 11Members ✭✭

    @addamka said:

    On another topic i uploaded some ABD debugging log to the devs, maybe they can see some interesting info in it.

    I try to conntact Thomson (tcl) on their official site, but the contact form broken, so no message sent...
    Maybe i try tcl.eu next time.

    I see Android 7 feature promo in TCL-s twitter, so maybe we can get an update soon.

    Thanks for the news. I don't know if it's a TCL or a Plex issue ... hope the android tv 7 update will solve that but I'm unsure, as it seems previous version of the plex app worked fine

    Did some tests meanwhile:

    • Kodi with plex plugin : direct play without troubles, even 4k works (tv is switching to hdr mode), but kodi keeps saying the tv resolution is 1080p so I'm unsure this is really displayed in 4k mode
    • Plex Android casting on the tv : direct play works fine, a bit of suttering, no 4k available
  • Corpo666Corpo666 Posts: 11Members ✭✭

    @addamka according to the french TCL facebook page, the android tv 7 update, originally scheduled for the end of october, is now due before the end of november.

  • Corpo666Corpo666 Posts: 11Members ✭✭
    edited December 2017

    @addamka , I managed to get the android TV v7 update (via polish forums)
    Now Plex is correctly playing video without transcoding (but is now trancoding the audio, complaining the hardware doesn't support DTS, go figure, I'm in audio passthrough mode and sure my receiver is okay with DTS)
    Unfortunately, Plex app also updated after upgrading to v7 so I don't know which action fixed the problem

    Which release of the TCL/Thomson software are you on ? v143 on their website is quite old. There's v173 from october and now the android 7 version is v315. Unfortunately, those upgrade are not OTA so they wipe the tv

  • addamkaaddamka Posts: 9Members, Plex Pass Plex Pass

    @Corpo666 said:
    @addamka , I managed to get the android TV v7 update (via polish forums)
    Now Plex is correctly playing video without transcoding (but is now trancoding the audio, complaining the hardware doesn't support DTS, go figure, I'm in audio passthrough mode and sure my receiver is okay with DTS)
    Unfortunately, Plex app also updated after upgrading to v7 so I don't know which action fixed the problem

    Which release of the TCL/Thomson software are you on ? v143 on their website is quite old. There's v173 from october and now the android 7 version is v315. Unfortunately, those upgrade are not OTA so they wipe the tv

    Wipe is not a big deal, can you give me some info where can i download v315?
    Thanks!

  • Corpo666Corpo666 Posts: 11Members ✭✭

    @addamka the update file is here : https://drive.google.com/file/d/1Y5bP_2G9Q-HavTyfcz1FaUeUCbWOIrdv/view

    Put this file on an empty FAT32 usb key, rename it Update.pkg (capital U is mandatory), plug the key in the usb 2.0 service port (not the 3.0 port). Switch off the TV completely (disable quick start or press power util you get the menu to switch off android). Turn it back on using the middle button under the led signal under the TV and maintain the button pressed until you the update starts (you should see the Thomson logo 2 times before). Release the button and wait approx. 10 minutes.

    I advise you not to update now, wait a few days and check system updates. Another french Thomson owner got the update yesterday, and his update seems a lite bit different. I asked him the build he got, and I'm waiting for his answer.

  • addamkaaddamka Posts: 9Members, Plex Pass Plex Pass

    Thanks, yesterday i found it on the polish site, and successfully installed the update.
    Plex works because the encoding (now i have green line on the bottom bug if hw encoding is enabled, but i think its media server + intel gfx driver related).

  • Corpo666Corpo666 Posts: 11Members ✭✭

    Do you have the same problem as I do regarding DTS ? I can only play without transcoding AC3 and MP3

  • Artem_LozinskyArtem_Lozinsky Posts: 2Members, Plex Pass Plex Pass

    Have almost same issue with my TCL. Dear @addamka, could you please share link to polish site with new update 'cause I find only v143 on site? Thank you in advance&

  • Corpo666Corpo666 Posts: 11Members ✭✭

    @Artem_Lozinsky said:
    Have almost same issue with my TCL. Dear @addamka, could you please share link to polish site with new update 'cause I find only v143 on site? Thank you in advance&

    Look at my post just here : https://forums.plex.tv/discussion/comment/1570514/#Comment_1570514
    You got the link and the instructions to perform the update.

Sign In or Register to comment.