If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Player identification?

AndyGR42AndyGR42 Posts: 6Members

Hey,

I'm looking for technical details how the player can be identified by the server. Is there anything else then IP and/or name? Is there something like a unique ID?

I'm trying to solve this problem: https://forums.plex.tv/discussion/294910/multiple-simultaneous-streaming-running-stream-stops-when-a-second-stream-starts

A cloned ID within the RasPlex image may be the answer for this issue.

TY

Answers

  • videotecaCNSUvideotecaCNSU Posts: 311Validating, Plex Pass Plex Pass
    edited November 15

    The error you are getting its because you are cloning the install. You can fix it by doing a soft reset.

    The cloned ID you are looking its inside /.plexht/userdata/guisettings.xml more precisely in line 281 under uid and 397 under uuid

    You can also edit line 353 that gives the network name

    if you edit it manually you can avoid that error but you are really better with a soft reset on most cases

  • AndyGR42AndyGR42 Posts: 6Members

    Thank you for support. But a soft reset don't fix the problem. It changes the UUID but not the UID. I've changed the UID manually, but the problem persists.

  • videotecaCNSUvideotecaCNSU Posts: 311Validating, Plex Pass Plex Pass

    but you are restoring a backup?

  • AndyGR42AndyGR42 Posts: 6Members

    No. I've installed both Pi's from the scratch with the latest RasPlex Image. After the first boot I've soft reset one of the them. The UUID was changed but not the UID. Then I've changed the UID manually. Then I signed in with both Pi's into Plex. The first, running player still stops if I start the second one.

  • videotecaCNSUvideotecaCNSU Posts: 311Validating, Plex Pass Plex Pass

    You are doing something strange. I have 20+ cloned image players and after handling those ids i dong have that problem

  • videotecaCNSUvideotecaCNSU Posts: 311Validating, Plex Pass Plex Pass

    Paste both guisettings so I can have a look

  • AndyGR42AndyGR42 Posts: 6Members

    Ok, I've removed the players from my profile, hard reset both, changed only the device name but nothing else and signed them in again. The UUID is different but the UID was reset to the default "10946050". I've updated the server to version 1.9.6.4429. Server is still running on my W10 computer.

    After some wired issues like "Error creating play queue, server was unable to create play queue" or "Playback Error The server "X Plex" does not have a valid connection for casting. Check that the server is claimed in server settings" I figured out that it is bad idea to use the browser for control casting on the same machine like the server is running.

    After I got everything up and running the initial problem still remains.

    • It only happens if a RasPlex player starts a new cast
    • It only effects other RasPlex players
    • Other players then RasPlex are continuing like expected
    • There is no difference between server plattforms. I've tested it with a Plex server running on a QNAP NAS with the same results.
    • I've tested up to 5 simultaneous casts to exclude performance issues

    I've compared the guisettings.xml and the only different lines are 352 (devicename), 395 (uuid) and 477/478 (some skin settings). I've added both files.

Sign In or Register to comment.