If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Consistent Shaka3016 errors

smw204smw204 Posts: 5Members, Plex Pass Plex Pass
edited November 2017 in Plex Web App

Hello,

I have recent started getting a lot of Shaka 3016 errors. Its popping on multiple PCs, across Chrome, Firefox, and Edge. I thought it might be my main PC, but the secondary PC is getting the error as well, and a few friends are getting it via remote access. Is there any way to find out where the error is coming from? A PC restart was resolving it temporarily for a while, but its getting worse, and seems to be much more consistent now.

Any ideas would be very welcome!

Thanks!

Tagged:

Answers

  • smw204smw204 Posts: 5Members, Plex Pass Plex Pass

    So far I have tried removing all plug ins, clearing cache, reinstalling Plex, then reinstalled Windows and restored my server as well. Its still ongoing. Anyone have any ideas?

  • smw204smw204 Posts: 5Members, Plex Pass Plex Pass

    Another note: It does not matter if Direct Play, Direct Stream, or Hardware encoding are enable or disabled. Any config on or off, and I still get errors.

  • ChrisHollowayChrisHolloway Posts: 4Members, Plex Pass Plex Pass

    I'm getting the same issue recently, only in the last few weeks. Sometimes after 5 minutes, sometimes after an hour.

  • TheutusTheutus Posts: 1Members, Plex Pass Plex Pass

    I just started getting these errors as well. I haven't changed anything so i'm assuming this is an issue with a Plex update?

  • tknueventknueven Posts: 4Members, Plex Pass Plex Pass

    I'm having the same issues when trying to play *.wma extensions. Is anyone's issue similar?

  • TruckFanTruckFan Posts: 51Members, Plex Pass Plex Pass

    Yes, happening here too. I have posted elsewhere in this "Plex Web Apps" of the issue. Would be nice to hear some official confirmation from Dev's.

  • Dom CDom C Plex Employee Posts: 998Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    It does not matter if Direct Play, Direct Stream, or Hardware encoding are enable or disabled. Any config on or off, and I still get errors.

    That is an interesting datapoint. We've only seen this issue when Direct Streaming previously.

    Please can you provide some media that is showing this issue and any PMS logs during playback?

  • hanson-plexhanson-plex Posts: 6Members ✭✭

    This is happening in Win 10 Pro x64 with the MS Edge and Firefox browsers. Chrome works fine.

  • dasmokedogdasmokedog Posts: 1Members, Plex Pass Plex Pass

    One thing to check is if this is caused by the latest Windows 10 upgrade (Fall Creators edition I think). After the OS was upgraded I immediately noticed that VMConnect, which I use to connect to my Hyper V VMs, was crashing every 5-20min. The event log showed the following error: msmpeg2vdec.dll_unloaded crash vmconnect.

    I only mention this because it turns out that when the OS is upgraded all the codec settings get reverted. What I did to resolve that issue was to disable the MS codec. Once that was done I did not experience a single crash of VMConnect. It also worth noting that I have not had the Plex issue you are having and my PMS is running on the same server that had the OS upgrade. Since I fixed the issue with the codec before I watched a video in PMS I cannot say if I had the same issue as you. Does Plex use the MS codecs of the server it is installed on? I do not know. It may be a long shot but something to look at.

    BTW I used the Codec Tweak Tool (http://www.thewindowsclub.com/codec-tweak-tool) to disable the codec. I ticked the first 4 check boxes on the MS Codecs page (in the app click the button in the bottom right to get there)

    Here is the MS patch (which did not resolve my issue): https://answers.microsoft.com/en-us/windows/forum/windows_10-update-winpc/applications-using-directshow-crash-after-windows/4028270b-f434-4d82-b9ff-c621d367ce0d?auth=1

    Hope it helps

  • Dom CDom C Plex Employee Posts: 998Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    It would be really helpful if you provide video samples and logs for when this is occurring. Thanks!

  • dujaduja Posts: 1Members, Plex Pass Plex Pass

    @hanson-plex said:
    This is happening in Win 10 Pro x64 with the MS Edge and Firefox browsers. Chrome works fine.

    For me it's the other way around. Works on FIrefox and Edge, it doesn't work on Chrome which is my default browser. I am sick of Plex issues, every day it's something new. If I didn't pay for Plex Pass I would never use it again.

  • chris41gchris41g Posts: 5Members ✭✭
    edited January 12

    this is happening to me on 9/10 videos. they play fine from a roku device. from any browser they buffer for a minute then pop a shaka3015 or shaka3016 error. from the xbox one app they buffer for around 4 to 5 minutes then will play without sound.

    edit: Android app also plays them, as well as plex media player from a remote pc, but locally on the server it will not.

  • Jackald1918Jackald1918 Posts: 4Members, Plex Pass Plex Pass

    I have also recently started getting a lot of Shaka 3016 errors popping on multiple PCs. Look at the container and it only seem to affect avi. file extensions. Converted the file to mp4. and the video plays smoothly.

  • bazanimebazanime Posts: 1Members, Plex Pass Plex Pass

    I'm getting the shaka3016 (Media) error when streaming to my Xbox One. I havent changed any setting apart from the recent plex update.

Sign In or Register to comment.