If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Amazon Echo does not play music tracks to end

2

Answers

  • munzymunzy Posts: 5Members, Plex Pass Plex Pass

    Same issue here. Software Version on Echo v2: 592452720. Plex version: 1.10.1.4561 (Premium).

    I'd really love this to work as intended.

  • gtphgtph Posts: 8Members ✭✭

    I upgraded to the latest plex version and it's still occurring. Alexa sw is newer too.

    Plex sw ver 1.10.0.4523
    Amazon Echo Plus sw ver 595479920

  • dcarrcodcarrco Posts: 3Members

    hey folks! is anyone from Plex reading this thread anymore or should i start a new one. i just set up Plex today, had it working with my Amazon Dot and Alexa, loaded my local library and voila! it worked. sadly, my enthusiasm was short lived because i am having the same problem. im getting these messages:

    Dec 14, 2017 14:19:33.750 [0x7feeb47f9700] DEBUG - Request: [192.168.1.1:45902 (Subnet)] GET /music/:/transcode/universal/session/a2880af2-cb46-4138-b34b-b0510a44c3b5/base/00341.ts (4 live) TLS Signed-in Dec 14, 2017 14:19:33.753 [0x7feecaffe700] DEBUG - Completed: [192.168.1.1:45902] 404 GET /music/:/transcode/universal/session/a2880af2-cb46-4138-b34b-b0510a44c3b5/base/00341.ts (4 live) TLS 2ms 288 bytes (pipelined: 15) Dec 14, 2017 14:19:36.909 [0x7feec37fb700] DEBUG - Streaming Resource: Timing out session 0x7feeb0215de0:dfpn6imazhss18dl36tem8e4 Dec 14, 2017 14:19:36.909 [0x7feec37fb700] DEBUG - Streaming Resource: Terminated session 0x7feeb0215de0:dfpn6imazhss18dl36tem8e4 with reason Client stopped playback. Dec 14, 2017 14:19:36.909 [0x7feec37fb700] DEBUG - Streaming Resource: Removing session 0x7feeb0215de0:dfpn6imazhss18dl36tem8e4
    and that is that. i can tell Alexa to PLAY again and it will start over the song. i can also SKIP and that works. but stops soon, usually by the song end, sometimes it makes it to the next song. any ideas?

  • gtphgtph Posts: 8Members ✭✭

    I upgraded to the latest plex version and it's still occurring. Alexa sw is newer too. When are you planning to fix this?

    Plex sw ver 1.10.1.4602
    Amazon Echo Plus sw ver 595530420

  • skopskop Posts: 6Members, Plex Pass Plex Pass

    Count me in as well...same issue as everyone else here. Latest version. Help!

  • mbanks850mbanks850 Posts: 3Members

    I am experiencing a similar issue. Server is running on Windows 10 using the latest software. It is a brand new Amazon Echo (2nd gen) . The two songs I tried played 30s then stopped. When I said "Alexa, resume" it finished the song, but did not play the next one in the album.

  • TrinityMaTrinityMa Posts: 21Members ✭✭

    Basic same problem i posted pic and logs here still no answer to why this happens.
    https://forums.plex.tv/discussion/299801/alexa-echo-music-playback-issues#latest

  • Still no resolution to this? Alexa says ok playing music by.... then silence.Is it really that hard to have music play from one device to another these days?? It seems many are having the same problem. You advertise that this works, but for who exactly?

  • otiswotisw Posts: 3Members, Plex Pass Plex Pass

    Today I learned about the ability to play to Amazon Echo devices from Plex. I found that asking plex to play an audio file does not work on the second generation Echo Dots. It does work on the original Echo Dot and original (big) Echo and Amazon Tap. Possibly this is a firmware issue with second generation Echo systems.

    Note that I have 3 of the second generation Dots that will not play, although it accepts the command and responds as if it will play the music. No audio comes out after the response, nor does the server activity show something is playing (both of these work find on the original Echos).

  • gtphgtph Posts: 8Members ✭✭

    @otisw said:
    Today I learned about the ability to play to Amazon Echo devices from Plex. I found that asking plex to play an audio file does not work on the second generation Echo Dots. It does work on the original Echo Dot and original (big) Echo and Amazon Tap. Possibly this is a firmware issue with second generation Echo systems.

    Note that I have 3 of the second generation Dots that will not play, although it accepts the command and responds as if it will play the music. No audio comes out after the response, nor does the server activity show something is playing (both of these work find on the original Echos).

    Hi Otis,

    They issue is not limited to just Echo Dot second generation. I also have an Echo Plus and it behaves in the same way.

    I can play music on both from Amazon Music, so, whatever the problem is, I believe is related to Plex Server, Plex Skill for Alexa, or both.

  • ANTH040ANTH040 Posts: 4Members ✭✭

    I have the exho plus version songs are just cutting out on me also can say next but then stops half way through.

  • mamvcivmmamvcivm Posts: 24Members, Plex Pass Plex Pass

    Another voice - I too am having this problem. Brand new 2nd gen. Echo, Plex server on a Synology NAS. Plays about a minute of a song then stops, have to say Alexa, tell Plex to play x to get it to play again, but it stops again after about a minute.

  • tdoulltdoull Posts: 49Members, Plex Pass Plex Pass

    I'm having a similar problem. On my brand new Echo dot playback works for some tracks, but stops for others. If you wait about 10 seconds or so the playback continues. On my brand new Echo I just stops and never resumes. I can skip to the next track on both devices and playback will start for the next track, but then stops after a short while. It's very frustrating.

  • tro1999tro1999 Posts: 2Members, Plex Pass Plex Pass

    Have there been any updates? In limited testing over the last week it >seems< to be working correctly now...

  • Plan9Plan9 Posts: 6Members ✭✭

    Got my echo yesterday and it’s doing the same thing. Server is up to date, and i assume the echo is.

  • Same problem here. I set up the Amazon Echo 2 and Plex yesterday (25 Dec 2017) and I could play music from the Plex server fine. Today all tracks stop after about 30s. I restarted everything but no change. Plex server 1.10.1.4602 (fedora), Echo 595530420. The most annoying thing is that it was OK yesterday, I will try to remember all the changes I made since then.

  • ice_burg333@yahoo.comice_burg333@yahoo.com Posts: 10Members ✭✭

    I'm having the same problem. Playback is acknowledged and then it's silent.

  • Geoff555Geoff555 Posts: 64Members, Plex Pass Plex Pass

    Suddenly playback is working! Playing tracks to the end and continuing on to the next track.

    Strangely no updates seem to have occurred since yesterday.

    I have been scratching my head as to what has changed as it was not working yesterday. The only thing I can think of is that last night I inadvertently left the Echo on overnight (I had been switching it off when I went to bed).

    I know my Plex server (which I leave on overnight) carries out various administrative tasks during this period. Is it possible that in doing these tasks it somehow fixed the issue between itself and the Echo?

  • coldfire84coldfire84 Posts: 6Members, Plex Pass Plex Pass

    So I think there are two issues here:
    1. Silence after the Echo/ Alexa states it is playing music (when using the Echo itself as the Plex client)
    2. Songs stopping part-way through (when using the Echo itself as the Plex client)


    I managed to fix #1 by:

    • Changing my Plex Server Remote Access Settings to use port 32400 externally, via the "Manually specify public port" setting, helps. (Note if you also do this you will have to manually configure a Port Forward rule on your router)
    • Changing my "NAT Loopback" setting in my Asus router from "Merlin" to "Asus," (this is unlikely to fix this for everyone considering that everyone will not have an Asus router with Merlin firmware installed)

    Issue #2 persists though, in that the music will start but will just stop after a period of circa 60 seconds. Tested against PMS Docker v1.11.0.4633 and a vCurrent Generation 2 Echo device.

  • gtphgtph Posts: 8Members ✭✭

    @Geoff555 said:
    Suddenly playback is working! Playing tracks to the end and continuing on to the next track.

    Strangely no updates seem to have occurred since yesterday.

    I have been scratching my head as to what has changed as it was not working yesterday. The only thing I can think of is that last night I inadvertently left the Echo on overnight (I had been switching it off when I went to bed).

    I know my Plex server (which I leave on overnight) carries out various administrative tasks during this period. Is it possible that in doing these tasks it somehow fixed the issue between itself and the Echo?

    I believe it's also related with short vs long songs. When it's something about 2-3 minutes, it works for me but as soon as I try something longer, it stops after some time.

    Try playing any Dream Theater song and you will see.

2
Sign In or Register to comment.